ar71xx: add ew-balin platform from Embedded Wireless
authorCatrinel Catrinescu <cc@80211.de>
Wed, 19 Jul 2017 10:44:56 +0000 (12:44 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 12 Dec 2017 11:46:04 +0000 (12:46 +0100)
Add the Embedded Wireless Balin platform, based on AR9344

Signed-off-by: Catrinel Catrinescu <cc@80211.de>
12 files changed:
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-ew-balin.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/generic.mk

index 7cf4212ac76d9d66a6d6aa459b5fd00b9f469603..21fec2249aeb1c86b3b91eb183feed41339ab639 100755 (executable)
@@ -366,6 +366,11 @@ ar71xx_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan"
                ;;
+       ew-balin)
+               ucidef_set_interface_raw "usb2" "usb0" "static"
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "5:lan:4" "4:lan:5" "3:wan"
+               ;;
        ew-dorin)
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:lan" "2:lan" "3:wan"
index 6cbb3576d8f4675041ba4de70f9e5c787a6b93d6..ca73d5f62bc0ad01db20795d860f29c7d8584a58 100644 (file)
@@ -193,6 +193,9 @@ get_status_led() {
        el-mini)
                status_led="easylink:green:system"
                ;;
+       ew-balin)
+               status_led="balin:green:status"
+               ;;
        ew-dorin|\
        ew-dorin-router)
                status_led="dorin:green:status"
index 29fdde40a0b9f780757f51dd25f372d65cfb335c..898082f552f2edf0fc5bc4f87d5a53f0f2b844b7 100644 (file)
@@ -53,6 +53,7 @@ dir-615-e1|\
 dir-615-e4|\
 dir-825-c1|\
 ebr-2310-c1|\
+ew-balin|\
 ew-dorin|\
 ew-dorin-router|\
 ja76pf|\
index 285fa68357c76330d78bedf88448cff099fcd68a..4df2b83b77f577373b6687dd388ac2560202fbe7 100755 (executable)
@@ -640,6 +640,9 @@ ar71xx_board_detect() {
        *"EL-MINI")
                name="el-mini"
                ;;
+       *EmbWir-Balin)
+               name="ew-balin"
+               ;;
        *"EmbWir-Dorin")
                name="ew-dorin"
                ;;
index e3c48c9eefe34b6ce4ad9da81abe8242eeaa92b9..a505c804f3620a3742e1661fe4a7be76744828a5 100755 (executable)
@@ -237,6 +237,7 @@ platform_check_image() {
        epg5000|\
        esr1750|\
        esr900|\
+       ew-balin|\
        ew-dorin|\
        ew-dorin-router|\
        gl-ar150|\
index 3ba3853720753fef45d6abaf6ee990f1f72ed12d..1a108456d886c6efd1aecbf49431d164d97584bf 100644 (file)
@@ -109,6 +109,7 @@ CONFIG_ATH79_MACH_ENS202EXT=y
 CONFIG_ATH79_MACH_EPG5000=y
 CONFIG_ATH79_MACH_ESR1750=y
 CONFIG_ATH79_MACH_ESR900=y
+CONFIG_ATH79_MACH_EW_BALIN=y
 CONFIG_ATH79_MACH_EW_DORIN=y
 CONFIG_ATH79_MACH_F9K1115V2=y
 CONFIG_ATH79_MACH_FRITZ300E=y
index 1d47246bf36b15487b1575a44e8f2d7ff3a95406..2161c7fe521225cae0d64c75a9df694e4450db01 100644 (file)
@@ -108,6 +108,7 @@ CONFIG_ATH79_MACH_EPG5000=y
 CONFIG_ATH79_MACH_ESR1750=y
 CONFIG_ATH79_MACH_ESR900=y
 CONFIG_ATH79_MACH_EW_DORIN=y
+CONFIG_ATH79_MACH_EW_BALIN=y
 CONFIG_ATH79_MACH_F9K1115V2=y
 CONFIG_ATH79_MACH_FRITZ300E=y
 CONFIG_ATH79_MACH_GL_AR150=y
index 1198fcb74bd15b630f01b5573bc3c50e81fa60e5..79b8f2500e43fd5145814fd0cf423f5a7d295a70 100644 (file)
@@ -702,6 +702,20 @@ config ATH79_MACH_ESR900
        select ATH79_DEV_WMAC
        select ATH79_NVRAM
 
+config ATH79_MACH_EW_BALIN
+       bool "embedded wireless Balin Platform support"
+       select SOC_AR934X
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_WMAC
+       select ATH79_DEV_ETH
+       select ATH79_DEV_USB
+       select ATH79_DEV_AP9X_PCI if PCI
+       help
+         Say 'Y' here if you want your kernel to support the
+         Balin Platform from www.80211.de .
+
 config ATH79_MACH_EW_DORIN
        bool "embedded wireless Dorin Platform support"
        select SOC_AR933X
index 455af762e334f8fee59ed286b8fb9e8159c919a7..bde1b753085b2b50cec61d28669bf06bda9ffde8 100644 (file)
@@ -115,6 +115,7 @@ obj-$(CONFIG_ATH79_MACH_ENS202EXT)          += mach-ens202ext.o
 obj-$(CONFIG_ATH79_MACH_EPG5000)               += mach-epg5000.o
 obj-$(CONFIG_ATH79_MACH_ESR1750)               += mach-esr1750.o
 obj-$(CONFIG_ATH79_MACH_ESR900)                        += mach-esr900.o
+obj-$(CONFIG_ATH79_MACH_EW_BALIN)              += mach-ew-balin.o
 obj-$(CONFIG_ATH79_MACH_EW_DORIN)              += mach-ew-dorin.o
 obj-$(CONFIG_ATH79_MACH_F9K1115V2)             += mach-f9k1115v2.o
 obj-$(CONFIG_ATH79_MACH_FRITZ300E)             += mach-fritz300e.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ew-balin.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ew-balin.c
new file mode 100644 (file)
index 0000000..7d7f38c
--- /dev/null
@@ -0,0 +1,112 @@
+/*
+ * EW Balin board support
+ * (based on Atheros DB120 reference board support)
+ *
+ * Copyright (c) 2011 Qualcomm Atheros
+ * Copyright (c) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2017 Embedded Wireless GmbH    www.80211.de
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/pci.h>
+#include <linux/phy.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define BALIN_GPIO_LED_STATUS  14
+
+#define BALIN_GPIO_BTN_WPS             18
+
+#define BALIN_KEYS_POLL_INTERVAL       20      /* msecs */
+#define BALIN_KEYS_DEBOUNCE_INTERVAL   (3 * BALIN_KEYS_POLL_INTERVAL)
+
+#define BALIN_CALDATA_OFFSET           0x1000
+#define BALIN_WMAC_MAC_OFFSET          (BALIN_CALDATA_OFFSET + 0x02)
+
+static struct gpio_led balin_leds_gpio[] __initdata = {
+       {
+               .name           = "balin:green:status",
+               .gpio           = BALIN_GPIO_LED_STATUS,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button balin_gpio_keys[] __initdata = {
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = BALIN_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = BALIN_GPIO_BTN_WPS,
+               .active_low     = 0,
+       },
+};
+
+
+static void __init balin_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+       static u8 mac[6];
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(balin_leds_gpio),
+                                balin_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, BALIN_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(balin_gpio_keys),
+                                       balin_gpio_keys);
+
+       ath79_register_usb();
+
+
+       ath79_register_wmac(art + BALIN_CALDATA_OFFSET,
+                                   art + BALIN_WMAC_MAC_OFFSET);
+
+       ath79_register_pci();
+
+       ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0 |
+                                  AR934X_ETH_CFG_SW_ONLY_MODE);
+
+       ath79_register_mdio(1, 0x0);
+
+       /* GMAC1 is connected to the internal switch */
+       memcpy(mac, art + BALIN_WMAC_MAC_OFFSET, sizeof(mac));
+       mac[3] |= 0x40;
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+
+       ath79_register_eth(1);
+}
+
+MIPS_MACHINE(ATH79_MACH_EW_BALIN, "EW-BALIN", "EmbWir-Balin",
+            balin_setup);
index 0f536f0ec5848e38e30891c0b9757991c910ebb0..ca684b4209f3755bcfb01e4530ff6f1137c0b3dd 100644 (file)
@@ -106,6 +106,7 @@ enum ath79_mach_type {
        ATH79_MACH_EPG5000,                     /* EnGenius EPG5000 */
        ATH79_MACH_ESR1750,                     /* EnGenius ESR1750 */
        ATH79_MACH_ESR900,                      /* EnGenius ESR900 */
+       ATH79_MACH_EW_BALIN,                    /* embedded wireless Balin Platform */
        ATH79_MACH_EW_DORIN,                    /* embedded wireless Dorin Platform */
        ATH79_MACH_EW_DORIN_ROUTER,             /* embedded wireless Dorin Router Platform */
        ATH79_MACH_F9K1115V2,                   /* Belkin AC1750DB */
index c0d9fdd0d6aa9765cf94fce027ad46b2d5e84bb7..58eb3fd9225f5e2591459c122fc764e4fc99b9c8 100644 (file)
@@ -229,6 +229,15 @@ define Device/dragino2
 endef
 TARGET_DEVICES += dragino2
 
+define Device/ew-balin
+  DEVICE_TITLE := Embedded Wireless Balin Platform
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea 
+  BOARDNAME = EW-BALIN
+  IMAGE_SIZE = 16000k
+  MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += ew-balin
+
 define Device/ew-dorin
   DEVICE_TITLE := Embedded Wireless Dorin Platform
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea