support make target/linux/package/*-compile
authorFelix Fietkau <nbd@openwrt.org>
Mon, 16 Oct 2006 00:47:11 +0000 (00:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 16 Oct 2006 00:47:11 +0000 (00:47 +0000)
SVN-Revision: 5145

openwrt/target/Makefile
openwrt/target/linux/Makefile
openwrt/target/linux/linux-2.4/Makefile

index e6156b48bf034474cbc056a824dbcff01b78760c..b9a94fb3734266960bc2a9d219e4cc55b9c218f7 100644 (file)
@@ -16,6 +16,9 @@ clean: linux-clean utils-clean lzma-clean image_clean
 image_clean:
        rm -f $(BIN_DIR)/openwrt-*
 
+linux/package/%:
+       $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+
 %-clean:
        $(MAKE) -C $(patsubst %-clean,%,$@) clean
 %-prepare:
index f05238b4e98e07af594b4fb0f0044be5e51f30e8..f3aa67e5a60e571aad2e225e8d23778fa1aa9c20 100644 (file)
@@ -41,6 +41,8 @@ install-ib: $(1)/$(2)-install-ib
 endif
 
 .PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install $(1)/$(2)-image $(1)/$(2)-install-ib
+package/%:
+       $(MAKE) -C linux-$(1) BOARD="$(2)" $$@
 endef
 
 .PHONY: clean prepare compile rebuild install imagebuilder install-ib kernel-install
index e261deaee83c08beb9b331a18fa0ef725f56547a..590ba375cc5d2f906de07ef0a8d18bc12b7544ab 100644 (file)
@@ -387,3 +387,8 @@ clean:
        rm -f $(STAMP_DIR)/.linux-compile
        rm -rf $(LINUX_BUILD_DIR)
        rm -f $(TARGETS)
+
+package/%:
+       $(MAKE) -C $(TOPDIR)/target/linux/package \
+               $(KPKG_MAKEOPTS) \
+               $(patsubst package/%,%,$@)