tools: refresh all patches main master
authorRosen Penev <rosenp@gmail.com>
Sat, 18 May 2024 19:14:20 +0000 (12:14 -0700)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 23 May 2024 09:49:03 +0000 (11:49 +0200)
Refresh all tools patches now that tools/refresh correctly works.

CI now checks for them and actively complain if tools have unrefreshed
patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
[ reword commit message ]
Link: https://github.com/openwrt/openwrt/pull/15524
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
tools/elftosb/patches/001-libm.patch
tools/elftosb/patches/002-fix-header-path.patch
tools/liblzo/patches/001-add-cmake-ENABLE-configurables.patch
tools/lzma/patches/001-large_files.patch
tools/lzma/patches/002-lzmp.patch
tools/lzma/patches/003-compile_fixes.patch
tools/lzop/patches/001-add-cmake-ENABLE_DOCS-configurable.patch
tools/patch/patches/050-CVE-2019-13636.patch
tools/patch/patches/060-CVE-2019-13638.patch

index 02705d24bb7ff8b897a867caecf89fcc1cf9758d..6b49ac1af22811fe528047671bab746ca6ed5d49 100644 (file)
@@ -1,6 +1,6 @@
---- elftosb-10.12.01/makefile.rules    2012-03-15 11:01:44.979020178 -0400
-+++ elftosb-10.12.01/makefile.rules    2012-03-15 11:01:16.332761989 -0400
-@@ -101,7 +101,7 @@
+--- a/makefile.rules
++++ b/makefile.rules
+@@ -101,7 +101,7 @@ OBJ_FILES_KEYGEN =                 \
        keygen.o
  
  
index 5e3b5091b90f59dcf7329d31a64a8dd4375a7180..5099b296447f802fc543b027a086c7e4254036d4 100644 (file)
@@ -5,9 +5,8 @@ others once multiarch becomes more common.
 This patch makes the types a relative path, and allows the system
 to use whatever include paths it feels are correct.
 
-diff -Naurp elftosb-10.12.01-orig/common/stdafx.h elftosb-10.12.01/common/stdafx.h
---- elftosb-10.12.01-orig/common/stdafx.h      2012-07-12 13:30:10.990249396 -0400
-+++ elftosb-10.12.01/common/stdafx.h   2012-07-12 13:30:06.858249391 -0400
+--- a/common/stdafx.h
++++ b/common/stdafx.h
 @@ -27,7 +27,7 @@
  // For Linux systems only, types.h only defines the signed
  // integer types.  This is not professional code.
index 9ab27fc924acdb26709bd59afa2d9137a17bc87b..e0ba41016724804502d4fc35c40b3a8cb2109cfd 100644 (file)
@@ -1,6 +1,6 @@
---- a/CMakeLists.txt   2022-11-28 06:34:39.171209779 -0800
-+++ b/CMakeLists.txt   2022-11-28 06:33:13.368239757 -0800
-@@ -51,8 +51,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -51,8 +51,11 @@ endif()
  project(lzo VERSION 2.10 LANGUAGES C)
  
  # configuration options
@@ -14,7 +14,7 @@
  if(NOT ENABLE_STATIC AND NOT ENABLE_SHARED)
      set(ENABLE_STATIC ON)
  endif()
-@@ -127,14 +130,20 @@
+@@ -127,14 +130,20 @@ macro(lzo_add_executable t)
      endif()
  endmacro()
  # main test driver
@@ -35,7 +35,7 @@
  # some boring internal test programs
  if(0)
      lzo_add_executable(align    tests/align.c)
-@@ -144,7 +153,7 @@
+@@ -144,7 +153,7 @@ if(0)
  endif()
  
  # miniLZO
@@ -44,7 +44,7 @@
      add_executable(testmini minilzo/testmini.c minilzo/minilzo.c)
      target_include_directories(testmini PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/include/lzo") # needed for "lzoconf.h"
  endif()
-@@ -263,8 +272,10 @@
+@@ -263,8 +272,10 @@ add_test(NAME lzotest-03 COMMAND lzotest
  
  if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)
  
@@ -57,7 +57,7 @@
  
  set(f include/lzo/lzo1.h include/lzo/lzo1a.h include/lzo/lzo1b.h
      include/lzo/lzo1c.h include/lzo/lzo1f.h include/lzo/lzo1x.h
-@@ -285,7 +296,7 @@
+@@ -285,7 +296,7 @@ if(ENABLE_SHARED)
      )
  endif()
  
index b95fe9e90fd192065130de94bdc91882ba5a22e9..65603f497633585c5e960d51d33b5ba5e1ccf48b 100644 (file)
@@ -1,8 +1,6 @@
-Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
-===================================================================
---- lzma-4.65.orig/CPP/7zip/Compress/LZMA_Alone/makefile.gcc   2009-05-15 23:33:51.000000000 +0200
-+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc        2009-06-01 22:00:54.000000000 +0200
-@@ -3,7 +3,7 @@
+--- a/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
++++ b/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
+@@ -3,7 +3,7 @@ CXX = g++ -O2 -Wall
  CXX_C = gcc -O2 -Wall
  LIB = -lm
  RM = rm -f
index 72d881cdb2c15cbc5cff113970e0cbd45ada7811..f1d45f45ff65b4cacb5ccc5c7e3354a1b695efe0 100644 (file)
@@ -1,7 +1,5 @@
-Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp    2009-06-01 22:01:10.000000000 +0200
+--- /dev/null
++++ b/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
 @@ -0,0 +1,895 @@
 +/*
 + * LZMA command line tool similar to gzip to encode and decode LZMA files.
@@ -898,10 +896,8 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
 +      return STATUS_OK;
 +}
 +
-Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h 2009-06-01 22:01:10.000000000 +0200
+--- /dev/null
++++ b/CPP/7zip/Compress/LZMA_Alone/Exception.h
 @@ -0,0 +1,45 @@
 +/* A couple of exceptions for lzmp.
 + *
@@ -948,10 +944,8 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h
 +
 +#endif
 +
-Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
-===================================================================
---- lzma-4.65.orig/CPP/7zip/Compress/LZMA_Alone/makefile.gcc   2009-06-01 22:00:54.000000000 +0200
-+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc        2009-06-01 22:06:13.000000000 +0200
+--- a/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
++++ b/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
 @@ -1,9 +1,10 @@
 -PROG = lzma
 +PROG = lzma_alone
@@ -965,7 +959,7 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
  
  ifdef SystemDrive
  IS_MINGW = 1
-@@ -45,12 +46,35 @@
+@@ -45,12 +46,35 @@ OBJS = \
    Lzma86Dec.o \
    Lzma86Enc.o \
  
@@ -1002,17 +996,15 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
  LzmaAlone.o: LzmaAlone.cpp
        $(CXX) $(CFLAGS) LzmaAlone.cpp
  
-@@ -131,5 +153,5 @@
+@@ -131,5 +155,5 @@ Lzma86Enc.o: ../../../../C/LzmaUtil/Lzma
        $(CXX_C) $(CFLAGS) ../../../../C/LzmaUtil/Lzma86Enc.c
  
  clean:
 -      -$(RM) $(PROG) $(OBJS)
 +      -$(RM) $(PROG) $(PROG2) $(OBJS)
  
-Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h      2009-06-01 22:01:10.000000000 +0200
+--- /dev/null
++++ b/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
 @@ -0,0 +1,31 @@
 +#ifndef LZMA_VERSION_H
 +#define LZMA_VERSION_H
@@ -1045,11 +1037,9 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
 +              "named COPYING.\n";
 +
 +#endif /* ifndef LZMA_VERSION_H */
-Index: lzma-4.65/CPP/Common/C_FileIO.h
-===================================================================
---- lzma-4.65.orig/CPP/Common/C_FileIO.h       2009-05-15 23:33:51.000000000 +0200
-+++ lzma-4.65/CPP/Common/C_FileIO.h    2009-06-01 22:06:56.000000000 +0200
-@@ -24,6 +24,7 @@
+--- a/CPP/Common/C_FileIO.h
++++ b/CPP/Common/C_FileIO.h
+@@ -24,6 +24,7 @@ public:
    bool Close();
    bool GetLength(UInt64 &length) const;
    off_t Seek(off_t distanceToMove, int moveMethod) const;
index 49ae66b9c42850315dca18c324d767926a527fa2..06f7a54aef978cef16041f86d4a36687d21344de 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN lzma-4.65/CPP/7zip/Common/FileStreams.h lzma-4.65.new/CPP/7zip/Common/FileStreams.h
---- lzma-4.65/CPP/7zip/Common/FileStreams.h    2009-05-15 23:33:51.000000000 +0200
-+++ lzma-4.65.new/CPP/7zip/Common/FileStreams.h        2009-06-01 22:30:01.000000000 +0200
-@@ -72,6 +72,7 @@
+--- a/CPP/7zip/Common/FileStreams.h
++++ b/CPP/7zip/Common/FileStreams.h
+@@ -72,6 +72,7 @@ class COutFileStream:
    public IOutStream,
    public CMyUnknownImp
  {
@@ -9,10 +8,9 @@ diff -urN lzma-4.65/CPP/7zip/Common/FileStreams.h lzma-4.65.new/CPP/7zip/Common/
    #ifdef USE_WIN_FILE
    NWindows::NFile::NIO::COutFile File;
    #else
-diff -urN lzma-4.65/CPP/Common/MyWindows.h lzma-4.65.new/CPP/Common/MyWindows.h
---- lzma-4.65/CPP/Common/MyWindows.h   2009-05-15 23:33:51.000000000 +0200
-+++ lzma-4.65.new/CPP/Common/MyWindows.h       2009-06-01 22:29:26.000000000 +0200
-@@ -101,8 +101,11 @@
+--- a/CPP/Common/MyWindows.h
++++ b/CPP/Common/MyWindows.h
+@@ -101,8 +101,11 @@ typedef LONG SCODE;
  
  #ifdef __cplusplus
  
index 01ebd33a399ae791f8dc2ace0684357da6471c5e..27af782c1cc6b602552ced98da6a081a83e23162 100644 (file)
@@ -1,6 +1,6 @@
---- a/CMakeLists.txt   2017-08-10 04:19:45.000000000 -0700
-+++ b/CMakeLists.txt   2022-11-28 17:21:03.453548350 -0800
-@@ -50,6 +50,9 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -50,6 +50,9 @@ endif()
  
  project(lzop VERSION 1.04 LANGUAGES C)
  
@@ -10,7 +10,7 @@
  # install directories
  if(NOT CMAKE_INSTALL_PREFIX)
      message(FATAL_ERROR "ERROR: CMAKE_INSTALL_PREFIX is not defined.")
-@@ -186,9 +189,11 @@
+@@ -186,9 +189,11 @@ if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)
  
  install(TARGETS lzop DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}")
  
index e62c3d41753c7f7bbd79c9943fb5c5ea0603a1c1..d819838bba44f7f75f11c6badd0529235320feca 100644 (file)
@@ -14,8 +14,6 @@ with O_CREAT | O_EXCL to avoid following symlinks in that case as well.
  src/util.c | 14 +++++++++++---
  2 files changed, 21 insertions(+), 5 deletions(-)
 
-diff --git a/src/inp.c b/src/inp.c
-index 32d0919..22d7473 100644
 --- a/src/inp.c
 +++ b/src/inp.c
 @@ -238,8 +238,13 @@ plan_a (char const *filename)
@@ -52,11 +50,9 @@ index 32d0919..22d7473 100644
        || ! (ifp = fdopen (ifd, binary_transput ? "rb" : "r")))
      pfatal ("Can't open file %s", quotearg (filename));
    if (TMPINNAME_needs_removal)
-diff --git a/src/util.c b/src/util.c
-index 1cc08ba..fb38307 100644
 --- a/src/util.c
 +++ b/src/util.c
-@@ -388,7 +388,7 @@ create_backup (char const *to, const struct stat *to_st, bool leave_original)
+@@ -388,7 +388,7 @@ create_backup (char const *to, const str
  
          try_makedirs_errno = ENOENT;
          safe_unlink (bakname);
@@ -65,7 +61,7 @@ index 1cc08ba..fb38307 100644
            {
              if (errno != try_makedirs_errno)
                pfatal ("Can't create file %s", quotearg (bakname));
-@@ -579,10 +579,13 @@ create_file (char const *file, int open_flags, mode_t mode,
+@@ -579,10 +579,13 @@ create_file (char const *file, int open_
  static void
  copy_to_fd (const char *from, int tofd)
  {
@@ -80,7 +76,7 @@ index 1cc08ba..fb38307 100644
      pfatal ("Can't reopen file %s", quotearg (from));
    while ((i = read (fromfd, buf, bufsize)) != 0)
      {
-@@ -625,6 +628,8 @@ copy_file (char const *from, char const *to, struct stat *tost,
+@@ -625,6 +628,8 @@ copy_file (char const *from, char const
    else
      {
        assert (S_ISREG (mode));
@@ -89,7 +85,7 @@ index 1cc08ba..fb38307 100644
        tofd = create_file (to, O_WRONLY | O_BINARY | to_flags, mode,
                          to_dir_known_to_exist);
        copy_to_fd (from, tofd);
-@@ -640,9 +645,12 @@ copy_file (char const *from, char const *to, struct stat *tost,
+@@ -640,9 +645,12 @@ copy_file (char const *from, char const
  void
  append_to_file (char const *from, char const *to)
  {
@@ -103,6 +99,3 @@ index 1cc08ba..fb38307 100644
      pfatal ("Can't reopen file %s", quotearg (to));
    copy_to_fd (from, tofd);
    if (close (tofd) != 0)
--- 
-cgit v1.0-41-gc330
-
index 38caff628aafa694e0ce3cfe6f165e1509e31a00..590cf186e7c67eff0b71ce54a09513e0bd1fbd30 100644 (file)
@@ -9,11 +9,9 @@ command to avoid quoting vulnerabilities.
  src/pch.c | 6 ++----
  1 file changed, 2 insertions(+), 4 deletions(-)
 
-diff --git a/src/pch.c b/src/pch.c
-index 4fd5a05..16e001a 100644
 --- a/src/pch.c
 +++ b/src/pch.c
-@@ -2459,9 +2459,6 @@ do_ed_script (char const *inname, char const *outname,
+@@ -2459,9 +2459,6 @@ do_ed_script (char const *inname, char c
            *outname_needs_removal = true;
            copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
          }
@@ -23,7 +21,7 @@ index 4fd5a05..16e001a 100644
        fflush (stdout);
  
        pid = fork();
-@@ -2470,7 +2467,8 @@ do_ed_script (char const *inname, char const *outname,
+@@ -2470,7 +2467,8 @@ do_ed_script (char const *inname, char c
        else if (pid == 0)
          {
            dup2 (tmpfd, 0);
@@ -33,6 +31,3 @@ index 4fd5a05..16e001a 100644
            _exit (2);
          }
        else
--- 
-cgit v1.0-41-gc330
-