bcm63xx: disable all devices with <= 4MiB flash and <= 32 MiB RAM
authorJonas Gorski <jonas.gorski@gmail.com>
Fri, 28 Feb 2020 11:00:29 +0000 (12:00 +0100)
committerJonas Gorski <jonas.gorski@gmail.com>
Mon, 2 Mar 2020 21:42:40 +0000 (22:42 +0100)
Device with 4 MiB flash and 32 MiB RAM won't be able to run OpenWrt in
a sufficient manner without tweaks, so don't build images for them by
default.

This includes all BCM6338, BCM6345 and BCM6348 "generic" devices,
as there are no supported devices of these with more than that.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
target/linux/bcm63xx/image/bcm63xx.mk

index 265fa0958ae0b501a7643f33b5c9b3e904046b1d..4e738c11b57d3239ccec62c1f5c4b04a798cc225 100644 (file)
@@ -90,6 +90,7 @@ define Device/brcm_bcm96338w
   DEVICE_MODEL := 96338W
   CFE_BOARD_ID := 6338W
   CFE_CHIP_ID := 6338
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96338w
 
@@ -111,6 +112,7 @@ define Device/brcm_bcm96348gw
   IMAGES += cfe-bc221.bin
   CFE_BOARD_ID := 96348GW
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348gw
 
@@ -120,6 +122,7 @@ define Device/brcm_bcm96348gw-10
   DEVICE_MODEL := 96348GW-10
   CFE_BOARD_ID := 96348GW-10
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348gw-10
 
@@ -129,6 +132,7 @@ define Device/brcm_bcm96348gw-11
   DEVICE_MODEL := 96348GW-11
   CFE_BOARD_ID := 96348GW-11
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348gw-11
 
@@ -138,6 +142,7 @@ define Device/brcm_bcm96348r
   DEVICE_MODEL := 96348R
   CFE_BOARD_ID := 96348R
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348r
 
@@ -512,6 +517,7 @@ define Device/d-link_dsl-274xb-c2
   CFE_BOARD_ID := 96358GW
   CFE_CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += d-link_dsl-274xb-c2
 
@@ -527,6 +533,7 @@ define Device/d-link_dsl-274xb-c3
   CFE_BOARD_ID := AW4139
   CFE_CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += d-link_dsl-274xb-c3
 
@@ -647,6 +654,7 @@ define Device/huawei_echolife-hg520v
   CFE_EXTRAS += --rsa-signature "EchoLife_HG520v"
   SOC := bcm6359
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += huawei_echolife-hg520v
 
@@ -1056,6 +1064,7 @@ define Device/tecom_gw6000
   CFE_BOARD_ID := 96348GW
   CFE_CHIP_ID := 6348
   DEVICE_PACKAGES := $(BRCMWL_PACKAGES) $(USB1_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += tecom_gw6000
 
@@ -1067,6 +1076,7 @@ define Device/tecom_gw6200
   CFE_CHIP_ID := 6348
   CFE_EXTRAS += --rsa-signature "$(shell printf '\x99')"
   DEVICE_PACKAGES := $(BRCMWL_PACKAGES) $(USB1_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += tecom_gw6200
 
@@ -1147,5 +1157,6 @@ define Device/zyxel_p870hw-51a-v2
   CFE_CHIP_ID := 6368
   CFE_EXTRAS += --rsa-signature "ZyXEL" --signature "ZyXEL_0001"
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += zyxel_p870hw-51a-v2