ffmpeg: fix build failure on x86 (closes: #8840), install libswscale headers (closes...
authorNicolas Thill <nico@openwrt.org>
Mon, 10 Oct 2011 02:42:59 +0000 (02:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 10 Oct 2011 02:42:59 +0000 (02:42 +0000)
SVN-Revision: 28397

multimedia/ffmpeg/Makefile
multimedia/ffmpeg/patches/901-fix_libswscale_on_x86.patch [new file with mode: 0644]

index 101e7d94d548fd34a971220e75082a28d5110e1f..e2dc1f13a3b5fe7df5b3e8e14a456d1ae9f42cea 100644 (file)
@@ -213,6 +213,8 @@ define Build/Configure
                --disable-debug \
                --enable-gpl \
                --disable-libfaad \
+               --disable-amd3dnow \
+               --disable-amd3dnowext \
                --disable-mmx \
                --disable-mmx2 \
                --enable-pthreads \
@@ -255,6 +257,7 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libav{codec,device,format,util} $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libpostproc $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libswscale $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libav{codec,device,format,util}.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpostproc.{a,so*} $(1)/usr/lib/
diff --git a/multimedia/ffmpeg/patches/901-fix_libswscale_on_x86.patch b/multimedia/ffmpeg/patches/901-fix_libswscale_on_x86.patch
new file mode 100644 (file)
index 0000000..2fcee2f
--- /dev/null
@@ -0,0 +1,35 @@
+Index: ffmpeg-0.5.4/libswscale/rgb2rgb.c
+===================================================================
+--- ffmpeg-0.5.4.orig/libswscale/rgb2rgb.c     2011-03-17 13:10:27.000000000 +0100
++++ ffmpeg-0.5.4/libswscale/rgb2rgb.c  2011-10-10 03:35:15.000000000 +0200
+@@ -149,7 +149,7 @@
+ #define RENAME(a) a ## _C
+ #include "rgb2rgb_template.c"
+-#if ARCH_X86 && CONFIG_GPL
++#if ARCH_X86 && CONFIG_GPL && 0
+ //MMX versions
+ #undef RENAME
+Index: ffmpeg-0.5.4/libswscale/swscale_template.c
+===================================================================
+--- ffmpeg-0.5.4.orig/libswscale/swscale_template.c    2011-10-10 03:33:19.000000000 +0200
++++ ffmpeg-0.5.4/libswscale/swscale_template.c 2011-10-10 03:38:37.000000000 +0200
+@@ -2219,7 +2219,7 @@
+     }
+     else // fast bilinear upscale / crap downscale
+     {
+-#if ARCH_X86 && CONFIG_GPL
++#if ARCH_X86 && CONFIG_GPL && 0
+ #if HAVE_MMX2
+         int i;
+ #if defined(PIC)
+@@ -2492,7 +2492,7 @@
+     }
+     else // fast bilinear upscale / crap downscale
+     {
+-#if ARCH_X86 && CONFIG_GPL
++#if ARCH_X86 && CONFIG_GPL && 0
+ #if HAVE_MMX2
+         int i;
+ #if defined(PIC)