d1: change the wireless module for the LicheePi Nano Dock
authorZoltan HERPAI <wigyori@uid0.hu>
Sun, 24 Mar 2024 17:49:42 +0000 (18:49 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Mon, 25 Mar 2024 00:30:32 +0000 (01:30 +0100)
The correct adapter on the board is the RTL8723DS (not the BS). Select
the newly packaged wireless driver, and also select wpad-basic to make
some use of the interface.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/d1/image/Makefile

index aadf1807e751afe0302efe3be64fb2982c19243e..f13af6dbde82c1dac950940ea193429e26660001 100644 (file)
@@ -63,7 +63,7 @@ define Device/lichee_rv_dock
   DEVICE_VENDOR := Sipeed
   DEVICE_MODEL := LicheePi RV (dock)
   DEVICE_DTS := allwinner/sun20i-d1-lichee-rv-dock
-  DEVICE_PACKAGES += kmod-rtl8723bs
+  DEVICE_PACKAGES += kmod-rtw88-8723ds wpad-basic-mbedtls
   UBOOT := lichee_rv_dock
 endef
 TARGET_DEVICES += lichee_rv_dock