[packages_10.03.1] merge r27834
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 30 Jul 2011 00:25:40 +0000 (00:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 30 Jul 2011 00:25:40 +0000 (00:25 +0000)
SVN-Revision: 27835

lang/php5/Makefile
lang/php5/patches/101-fix_membar_producer_link_error_gcc3x.patch [new file with mode: 0644]

index 138a140365be0102640f4c636a8ea4f6ae68183e..fe1d34597acaf76ef273e9ecd005bb0120d6be68 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=5.3.6
-PKG_RELEASE:=3.1
+PKG_RELEASE:=3.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
diff --git a/lang/php5/patches/101-fix_membar_producer_link_error_gcc3x.patch b/lang/php5/patches/101-fix_membar_producer_link_error_gcc3x.patch
new file mode 100644 (file)
index 0000000..b3f677f
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/ext/standard/php_crypt_r.c
++++ b/ext/standard/php_crypt_r.c
+@@ -96,6 +96,8 @@ void _crypt_extended_init_r(void)
+               InterlockedIncrement(&initialized);
+ #elif (defined(__GNUC__) && (__GNUC__ >= 4 && __GNUC_MINOR__ >= 1))
+               __sync_fetch_and_add(&initialized, 1);
++#elif (defined(__GNUC__) && (__GNUC__ == 3))
++              initialized = 1;
+ #elif defined(HAVE_ATOMIC_H) /* Solaris 10 defines atomic API within */
+               membar_producer();
+               atomic_add_int(&initialized, 1);