package/busybox: backport r29299 (wget: URL-decode user:password before base64-encodi...
authorNicolas Thill <nico@openwrt.org>
Wed, 23 Nov 2011 22:44:00 +0000 (22:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 23 Nov 2011 22:44:00 +0000 (22:44 +0000)
SVN-Revision: 29315

package/busybox/Makefile
package/busybox/patches/110-wget_getopt_fix.patch
package/busybox/patches/310-passwd_access.patch
package/busybox/patches/350-httpd_redir.patch
package/busybox/patches/410-httpd_cgi_headers.patch
package/busybox/patches/440-httpd_chdir.patch

index d2b16aa9138c18f0b89acb7300f3c6ed8caefabf..ac41b6412303dc7049acea910417ed590473b56f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.15.3
-PKG_RELEASE:=3.3
+PKG_RELEASE:=3.4
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 617679eab380cf49f830b0efdd5c90456c83506a..01c5cd30f61df1bb7ac728ddb16c4961c706b15a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/networking/wget.c
 +++ b/networking/wget.c
-@@ -653,7 +653,7 @@ int wget_main(int argc UNUSED_PARAM, cha
+@@ -658,7 +658,7 @@ int wget_main(int argc UNUSED_PARAM, cha
                // "tries\0"            Required_argument "t"
                // "timeout\0"          Required_argument "T"
                /* Ignored (we always use PASV): */
index 6ab6d4b8c4ee8dad702c7ca4f768bcb47e1d29f1..248fb24aad9a8bc72ddd79229d457887a859377a 100644 (file)
@@ -3,7 +3,7 @@
 
 --- a/networking/httpd.c
 +++ b/networking/httpd.c
-@@ -1699,21 +1699,32 @@ static int check_user_passwd(const char 
+@@ -1627,21 +1627,32 @@ static int check_user_passwd(const char 
  
                if (ENABLE_FEATURE_HTTPD_AUTH_MD5) {
                        char *md5_passwd;
index 3d3e041ce8f1656c3b4023f4cde93bb6344b9bc3..99f60457caa2da8ecbaac2de046e93792a4b464b 100644 (file)
@@ -37,7 +37,7 @@
  #define last_mod          (G.last_mod         )
  #define ip_a_d            (G.ip_a_d           )
  #define g_realm           (G.g_realm          )
-@@ -993,8 +997,11 @@ static void send_headers(int responseNum
+@@ -921,8 +925,11 @@ static void send_headers(int responseNum
        }
  #endif
        if (responseNum == HTTP_MOVED_TEMPORARILY) {
@@ -50,7 +50,7 @@
                                (g_query ? "?" : ""),
                                (g_query ? g_query : ""));
        }
-@@ -1924,8 +1931,12 @@ static void handle_incoming_and_exit(con
+@@ -1852,8 +1859,12 @@ static void handle_incoming_and_exit(con
        } while (*++tptr);
        *++urlp = '\0';       /* terminate after last character */
  
@@ -64,7 +64,7 @@
                if (is_directory(urlcopy + 1, 1, &sb)) {
                        found_moved_temporarily = urlcopy;
                }
-@@ -2266,7 +2277,9 @@ static void sighup_handler(int sig UNUSE
+@@ -2194,7 +2205,9 @@ static void sighup_handler(int sig UNUSE
  }
  
  enum {
@@ -75,7 +75,7 @@
        d_opt_decode_url,
        h_opt_home_httpd,
        IF_FEATURE_HTTPD_ENCODE_URL_STR(e_opt_encode_url,)
-@@ -2315,12 +2328,13 @@ int httpd_main(int argc UNUSED_PARAM, ch
+@@ -2243,12 +2256,13 @@ int httpd_main(int argc UNUSED_PARAM, ch
        /* We do not "absolutize" path given by -h (home) opt.
         * If user gives relative path in -h,
         * $SCRIPT_FILENAME will not be set. */
index 2f464608f1b0311f0a23c1d69518dc317684692a..af2dc0c283841ee5c43cc63af08924ce05e95d5c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/networking/httpd.c
 +++ b/networking/httpd.c
-@@ -1250,10 +1250,10 @@ static NOINLINE void cgi_io_loop_and_exi
+@@ -1178,10 +1178,10 @@ static NOINLINE void cgi_io_loop_and_exi
                                                if (full_write(STDOUT_FILENO, HTTP_200, sizeof(HTTP_200)-1) != sizeof(HTTP_200)-1)
                                                        break;
                                        }
index 0abea5dc3b89a807502ade3adbc9250a0e3d954a..0a412f8b31d9770bac7141acd803ffdbd6fe629b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/networking/httpd.c
 +++ b/networking/httpd.c
-@@ -1810,6 +1810,7 @@ static void handle_incoming_and_exit(con
+@@ -1738,6 +1738,7 @@ static void handle_incoming_and_exit(con
        char *header_ptr = header_ptr;
        Htaccess_Proxy *proxy_entry;
  #endif