modules: add support for H5 (3-wire) Bluetooth UART protocols
authorZoltan HERPAI <wigyori@uid0.hu>
Sun, 24 Mar 2024 22:04:14 +0000 (23:04 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Mon, 25 Mar 2024 00:30:34 +0000 (01:30 +0100)
Most of the Realtek bluetooth devices work with the H5 (3-wire)
UART protocols. Add support for these in the hci_uart module.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/kernel/linux/modules/other.mk
target/linux/generic/config-5.15
target/linux/generic/config-6.1
target/linux/generic/config-6.6

index e227fd6a0f98ad25b4a63360fe81d1700b2d41c8..8b60ea57f01235cdd808f7c0dc34202dcbbf84dd 100644 (file)
@@ -47,6 +47,7 @@ define KernelPackage/bluetooth
        CONFIG_BT_HCIUART_INTEL=n \
        CONFIG_BT_HCIUART_H4 \
        CONFIG_BT_HCIUART_NOKIA=n \
+       CONFIG_BT_HCIUART_RTL \
        CONFIG_BT_HIDP
   $(call AddDepends/rfkill)
   FILES:= \
index 8f6ccad216f305bfec5f57bf69951c14910693d2..7394822a7f3c01a167b6601d9fa1dbb617effec7 100644 (file)
@@ -797,7 +797,7 @@ CONFIG_BT_BNEP_PROTO_FILTER=y
 # CONFIG_BT_HCIBTUSB_RTL is not set
 # CONFIG_BT_HCIDTL1 is not set
 # CONFIG_BT_HCIUART is not set
-# CONFIG_BT_HCIUART_3WIRE is not set
+CONFIG_BT_HCIUART_3WIRE=y
 # CONFIG_BT_HCIUART_AG6XX is not set
 # CONFIG_BT_HCIUART_ATH3K is not set
 CONFIG_BT_HCIUART_BCSP=y
@@ -805,7 +805,7 @@ CONFIG_BT_HCIUART_H4=y
 # CONFIG_BT_HCIUART_LL is not set
 # CONFIG_BT_HCIUART_MRVL is not set
 # CONFIG_BT_HCIUART_QCA is not set
-# CONFIG_BT_HCIUART_RTL is not set
+CONFIG_BT_HCIUART_RTL=y
 # CONFIG_BT_HCIVHCI is not set
 # CONFIG_BT_HIDP is not set
 # CONFIG_BT_HS is not set
index fa82f9cb9acefe10cbe087216c3681afab10e9bb..6606a065797b8c59e592ce5c448081b08ca27106 100644 (file)
@@ -843,7 +843,7 @@ CONFIG_BT_BNEP_PROTO_FILTER=y
 # CONFIG_BT_HCIBTUSB_RTL is not set
 # CONFIG_BT_HCIDTL1 is not set
 # CONFIG_BT_HCIUART is not set
-# CONFIG_BT_HCIUART_3WIRE is not set
+CONFIG_BT_HCIUART_3WIRE=y
 # CONFIG_BT_HCIUART_AG6XX is not set
 # CONFIG_BT_HCIUART_ATH3K is not set
 CONFIG_BT_HCIUART_BCSP=y
@@ -851,7 +851,7 @@ CONFIG_BT_HCIUART_H4=y
 # CONFIG_BT_HCIUART_LL is not set
 # CONFIG_BT_HCIUART_MRVL is not set
 # CONFIG_BT_HCIUART_QCA is not set
-# CONFIG_BT_HCIUART_RTL is not set
+CONFIG_BT_HCIUART_RTL=y
 # CONFIG_BT_HCIVHCI is not set
 # CONFIG_BT_HIDP is not set
 # CONFIG_BT_HS is not set
index 7486d8c882a1bb43ef52328b67ede5321f2bf170..4284a1b1d2ec1cfab1ff5b49eef9086142a48fcb 100644 (file)
@@ -854,7 +854,7 @@ CONFIG_BT_HCIBTUSB_POLL_SYNC=y
 # CONFIG_BT_HCIBTUSB_RTL is not set
 # CONFIG_BT_HCIDTL1 is not set
 # CONFIG_BT_HCIUART is not set
-# CONFIG_BT_HCIUART_3WIRE is not set
+CONFIG_BT_HCIUART_3WIRE=y
 # CONFIG_BT_HCIUART_AG6XX is not set
 # CONFIG_BT_HCIUART_ATH3K is not set
 CONFIG_BT_HCIUART_BCSP=y
@@ -862,7 +862,7 @@ CONFIG_BT_HCIUART_H4=y
 # CONFIG_BT_HCIUART_LL is not set
 # CONFIG_BT_HCIUART_MRVL is not set
 # CONFIG_BT_HCIUART_QCA is not set
-# CONFIG_BT_HCIUART_RTL is not set
+CONFIG_BT_HCIUART_RTL=y
 # CONFIG_BT_HCIVHCI is not set
 # CONFIG_BT_HIDP is not set
 # CONFIG_BT_HS is not set