cleanup: toolchain/uClibc: remove "broken" stuff
authorNicolas Thill <nico@openwrt.org>
Wed, 23 Nov 2011 21:44:53 +0000 (21:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 23 Nov 2011 21:44:53 +0000 (21:44 +0000)
 * remove NPTL support

SVN-Revision: 29312

25 files changed:
toolchain/gcc/Config.in
toolchain/uClibc/Config.in
toolchain/uClibc/Config.version
toolchain/uClibc/Makefile
toolchain/uClibc/config-0.9.30+nptl/arm [deleted file]
toolchain/uClibc/config-0.9.30+nptl/armeb [deleted file]
toolchain/uClibc/config-0.9.30+nptl/avr32 [deleted file]
toolchain/uClibc/config-0.9.30+nptl/common [deleted file]
toolchain/uClibc/config-0.9.30+nptl/cris [deleted file]
toolchain/uClibc/config-0.9.30+nptl/debug [deleted file]
toolchain/uClibc/config-0.9.30+nptl/i386 [deleted file]
toolchain/uClibc/config-0.9.30+nptl/i686 [deleted file]
toolchain/uClibc/config-0.9.30+nptl/m68k [deleted file]
toolchain/uClibc/config-0.9.30+nptl/mips [deleted file]
toolchain/uClibc/config-0.9.30+nptl/mips64 [deleted file]
toolchain/uClibc/config-0.9.30+nptl/mips64el [deleted file]
toolchain/uClibc/config-0.9.30+nptl/mipsel [deleted file]
toolchain/uClibc/config-0.9.30+nptl/mipsel.brcm-2.4 [deleted file]
toolchain/uClibc/config-0.9.30+nptl/powerpc [deleted file]
toolchain/uClibc/config-0.9.30+nptl/x86_64 [deleted file]
toolchain/uClibc/patches-0.9.30+nptl/110-compat_macros.patch [deleted file]
toolchain/uClibc/patches-0.9.30+nptl/130-compile_fix.patch [deleted file]
toolchain/uClibc/patches-0.9.30+nptl/140-math_finite.patch [deleted file]
toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch [deleted file]
toolchain/uClibc/patches-0.9.30+nptl/350-use-fputs_unlocked.patch [deleted file]

index e7a1250df7ecca0bd1a23013cec2075839427b25..a08b8125a7e222eed22096c2e9595d3498035b83 100644 (file)
@@ -68,7 +68,7 @@ config SSP_SUPPORT
 
 config TLS_SUPPORT
        bool
-       depends !GCC_VERSION_3_4_6 && UCLIBC_VERSION_NPTL
+       depends !GCC_VERSION_3_4_6
        prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
        default n
        help
index 670ba024ad664e768b3b913491f028f56a4bb2aa..31ddb596272f59797432eef66827c7a2500847c8 100644 (file)
@@ -16,10 +16,6 @@ choice
        config UCLIBC_VERSION_0_9_30_3
                bool "uClibc 0.9.30.3"
 
-       config UCLIBC_VERSION_NPTL
-               bool "uClibc NPTL branch"
-               depends BROKEN
-
 endchoice
 
 
index 9ce5a9d9b5ed1dd7ada3633370376fdfc3722c0b..dcab35dc310b072f7b9976f5b11dd32b180114d7 100644 (file)
@@ -4,7 +4,6 @@ config UCLIBC_VERSION
        default "0.9.30.1"     if UCLIBC_VERSION_0_9_30_1
        default "0.9.30.2"     if UCLIBC_VERSION_0_9_30_2
        default "0.9.30.3"     if UCLIBC_VERSION_0_9_30_3
-       default "0.9.30+nptl"  if UCLIBC_VERSION_NPTL
        default "0.9.30.1"
 
 if !TOOLCHAINOPTS
index d47be0c4181240d8c05a084817369b7b003ea679..deee154bb8756f42b7b0e03c06d845642426ab79 100644 (file)
@@ -9,18 +9,11 @@ include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=uClibc
 PKG_VERSION:=$(call qstrip,$(CONFIG_UCLIBC_VERSION))
-ifeq ($(CONFIG_UCLIBC_VERSION_NPTL),y)
-  PKG_SOURCE_URL:=git://git.busybox.net/uClibc
-  PKG_SOURCE_PROTO:=git
-  PKG_SOURCE_VERSION:=ef18cfe8ebab25f5ef92e81956f50e2dc57df602
-  PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-  LIBC_SO_VERSION:=0.9.30-git
-else
-  PKG_SOURCE_URL:=http://www.uclibc.org/downloads
-  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-  LIBC_SO_VERSION:=$(PKG_VERSION)
-endif
+
+PKG_SOURCE_URL:=http://www.uclibc.org/downloads
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+LIBC_SO_VERSION:=$(PKG_VERSION)
+
 PATCH_DIR:=./patches-$(PKG_VERSION)
 CONFIG_DIR:=./config-$(PKG_VERSION)
 
diff --git a/toolchain/uClibc/config-0.9.30+nptl/arm b/toolchain/uClibc/config-0.9.30+nptl/arm
deleted file mode 100644 (file)
index d26b075..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_ARM10T is not set
-# CONFIG_ARM1136JF_S is not set
-# CONFIG_ARM1176JZF_S is not set
-# CONFIG_ARM1176JZ_S is not set
-# CONFIG_ARM610 is not set
-# CONFIG_ARM710 is not set
-# CONFIG_ARM720T is not set
-# CONFIG_ARM7TDMI is not set
-# CONFIG_ARM920T is not set
-# CONFIG_ARM922T is not set
-# CONFIG_ARM926T is not set
-# CONFIG_ARM_CORTEX_M1 is not set
-# CONFIG_ARM_CORTEX_M3 is not set
-# CONFIG_ARM_EABI is not set
-# CONFIG_ARM_IWMMXT is not set
-CONFIG_ARM_OABI=y
-# CONFIG_ARM_SA110 is not set
-# CONFIG_ARM_SA1100 is not set
-CONFIG_ARM_XSCALE=y
-# CONFIG_GENERIC_ARM is not set
-TARGET_ARCH="arm"
-TARGET_arm=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/armeb b/toolchain/uClibc/config-0.9.30+nptl/armeb
deleted file mode 100644 (file)
index ba3ea5c..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_BIG_ENDIAN=y
-ARCH_WANTS_BIG_ENDIAN=y
-# CONFIG_ARM10T is not set
-# CONFIG_ARM1136JF_S is not set
-# CONFIG_ARM1176JZF_S is not set
-# CONFIG_ARM1176JZ_S is not set
-# CONFIG_ARM610 is not set
-# CONFIG_ARM710 is not set
-# CONFIG_ARM720T is not set
-# CONFIG_ARM7TDMI is not set
-# CONFIG_ARM920T is not set
-# CONFIG_ARM922T is not set
-# CONFIG_ARM926T is not set
-# CONFIG_ARM_CORTEX_M1 is not set
-# CONFIG_ARM_CORTEX_M3 is not set
-# CONFIG_ARM_EABI is not set
-# CONFIG_ARM_IWMMXT is not set
-CONFIG_ARM_OABI=y
-# CONFIG_ARM_SA110 is not set
-# CONFIG_ARM_SA1100 is not set
-CONFIG_ARM_XSCALE=y
-# CONFIG_GENERIC_ARM is not set
-TARGET_ARCH="arm"
-TARGET_arm=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/avr32 b/toolchain/uClibc/config-0.9.30+nptl/avr32
deleted file mode 100644 (file)
index bf7907a..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-ARCH_BIG_ENDIAN=y
-CONFIG_AVR32_AP7=y
-FORCE_SHAREABLE_TEXT_SEGMENTS=y
-LINKRELAX=y
-TARGET_ARCH="avr32"
-TARGET_avr32=y
-UCLIBC_HAS_FPU=y
-# UCLIBC_HAS_SCANF_GLIBC_A_FLAG is not set
-# UCLIBC_HAS_STRING_ARCH_OPT is not set
-UNIX98PTY_ONLY=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/common b/toolchain/uClibc/config-0.9.30+nptl/common
deleted file mode 100644 (file)
index 33c9273..0000000
+++ /dev/null
@@ -1,192 +0,0 @@
-# ARCH_ANY_ENDIAN is not set
-ARCH_HAS_MMU=y
-# ARCH_HAS_NO_LDSO is not set
-# ARCH_HAS_NO_SHARED is not set
-# ARCH_LITTLE_ENDIAN is not set
-ARCH_USE_MMU=y
-# ARCH_WANTS_BIG_ENDIAN is not set
-# ARCH_WANTS_LITTLE_ENDIAN is not set
-ASSUME_DEVPTS=y
-COMPAT_ATEXIT=y
-CROSS_COMPILER_PREFIX=""
-DEVEL_PREFIX="/usr/"
-# DOASSERTS is not set
-# DODEBUG is not set
-# DODEBUG_PT is not set
-# DOMULTI is not set
-DOPIC=y
-DOSTRIP=y
-DO_C99_MATH=y
-# DO_XSI_MATH is not set
-# EXTRA_WARNINGS is not set
-FORCE_OPTIONS_FOR_ARCH=y
-# FORCE_SHAREABLE_TEXT_SEGMENTS is not set
-HARDWIRED_ABSPATH=y
-# HAS_NO_THREADS is not set
-HAVE_DOT_CONFIG=y
-# HAVE_NO_PIC is not set
-# HAVE_NO_SSP is not set
-HAVE_SHARED=y
-KERNEL_HEADERS="."
-LDSO_BASE_FILENAME="ld.so"
-LDSO_CACHE_SUPPORT=y
-# LDSO_GNU_HASH_SUPPORT is not set
-LDSO_LDD_SUPPORT=y
-# LDSO_PRELOAD_FILE_SUPPORT is not set
-LDSO_RUNPATH=y
-LDSO_SEARCH_INTERP_PATH=y
-# LINUXTHREADS_NEW is not set
-# LINUXTHREADS_OLD is not set
-# MALLOC is not set
-MALLOC_GLIBC_COMPAT=y
-# MALLOC_SIMPLE is not set
-MALLOC_STANDARD=y
-# PTHREADS_DEBUG_SUPPORT is not set
-RUNTIME_PREFIX="/"
-SHARED_LIB_LOADER_PREFIX="/lib"
-# SUPPORT_LD_DEBUG is not set
-# SUPPORT_LD_DEBUG_EARLY is not set
-TARGET_SUBARCH=""
-# TARGET_alpha is not set
-# TARGET_arm is not set
-# TARGET_avr32 is not set
-# TARGET_bfin is not set
-# TARGET_cris is not set
-# TARGET_e1 is not set
-# TARGET_frv is not set
-# TARGET_h8300 is not set
-# TARGET_hppa is not set
-# TARGET_i386 is not set
-# TARGET_i960 is not set
-# TARGET_ia64 is not set
-# TARGET_m68k is not set
-# TARGET_microblaze is not set
-# TARGET_mips is not set
-# TARGET_nios is not set
-# TARGET_nios2 is not set
-# TARGET_powerpc is not set
-# TARGET_sh is not set
-# TARGET_sh64 is not set
-# TARGET_sparc is not set
-# TARGET_v850 is not set
-# TARGET_vax is not set
-# TARGET_x86_64 is not set
-# TARGET_xtensa is not set
-UCLIBC_BSD_SPECIFIC=y
-UCLIBC_BUILD_NOEXECSTACK=y
-# UCLIBC_BUILD_NOW is not set
-# UCLIBC_BUILD_PIE is not set
-UCLIBC_BUILD_RELRO=y
-UCLIBC_CTOR_DTOR=y
-UCLIBC_DYNAMIC_ATEXIT=y
-UCLIBC_EXTRA_CFLAGS=""
-UCLIBC_GRP_BUFFER_SIZE=256
-UCLIBC_HAS_ADVANCED_REALTIME=y
-# UCLIBC_HAS_ARC4RANDOM is not set
-UCLIBC_HAS_BSD_ERR=y
-UCLIBC_HAS_BSD_RES_CLOSE=y
-UCLIBC_HAS_COMPAT_RES_STATE=y
-UCLIBC_HAS_CRYPT=y
-UCLIBC_HAS_CRYPT_IMPL=y
-UCLIBC_HAS_CTYPE_CHECKED=y
-# UCLIBC_HAS_CTYPE_ENFORCED is not set
-UCLIBC_HAS_CTYPE_SIGNED=y
-UCLIBC_HAS_CTYPE_TABLES=y
-# UCLIBC_HAS_CTYPE_UNSAFE is not set
-UCLIBC_HAS_EPOLL=y
-UCLIBC_HAS_ERRNO_MESSAGES=y
-# UCLIBC_HAS_EXTRA_COMPAT_RES_STATE is not set
-# UCLIBC_HAS_FENV is not set
-UCLIBC_HAS_FLOATS=y
-UCLIBC_HAS_FNMATCH=y
-UCLIBC_HAS_FNMATCH_OLD=y
-UCLIBC_HAS_FOPEN_EXCLUSIVE_MODE=y
-# UCLIBC_HAS_FOPEN_LARGEFILE_MODE is not set
-# UCLIBC_HAS_FPU is not set
-UCLIBC_HAS_FTW=y
-UCLIBC_HAS_FULL_RPC=y
-UCLIBC_HAS_GETPT=y
-UCLIBC_HAS_GLIBC_CUSTOM_PRINTF=y
-UCLIBC_HAS_GLIBC_CUSTOM_STREAMS=y
-UCLIBC_HAS_GLOB=y
-UCLIBC_HAS_GNU_ERROR=y
-UCLIBC_HAS_GNU_GETOPT=y
-UCLIBC_HAS_GNU_GETSUBOPT=y
-UCLIBC_HAS_GNU_GLOB=y
-UCLIBC_HAS_HEXADECIMAL_FLOATS=y
-UCLIBC_HAS_IPV4=y
-UCLIBC_HAS_IPV6=y
-UCLIBC_HAS_LFS=y
-UCLIBC_HAS_LIBNSL_STUB=y
-UCLIBC_HAS_LIBRESOLV_STUB=y
-UCLIBC_HAS_LIBUTIL=y
-# UCLIBC_HAS_LOCALE is not set
-UCLIBC_HAS_NETWORK_SUPPORT=y
-# UCLIBC_HAS_NFTW is not set
-# UCLIBC_HAS_OBSOLETE_BSD_SIGNAL is not set
-# UCLIBC_HAS_OBSOLETE_SYSV_SIGNAL is not set
-UCLIBC_HAS_PRINTF_M_SPEC=y
-# UCLIBC_HAS_PROFILING is not set
-UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
-UCLIBC_HAS_PTY=y
-UCLIBC_HAS_REALTIME=y
-# UCLIBC_HAS_REENTRANT_RPC is not set
-UCLIBC_HAS_REGEX=y
-UCLIBC_HAS_REGEX_OLD=y
-UCLIBC_HAS_RPC=y
-UCLIBC_HAS_SCANF_GLIBC_A_FLAG=y
-UCLIBC_HAS_SHADOW=y
-UCLIBC_HAS_SIGNUM_MESSAGES=y
-UCLIBC_HAS_SOCKET=y
-UCLIBC_HAS_SOFT_FLOAT=y
-# UCLIBC_HAS_SSP is not set
-UCLIBC_HAS_STDIO_AUTO_RW_TRANSITION=y
-# UCLIBC_HAS_STDIO_BUFSIZ_1024 is not set
-# UCLIBC_HAS_STDIO_BUFSIZ_2048 is not set
-# UCLIBC_HAS_STDIO_BUFSIZ_256 is not set
-UCLIBC_HAS_STDIO_BUFSIZ_4096=y
-# UCLIBC_HAS_STDIO_BUFSIZ_512 is not set
-# UCLIBC_HAS_STDIO_BUFSIZ_8192 is not set
-# UCLIBC_HAS_STDIO_BUFSIZ_NONE is not set
-# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_4 is not set
-# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_8 is not set
-UCLIBC_HAS_STDIO_BUILTIN_BUFFER_NONE=y
-UCLIBC_HAS_STDIO_FUTEXES=y
-UCLIBC_HAS_STDIO_GETC_MACRO=y
-UCLIBC_HAS_STDIO_PUTC_MACRO=y
-# UCLIBC_HAS_STDIO_SHUTDOWN_ON_ABORT is not set
-UCLIBC_HAS_STRING_ARCH_OPT=y
-UCLIBC_HAS_STRING_GENERIC_OPT=y
-# UCLIBC_HAS_STUBS is not set
-UCLIBC_HAS_SYSLOG=y
-# UCLIBC_HAS_SYS_ERRLIST is not set
-# UCLIBC_HAS_SYS_SIGLIST is not set
-UCLIBC_HAS_THREADS=y
-UCLIBC_HAS_THREADS_NATIVE=y
-UCLIBC_HAS_TLS=y
-UCLIBC_HAS_TM_EXTENSIONS=y
-UCLIBC_HAS_TZ_CACHING=y
-UCLIBC_HAS_TZ_FILE=y
-UCLIBC_HAS_TZ_FILE_READ_MANY=y
-UCLIBC_HAS_WCHAR=y
-UCLIBC_HAS_WORDEXP=y
-# UCLIBC_HAS_XATTR is not set
-UCLIBC_HAS___PROGNAME=y
-# UCLIBC_LINUX_MODULE_24 is not set
-UCLIBC_LINUX_SPECIFIC=y
-# UCLIBC_MALLOC_DEBUGGING is not set
-# UCLIBC_MJN3_ONLY is not set
-# UCLIBC_NTP_LEGACY is not set
-UCLIBC_PRINTF_SCANF_POSITIONAL_ARGS=9
-UCLIBC_PWD_BUFFER_SIZE=256
-# UCLIBC_STATIC_LDCONFIG is not set
-# UCLIBC_SUPPORT_AI_ADDRCONFIG is not set
-UCLIBC_SUSV3_LEGACY=y
-UCLIBC_SUSV3_LEGACY_MACROS=y
-UCLIBC_SUSV4_LEGACY=y
-# UCLIBC_SV4_DEPRECATED is not set
-UCLIBC_TZ_FILE_PATH="/etc/TZ"
-UCLIBC_USE_NETLINK=y
-# UNIX98PTY_ONLY is not set
-USE_BX=y
-WARNINGS="-Wall"
diff --git a/toolchain/uClibc/config-0.9.30+nptl/cris b/toolchain/uClibc/config-0.9.30+nptl/cris
deleted file mode 100644 (file)
index b9ea676..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-ARCH_LITTLE_ENDIAN=y
-CONFIG_CRIS=y
-# CONFIG_CRISV32 is not set
-TARGET_ARCH="cris"
-TARGET_cris=y
-UCLIBC_HAS_FPU=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/debug b/toolchain/uClibc/config-0.9.30+nptl/debug
deleted file mode 100644 (file)
index b366e66..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-DODEBUG=y
-DODEBUG_PT=y
-PTHREADS_DEBUG_SUPPORT=y
-SUPPORT_LD_DEBUG=y
-SUPPORT_LD_DEBUG_EARLY=y
-UCLIBC_MALLOC_DEBUGGING=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/i386 b/toolchain/uClibc/config-0.9.30+nptl/i386
deleted file mode 100644 (file)
index 521ce8c..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-ARCH_LITTLE_ENDIAN=y
-# CONFIG_386 is not set
-CONFIG_486=y
-# CONFIG_586 is not set
-# CONFIG_586MMX is not set
-# CONFIG_686 is not set
-# CONFIG_CRUSOE is not set
-# CONFIG_CYRIXIII is not set
-# CONFIG_ELAN is not set
-# CONFIG_GENERIC_386 is not set
-# CONFIG_K6 is not set
-# CONFIG_K7 is not set
-# CONFIG_NEHEMIAH is not set
-# CONFIG_PENTIUM4 is not set
-# CONFIG_PENTIUMII is not set
-# CONFIG_PENTIUMIII is not set
-# CONFIG_WINCHIP2 is not set
-# CONFIG_WINCHIPC6 is not set
-LINUXTHREADS_NEW=y
-# LINUXTHREADS_OLD is not set
-TARGET_ARCH="i386"
-TARGET_i386=y
-UCLIBC_HAS_FPU=y
-UCLIBC_HAS_LONG_DOUBLE_MATH=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/i686 b/toolchain/uClibc/config-0.9.30+nptl/i686
deleted file mode 100644 (file)
index 22379f4..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-ARCH_LITTLE_ENDIAN=y
-# CONFIG_386 is not set
-# CONFIG_486 is not set
-# CONFIG_586 is not set
-# CONFIG_586MMX is not set
-CONFIG_686=y
-# CONFIG_CRUSOE is not set
-# CONFIG_CYRIXIII is not set
-# CONFIG_ELAN is not set
-# CONFIG_GENERIC_386 is not set
-# CONFIG_K6 is not set
-# CONFIG_K7 is not set
-# CONFIG_NEHEMIAH is not set
-# CONFIG_PENTIUM4 is not set
-# CONFIG_PENTIUMII is not set
-# CONFIG_PENTIUMIII is not set
-# CONFIG_WINCHIP2 is not set
-# CONFIG_WINCHIPC6 is not set
-LINUXTHREADS_NEW=y
-# LINUXTHREADS_OLD is not set
-TARGET_ARCH="i386"
-TARGET_i386=y
-UCLIBC_HAS_FPU=y
-UCLIBC_HAS_LONG_DOUBLE_MATH=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/m68k b/toolchain/uClibc/config-0.9.30+nptl/m68k
deleted file mode 100644 (file)
index ae98491..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-ARCH_BIG_ENDIAN=y
-TARGET_ARCH="m68k"
-TARGET_SUBARCH=""
-TARGET_m68k=y
-UCLIBC_HAS_LONG_DOUBLE_MATH=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/mips b/toolchain/uClibc/config-0.9.30+nptl/mips
deleted file mode 100644 (file)
index 7398c66..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_BIG_ENDIAN=y
-ARCH_CFLAGS="-mno-split-addresses"
-ARCH_WANTS_BIG_ENDIAN=y
-# CONFIG_MIPS_ISA_1 is not set
-# CONFIG_MIPS_ISA_2 is not set
-# CONFIG_MIPS_ISA_3 is not set
-# CONFIG_MIPS_ISA_4 is not set
-CONFIG_MIPS_ISA_MIPS32=y
-# CONFIG_MIPS_ISA_MIPS32R2 is not set
-# CONFIG_MIPS_ISA_MIPS64 is not set
-# CONFIG_MIPS_N32_ABI is not set
-# CONFIG_MIPS_N64_ABI is not set
-CONFIG_MIPS_O32_ABI=y
-TARGET_ARCH="mips"
-TARGET_mips=y
-UCLIBC_HAS_FPU=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/mips64 b/toolchain/uClibc/config-0.9.30+nptl/mips64
deleted file mode 100644 (file)
index fa5bee3..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_BIG_ENDIAN=y
-ARCH_CFLAGS="-mno-split-addresses"
-ARCH_WANTS_BIG_ENDIAN=y
-# CONFIG_MIPS_ISA_1 is not set
-# CONFIG_MIPS_ISA_2 is not set
-# CONFIG_MIPS_ISA_3 is not set
-# CONFIG_MIPS_ISA_4 is not set
-# CONFIG_MIPS_ISA_MIPS32 is not set
-# CONFIG_MIPS_ISA_MIPS32R2 is not set
-CONFIG_MIPS_ISA_MIPS64=y
-# CONFIG_MIPS_N32_ABI is not set
-CONFIG_MIPS_N64_ABI=y
-# CONFIG_MIPS_O32_ABI is not set
-TARGET_ARCH="mips"
-TARGET_mips=y
-UCLIBC_HAS_FPU=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/mips64el b/toolchain/uClibc/config-0.9.30+nptl/mips64el
deleted file mode 100644 (file)
index 1ca764f..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_CFLAGS="-mno-split-addresses"
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_MIPS_ISA_1 is not set
-# CONFIG_MIPS_ISA_2 is not set
-# CONFIG_MIPS_ISA_3 is not set
-# CONFIG_MIPS_ISA_4 is not set
-# CONFIG_MIPS_ISA_MIPS32 is not set
-# CONFIG_MIPS_ISA_MIPS32R2 is not set
-CONFIG_MIPS_ISA_MIPS64=y
-# CONFIG_MIPS_N32_ABI is not set
-CONFIG_MIPS_N64_ABI=y
-# CONFIG_MIPS_O32_ABI is not set
-TARGET_ARCH="mips"
-TARGET_mips=y
-UCLIBC_HAS_FPU=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/mipsel b/toolchain/uClibc/config-0.9.30+nptl/mipsel
deleted file mode 100644 (file)
index 7648f39..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_CFLAGS="-mno-split-addresses"
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_MIPS_ISA_1 is not set
-# CONFIG_MIPS_ISA_2 is not set
-# CONFIG_MIPS_ISA_3 is not set
-# CONFIG_MIPS_ISA_4 is not set
-CONFIG_MIPS_ISA_MIPS32=y
-# CONFIG_MIPS_ISA_MIPS32R2 is not set
-# CONFIG_MIPS_ISA_MIPS64 is not set
-# CONFIG_MIPS_N32_ABI is not set
-# CONFIG_MIPS_N64_ABI is not set
-CONFIG_MIPS_O32_ABI=y
-TARGET_ARCH="mips"
-TARGET_mips=y
-UCLIBC_HAS_FPU=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/mipsel.brcm-2.4 b/toolchain/uClibc/config-0.9.30+nptl/mipsel.brcm-2.4
deleted file mode 100644 (file)
index 7857868..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-ARCH_ANY_ENDIAN=y
-ARCH_CFLAGS="-mno-split-addresses"
-ARCH_LITTLE_ENDIAN=y
-ARCH_WANTS_LITTLE_ENDIAN=y
-# CONFIG_MIPS_ISA_1 is not set
-# CONFIG_MIPS_ISA_2 is not set
-# CONFIG_MIPS_ISA_3 is not set
-# CONFIG_MIPS_ISA_4 is not set
-CONFIG_MIPS_ISA_MIPS32=y
-# CONFIG_MIPS_ISA_MIPS32R2 is not set
-# CONFIG_MIPS_ISA_MIPS64 is not set
-# CONFIG_MIPS_N32_ABI is not set
-# CONFIG_MIPS_N64_ABI is not set
-CONFIG_MIPS_O32_ABI=y
-TARGET_ARCH="mips"
-TARGET_mips=y
-UCLIBC_HAS_FPU=y
-UCLIBC_LINUX_MODULE_24=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/powerpc b/toolchain/uClibc/config-0.9.30+nptl/powerpc
deleted file mode 100644 (file)
index 4e5cd43..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-ARCH_BIG_ENDIAN=y
-CONFIG_CLASSIC=y
-# CONFIG_E500 is not set
-TARGET_ARCH="powerpc"
-TARGET_SUBARCH="classic"
-TARGET_powerpc=y
-UCLIBC_HAS_LONG_DOUBLE_MATH=y
diff --git a/toolchain/uClibc/config-0.9.30+nptl/x86_64 b/toolchain/uClibc/config-0.9.30+nptl/x86_64
deleted file mode 100644 (file)
index 20a18f1..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-ARCH_LITTLE_ENDIAN=y
-# LINUXTHREADS_NEW is not set
-TARGET_ARCH="x86_64"
-TARGET_x86_64=y
-UCLIBC_BSD_SPECIFIC=y 
-UCLIBC_HAS_FPU=y
-UCLIBC_HAS_LONG_DOUBLE_MATH=y
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/110-compat_macros.patch b/toolchain/uClibc/patches-0.9.30+nptl/110-compat_macros.patch
deleted file mode 100644 (file)
index 7659e46..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
---- ./include/string.h.orig    2008-06-08 22:38:53.000000000 +0200
-+++ ./include/string.h 2009-01-02 16:09:03.000000000 +0100
-@@ -355,18 +355,40 @@
- /* Find the last occurrence of C in S (same as strrchr).  */
- extern char *rindex (__const char *__s, int __c)
-      __THROW __attribute_pure__ __nonnull ((1));
--# else
--#  ifdef __UCLIBC_SUSV3_LEGACY_MACROS__
-+# elif defined(__UCLIBC_SUSV3_LEGACY_MACROS__) && !defined(_STRINGS_H)
- /* bcopy/bzero/bcmp/index/rindex are marked LEGACY in SuSv3.
-  * They are replaced as proposed by SuSv3. Don't sync this part
-  * with glibc and keep it in sync with strings.h.  */
--#  define bcopy(src,dest,n) (memmove((dest), (src), (n)), (void) 0)
--#  define bzero(s,n) (memset((s), '\0', (n)), (void) 0)
--#  define bcmp(s1,s2,n) memcmp((s1), (s2), (size_t)(n))
--#  define index(s,c) strchr((s), (c))
--#  define rindex(s,c) strrchr((s), (c))
--#  endif
-+/* Copy N bytes of SRC to DEST (like memmove, but args reversed).  */
-+static __inline__ void bcopy (__const void *__src, void *__dest, size_t __n)
-+{
-+      memmove(__dest, __src, __n);
-+}
-+
-+/* Set N bytes of S to 0.  */
-+static __inline__ void bzero (void *__s, size_t __n)
-+{
-+      memset(__s, 0, __n);
-+}
-+
-+/* Compare N bytes of S1 and S2 (same as memcmp).  */
-+static __inline__ int bcmp (__const void *__s1, __const void *__s2, size_t __n)
-+{
-+      return memcmp(__s1, __s2, __n);
-+}
-+
-+/* Find the first occurrence of C in S (same as strchr).  */
-+static __inline__ char *index (__const char *__s, int __c)
-+{
-+      return strchr(__s, __c);
-+}
-+
-+/* Find the last occurrence of C in S (same as strrchr).  */
-+static __inline__ char *rindex (__const char *__s, int __c)
-+{
-+      return strrchr(__s, __c);
-+}
- # endif
- /* Return the position of the first bit set in I, or 0 if none are set.
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/130-compile_fix.patch b/toolchain/uClibc/patches-0.9.30+nptl/130-compile_fix.patch
deleted file mode 100644 (file)
index ed3812a..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/librt/mq_receive.c
-+++ b/librt/mq_receive.c
-@@ -6,7 +6,8 @@
- #include <stddef.h>
- #include <sys/syscall.h>
- #include <mqueue.h>
--#warning FIXME: hard dependency on ADVANCED REALTIME feature
-+
-+#ifdef __UCLIBC_HAS_ADVANCED_REALTIME__
- librt_hidden_proto(mq_timedreceive)
-@@ -44,3 +45,5 @@ ssize_t mq_receive(mqd_t mqdes, char *ms
- {
-       return mq_timedreceive(mqdes, msg_ptr, msg_len, msg_prio, NULL);
- }
-+
-+#endif /* __UCLIBC_HAS_ADVANCED_REALTIME__ */
---- a/librt/mq_send.c
-+++ b/librt/mq_send.c
-@@ -6,7 +6,8 @@
- #include <stddef.h>
- #include <sys/syscall.h>
- #include <mqueue.h>
--#warning FIXME: hard dependency on ADVANCED REALTIME feature
-+
-+#ifdef __UCLIBC_HAS_ADVANCED_REALTIME__
- librt_hidden_proto(mq_timedsend)
-@@ -43,3 +44,5 @@ int mq_send(mqd_t mqdes, const char *msg
- {
-       return mq_timedsend(mqdes, msg_ptr, msg_len, msg_prio, NULL);
- }
-+
-+#endif /* __UCLIBC_HAS_ADVANCED_REALTIME__ */
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/140-math_finite.patch b/toolchain/uClibc/patches-0.9.30+nptl/140-math_finite.patch
deleted file mode 100644 (file)
index 9731772..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/include/math.h
-+++ b/include/math.h
-@@ -179,7 +179,7 @@
- /* ISO C99 defines some generic macros which work on any data type.  */
--#ifdef __USE_ISOC99
-+#if defined(__USE_ISOC99) || defined(__USE_BSD)
- /* Get the architecture specific values describing the floating-point
-    evaluation.  The following symbols will get defined:
-@@ -299,6 +299,11 @@
- #endif /* Use ISO C99.  */
-+/* BSD compat */
-+#define finite(x) __finite(x)
-+#define finitef(x) __finitef(x)
-+#define finitel(x) __finitel(x)
-+
- #ifdef        __USE_MISC
- /* Support for various different standard error handling behaviors.  */
- typedef enum
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch b/toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch
deleted file mode 100644 (file)
index bfa5558..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/libpthread/nptl/Makefile.in
-+++ b/libpthread/nptl/Makefile.in
-@@ -174,7 +174,7 @@
- CFLAGS-pthread_barrierattr_setpshared.c = -D_GNU_SOURCE
- CFLAGS-sem_open.c = -D_GNU_SOURCE
--CFLAGS-nptl = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 $(SSP_ALL_CFLAGS)
-+CFLAGS-nptl = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 -std=gnu99 $(SSP_ALL_CFLAGS)
- CFLAGS-OMIT-alloca_cutoff.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
- CFLAGS-OMIT-forward.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
---- a/libpthread/nptl/sysdeps/unix/sysv/linux/Makefile.in
-+++ b/libpthread/nptl/sysdeps/unix/sysv/linux/Makefile.in
-@@ -82,7 +82,7 @@
- CFLAGS-timer_routines.c = -I$(top_srcdir)librt -DIS_IN_librt=1
- CFLAGS-timer_settime.c = -I$(top_srcdir)librt -DIS_IN_librt=1
--CFLAGS-linux = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 $(SSP_ALL_CFLAGS)
-+CFLAGS-linux = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 -std=gnu99 $(SSP_ALL_CFLAGS)
- #CFLAGS:=$(CFLAGS:-O1=-O2)
- CFLAGS-OMIT-libc_pthread_init.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
---- a/ldso/ldso/Makefile.in
-+++ b/ldso/ldso/Makefile.in
-@@ -13,7 +13,7 @@
- CFLAGS-ldso += -fno-omit-frame-pointer
- CFLAGS-ldso += -I$(top_srcdir)ldso/ldso/$(TARGET_ARCH) -I$(top_srcdir)ldso/include -I$(top_srcdir)ldso/ldso
--CFLAGS-ldso += -DUCLIBC_RUNTIME_PREFIX=\"$(RUNTIME_PREFIX)\" -DUCLIBC_LDSO=\"$(UCLIBC_LDSO)\"
-+CFLAGS-ldso += -DUCLIBC_RUNTIME_PREFIX=\"$(RUNTIME_PREFIX)\" -DUCLIBC_LDSO=\"$(UCLIBC_LDSO)\" -std=gnu99
- ifeq ($(DODEBUG),y)
- # Not really much point in including debugging info, since gdb
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/350-use-fputs_unlocked.patch b/toolchain/uClibc/patches-0.9.30+nptl/350-use-fputs_unlocked.patch
deleted file mode 100644 (file)
index b2cd37f..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-commit 3e3ae40f053b22fbb9bef50067d6edad4c358c4c
-Author: Mirko Vogt <dev@nanl.de>
-Date:   Tue May 24 14:36:42 2011 +0200
-
-    use 'fputws_unlocked(S,F)' instead of 'fputws(S,F)'
-    
-    this eliminates a source of reproduceable freezes
-
-diff --git a/libc/stdio/_vfprintf.c b/libc/stdio/_vfprintf.c
-index 3db8cdf..069db16 100644
---- a/libc/stdio/_vfprintf.c
-+++ b/libc/stdio/_vfprintf.c
-@@ -1229,7 +1229,7 @@ static size_t _fp_out_narrow(FILE *fp, intptr_t type, intptr_t len, intptr_t buf
- #define STRLEN  wcslen
- #define _PPFS_init _ppwfs_init
- /* Pulls in fseek: */
--#define OUTPUT(F,S)                   fputws(S,F)
-+#define OUTPUT(F,S)                   fputws_unlocked(S,F)
- /* TODO: #define OUTPUT(F,S)          _wstdio_fwrite((S),wcslen(S),(F)) */
- #define _outnwcs(stream, wstring, len)        _wstdio_fwrite((const wchar_t *)(wstring), len, stream)
- #define FP_OUT _fp_out_wide