add a patch to use a reasonable heap size (reported by Dex), bump release number
authorNicolas Thill <nico@openwrt.org>
Fri, 4 Nov 2005 23:42:11 +0000 (23:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 4 Nov 2005 23:42:11 +0000 (23:42 +0000)
SVN-Revision: 2332

openwrt/package/sablevm/Makefile
openwrt/package/sablevm/patches/001-heap_size.patch [new file with mode: 0644]

index e57fdb225657b60d8540cfe36394f67137859940..b683d647819b1c00f076922e9ae12d614330f6e8 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sablevm
 PKG_VERSION:=1.11.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=aea6e808c5f2e3646a60971485220bff
 
 PKG_SOURCE_URL:=http://sablevm.org/download/release/$(PKG_VERSION)/
diff --git a/openwrt/package/sablevm/patches/001-heap_size.patch b/openwrt/package/sablevm/patches/001-heap_size.patch
new file mode 100644 (file)
index 0000000..d282372
--- /dev/null
@@ -0,0 +1,15 @@
+diff -ruN sablevm-1.11.1-orig/src/libsablevm/system.h sablevm-1.11.1-1/src/libsablevm/system.h
+--- sablevm-1.11.1-orig/src/libsablevm/system.h        2005-03-18 01:25:09.000000000 +0100
++++ sablevm-1.11.1-1/src/libsablevm/system.h   2005-03-22 01:05:19.000000000 +0100
+@@ -279,9 +279,9 @@
+ #elif defined (_SABLEVM_COPY_GC) || (_SABLEVM_GENCOPY_GC)
+-#define SVM_HEAP_DEFAULT_MIN_SIZE 16777216
++#define SVM_HEAP_DEFAULT_MIN_SIZE 1048576
+ #define SVM_HEAP_DEFAULT_MAX_SIZE 0
+-#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 1048576
++#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 65536
+ #if defined (_SABLEVM_GENCOPY_GC)