AA: firewall: backport r35348
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 28 Jan 2013 15:59:01 +0000 (15:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 28 Jan 2013 15:59:01 +0000 (15:59 +0000)
SVN-Revision: 35350

package/firewall/Makefile
package/firewall/files/lib/core_interface.sh

index 4d7970a502c8a2ad4779e8b1acd0b7372bb1557e..b2be06b30c8995cdccd75f5a2f711bedabe8726a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=55
+PKG_RELEASE:=55.1
 
 include $(INCLUDE_DIR)/package.mk
 
index 3d6718431fb2f0fecce58f505bdc3c856ab96c6d..7400e2d35112b065a52c82c10cdf0e29e047af8f 100644 (file)
@@ -106,6 +106,9 @@ fw_configure_interface() {
                fw $action $mode r PREROUTING ${chain}_notrack    $ { -i "$ifname" $inet }
                fw $action $mode n POSTROUTING ${chain}_nat       $ { -o "$ifname" $onet }
 
+               # Flush conntrack table
+               echo f >/proc/net/nf_conntrack 2>/dev/null
+
                lock -u /var/run/firewall-interface.lock
        }