[backfire/packages] revert accidentally committed modeswitch changes from r29036
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 13 Nov 2011 18:37:59 +0000 (18:37 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 13 Nov 2011 18:37:59 +0000 (18:37 +0000)
SVN-Revision: 29038

utils/usb-modeswitch-data/Makefile
utils/usb-modeswitch/Makefile
utils/usb-modeswitch/files/modeswitch.hotplug

index d21a2ca9c1b2fbe6df49ba13eba28b8ba2152cdf..ed579c06c20385d89a5a53b6f19cd82fee0f3f1c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usb-modeswitch-data
-PKG_VERSION:=20111023
+PKG_VERSION:=20110705
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.draisberghof.de/usb_modeswitch/
-PKG_MD5SUM:=6e7cb67d0428bda241600b038ba11aeb
+PKG_MD5SUM:=5046e7be8d10d2fe699f9af21a0c3769
 
 include $(INCLUDE_DIR)/package.mk
 
index c033c7291404ecf1c7ef5e048d3155b2179de4dd..411f0a5eab2852e6432061e25d8d10abc117f641 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usb-modeswitch
-PKG_VERSION:=1.2.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.draisberghof.de/usb_modeswitch
-PKG_MD5SUM:=1932ab96d6e3c5e0a6bdfac863338627
+PKG_MD5SUM:=1aaaa45e0465843e4973d7778bfbafbb
 
 include $(INCLUDE_DIR)/package.mk
 
index 8042451373b57bd13a714923fd17243127460ecd..1aecb1fb3150da9b28cbed8d3057b208a5836e50 100644 (file)
@@ -120,20 +120,7 @@ if [ "$ACTION" = add ]; then
                # If a candidate is remaining, start usb-modeswitch
                [ -n "$configs" ] && {
                        log "$DEVICENAME: Selecting ${configs%% *} for mode switching"
-                       # ugly workaround, but working for all hw we got for testing
-                       switching_done=0
-                       switching_tries=0
-                       local usb_dir="/sys/$DEVPATH"       
-                       [ -f "$usb_dir/idVendor" ] || usb_dir="${usb_dir%/*}"
-                       while [ $switching_done -lt 1 -a $switching_tries -le 6 ]; do
-                               $modeswitch -I -D -n -s 30 -c "${configs%% *}"
-                               if [ $(sanitize "$usb_dir/idProduct") = $uPid ]; then
-                                       log "switching seemingly failed"
-                               else
-                                       switching_done=1
-                               fi
-                               switching_tries=$(( $switching_tries + 1 ))
-                       done
+                       $modeswitch -c "${configs%% *}"
                }
        }
 fi