build: fix including modules.mk for targets pulled in from feeds
authorFelix Fietkau <nbd@nbd.name>
Sun, 18 Sep 2022 04:27:09 +0000 (06:27 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 27 Sep 2022 11:45:03 +0000 (13:45 +0200)
Fixes: ebc36ebb2349 ("scripts/feeds: install targets to target/linux/feeds and support overriding")
Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry-picked from commit 00094efec33f07c9dc16cce23be492430c40b3cc)

package/kernel/linux/Makefile

index 9fa68d78f722f414de60a01467615fa2220a20b1..ad68bde9b3137b27554742ac49dae5c693b9f923 100644 (file)
@@ -12,7 +12,7 @@ PKG_NAME:=kernel
 PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk $(TOPDIR)/include/netfilter.mk
+SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk $(TOPDIR)/target/linux/*/*/modules.mk $(TOPDIR)/include/netfilter.mk
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=
@@ -64,3 +64,4 @@ $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
 include $(sort $(wildcard ./modules/*.mk))
 -include $(TOPDIR)/target/linux/*/modules.mk
+-include $(TOPDIR)/target/linux/*/*/modules.mk