update busybox to v1.1.3, remove passwd_salt patch (fixed upstream).
authorNicolas Thill <nico@openwrt.org>
Thu, 18 May 2006 08:32:07 +0000 (08:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 18 May 2006 08:32:07 +0000 (08:32 +0000)
SVN-Revision: 3794

openwrt/package/busybox/Makefile
openwrt/package/busybox/patches/230-passwd_salt.patch [deleted file]

index 35f954b931ef5e309653718d03ef31f4bdad056a..83c74ff4cf7d1a07898f01e7e6ff0c251fdc855f 100644 (file)
@@ -13,11 +13,11 @@ PKG_SOURCE:=$(PKG_NAME)-snapshot.tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads/snapshots
 PKG_MD5SUM:=x
 else
-PKG_VERSION:=1.1.2
+PKG_VERSION:=1.1.3
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads
-PKG_MD5SUM:=0b5d78072302fe687407956537bdb9e3
+PKG_MD5SUM:=19a0b475169335f17e421cf644616fe7
 endif
 PKG_CAT:=bzcat
 
diff --git a/openwrt/package/busybox/patches/230-passwd_salt.patch b/openwrt/package/busybox/patches/230-passwd_salt.patch
deleted file mode 100644 (file)
index 0322a98..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- busybox-1.00/loginutils/passwd.c   2006-03-26 06:07:37 -05:00
-+++ busybox-1.00/loginutils/passwd.c   2006-03-26 06:09:03 -05:00
-@@ -386,7 +386,9 @@
-       bzero(orig, sizeof(orig));
-       if (algo == 1) {
--              cp = pw_encrypt(pass, "$1$");
-+              char salt[6]="$1$\0\0\0";
-+              memcpy(salt+3,crypt_make_salt(),3);
-+              cp = pw_encrypt(pass, salt);
-       } else
-               cp = pw_encrypt(pass, crypt_make_salt());
-       bzero(pass, sizeof pass);