kernel: load FAT filesystem drivers before mount_root
authorTomasz Maciej Nowak <tmn505@gmail.com>
Mon, 29 Aug 2022 14:22:18 +0000 (16:22 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 7 Sep 2022 19:21:38 +0000 (21:21 +0200)
Devices using GPT usually have FAT filesystem on boot partition and
that's where the intermediary backup of system configuration is stored
on sysupgrade. Automatic restoring of OpenWrt configuration after
sysupgrade will be inhibited if the driver is not loaded and file system
type is not specified in mount command.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
package/kernel/linux/modules/fs.mk

index 0e4c0c091a5ad637ee696e1485b579dfa934b503..3ad458286f450e359f7e2e5576ea0ae8ef29189a 100644 (file)
@@ -601,7 +601,7 @@ define KernelPackage/fs-vfat
   FILES:= \
        $(LINUX_DIR)/fs/fat/fat.ko \
        $(LINUX_DIR)/fs/fat/vfat.ko
-  AUTOLOAD:=$(call AutoLoad,30,fat vfat)
+  AUTOLOAD:=$(call AutoLoad,30,fat vfat,1)
   $(call AddDepends/nls,cp437 iso8859-1 utf8)
 endef