iptables: patch CVE-2019-11360 (security fix)
authorJan Pavlinec <jan.pavlinec@nic.cz>
Thu, 15 Aug 2019 10:51:52 +0000 (12:51 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Aug 2019 15:23:17 +0000 (17:23 +0200)
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
package/network/utils/iptables/Makefile
package/network/utils/iptables/patches/900-fix-cve-2019-11360.patch [new file with mode: 0644]

index 9c7179c51dc950b82df83b45f8fab184b93a48d1..ac3712b498b4937fa3d3f75f706b48efb847b568 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.6.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.netfilter.org/iptables
diff --git a/package/network/utils/iptables/patches/900-fix-cve-2019-11360.patch b/package/network/utils/iptables/patches/900-fix-cve-2019-11360.patch
new file mode 100644 (file)
index 0000000..10d8c31
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/iptables/iptables-restore.c
++++ b/iptables/iptables-restore.c
+@@ -129,6 +129,10 @@ static void add_param_to_argv(char *pars
+        * longer a real hacker, but I can live with that */
+       for (curchar = parsestart; *curchar; curchar++) {
++              if (param_len >= sizeof(param_buffer))
++                      xtables_error(PARAMETER_PROBLEM,
++                      "Parameter too long!");
++
+               if (quote_open) {
+                       if (escaped) {
+                               param_buffer[param_len++] = *curchar;