realtek: move hpe_1920 recipe to common.mk
authorSander Vanheule <sander@svanheule.net>
Sat, 17 Sep 2022 20:20:30 +0000 (22:20 +0200)
committerSander Vanheule <sander@svanheule.net>
Sat, 17 Sep 2022 20:20:32 +0000 (22:20 +0200)
Currently supported HPE 1920 devices all have an RTL838x SoC, but there
are larger switches with RTL839x SoCs, although currently not supported.
Move the build recipe to common.mk so the larger devices can also make
use of the recipe, while moving it out of the main Makefile.

Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/image/Makefile
target/linux/realtek/image/common.mk
target/linux/realtek/image/rtl838x.mk

index 6165d99bfc513cbdc9d9374eba53df2663ed8f69..7d35581488b99ed6f7a9f8f426f28973379bd494 100644 (file)
@@ -90,17 +90,6 @@ define Device/Default
        check-size | append-metadata
 endef
 
-define Device/hpe_1920
-  DEVICE_VENDOR := HPE
-  IMAGE_SIZE := 29632k
-  BLOCKSIZE := 64k
-  H3C_PRODUCT_ID := 0x3c010501
-  KERNEL := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image | h3c-vfs
-  KERNEL_INITRAMFS := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image
-  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
-       pad-rootfs | check-size | append-metadata
-endef
-
 # "NGE" refers to the uImage magic
 define Device/netgear_nge
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
index 59286b211d16f83140ab5a49f5a5cf31a1e92437..560cf6c8e69a0116d4d00bc27e18d3b6afad9326 100644 (file)
@@ -14,3 +14,14 @@ define Build/d-link_dgs-1210
         append-rootfs | pad-rootfs | pad-to 16 | check-size | \
         dlink-version | dlink-headers
 endef
+
+define Build/hpe_1920
+  DEVICE_VENDOR := HPE
+  IMAGE_SIZE := 29632k
+  BLOCKSIZE := 64k
+  H3C_PRODUCT_ID := 0x3c010501
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image | h3c-vfs
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+       pad-rootfs | check-size | append-metadata
+endef
index 2fe2013f702d0534dd3c56565f3263cb0839fbc4..b221ed74a24eae3aec14c0f4f79cfcffe5b7f2d9 100644 (file)
@@ -64,7 +64,7 @@ endef
 TARGET_DEVICES += engenius_ews2910p
 
 define Device/hpe_1920-8g
-  $(Device/hpe_1920)
+  $(Build/hpe_1920)
   SOC := rtl8380
   DEVICE_MODEL := 1920-8G (JG920A)
   H3C_DEVICE_ID := 0x00010023
@@ -72,7 +72,7 @@ endef
 TARGET_DEVICES += hpe_1920-8g
 
 define Device/hpe_1920-16g
-  $(Device/hpe_1920)
+  $(Build/hpe_1920)
   SOC := rtl8382
   DEVICE_MODEL := 1920-16G (JG923A)
   H3C_DEVICE_ID := 0x00010026
@@ -80,7 +80,7 @@ endef
 TARGET_DEVICES += hpe_1920-16g
 
 define Device/hpe_1920-24g
-  $(Device/hpe_1920)
+  $(Build/hpe_1920)
   SOC := rtl8382
   DEVICE_MODEL := 1920-24G (JG924A)
   H3C_DEVICE_ID := 0x00010027