add whiterussian change for compatibility with latest trunk package changes
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 10:51:26 +0000 (10:51 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 10:51:26 +0000 (10:51 +0000)
SVN-Revision: 2224

openwrt/package/rules.mk

index f7b81c62aff242465134abce78b454412db91850..5862ece405ae74b1e020d19b7112bbb24a9e9e4a 100644 (file)
@@ -54,10 +54,14 @@ endif
 
 all: compile
 
+compile-targets:
+install-targets:
+clean-targets:
+
 source: $(DL_DIR)/$(PKG_SOURCE)
 prepare: $(PKG_BUILD_DIR)/.prepared
-compile:
-install:
+compile: compile-targets
+install: install-targets
 mostlyclean:
 rebuild:
        -$(MAKE) mostlyclean
@@ -72,7 +76,7 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
 $(PACKAGE_DIR):
        mkdir -p $@
 
-clean: 
+clean: clean-targets
        rm -rf $(PKG_BUILD_DIR)
 
 .PHONY: all source prepare compile install clean