[backfire] packages: add libldns, merge r27602, r28780 & r28781 (closes: #10308)
authorNicolas Thill <nico@openwrt.org>
Tue, 15 Nov 2011 03:12:51 +0000 (03:12 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 15 Nov 2011 03:12:51 +0000 (03:12 +0000)
SVN-Revision: 29146

libs/ldns/Makefile [new file with mode: 0644]

diff --git a/libs/ldns/Makefile b/libs/ldns/Makefile
new file mode 100644 (file)
index 0000000..c60903b
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ldns
+PKG_VERSION:=1.6.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.nlnetlabs.nl/downloads/ldns
+PKG_MD5SUM:=c55b592a679672281712c457fbb41eb5
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libldns
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A library to simplify DNS programming
+  URL:=http://www.nlnetlabs.nl/projects/ldns/
+  DEPENDS:=+libopenssl
+endef
+
+CONFIGURE_ARGS += \
+       --disable-gost \
+       --with-ssl="$(STAGING_DIR)/usr"
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ldns $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libldns.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libldns/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libldns.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libldns))