libidn: moved to github
authorSteven Barth <cyrus@openwrt.org>
Sun, 13 Jul 2014 10:51:12 +0000 (10:51 +0000)
committerSteven Barth <cyrus@openwrt.org>
Sun, 13 Jul 2014 10:51:12 +0000 (10:51 +0000)
SVN-Revision: 41602

libs/libidn/Makefile [deleted file]
libs/libidn/patches/002-disable-po-docs-examples.patch [deleted file]

diff --git a/libs/libidn/Makefile b/libs/libidn/Makefile
deleted file mode 100644 (file)
index c23ce70..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2009-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libidn
-PKG_VERSION:=1.18
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/libidn
-PKG_MD5SUM:=66f115347439f56386f37a3ad92c1da2
-
-PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES:=GNUmakefile aclocal.m4
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libidn
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Stringprep, Punycode and IDNA implementation
-  URL:=http://www.gnu.org/software/libidn/
-endef
-
-define Package/libidn/description
-  GNU Libidn is a fully documented implementation of the Stringprep,
-  Punycode and IDNA specifications. Libidn's purpose is to encode and
-  decode internationalized domain names.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-
-MAKE_FLAGS += \
-       CC="$(TARGET_CC)" \
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libidn.{a,so*} $(1)/usr/lib/
-endef
-
-define Package/libidn/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libidn.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libidn))
diff --git a/libs/libidn/patches/002-disable-po-docs-examples.patch b/libs/libidn/patches/002-disable-po-docs-examples.patch
deleted file mode 100644 (file)
index 817749e..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -16,7 +16,7 @@
- # You should have received a copy of the GNU General Public License
- # along with this program.  If not, see <http://www.gnu.org/licenses/>.
--SUBDIRS = gl lib/gl lib po src doc gltests lib/gltests tests examples \
-+SUBDIRS = gl lib/gl lib src \
-       java csharp
- EXTRA_DIST = cfg.mk maint.mk .clcopying
---- a/configure.ac
-+++ b/configure.ac
-@@ -46,8 +46,6 @@ gl_EARLY
- AC_PROG_LIBTOOL
- AM_MISSING_PROG(PERL, perl, $missing_dir)
- AM_MISSING_PROG(HELP2MAN, help2man, $missing_dir)
--AM_GNU_GETTEXT(external)
--AM_GNU_GETTEXT_VERSION(0.17)
- AM_ICONV
- AM_PATH_LISPDIR