mpc85xx: convert TL-WDR4900 v1 to simpleImage
[openwrt/staging/blogic.git] / target / linux / mpc85xx / patches-4.19 / 100-powerpc-85xx-tl-wdr4900-v1-support.patch
index 6d76ebc32ccde629ca25a160f301a9733a41f5c7..38380773ac77725db98ce9447270c7aab72b6081 100644 (file)
@@ -1,4 +1,4 @@
-From 406d86e5990ac171f18ef6e2973672d8fbfe1556 Mon Sep 17 00:00:00 2001
+From 1d9f596e572917772b87a2a37e1680902964782f Mon Sep 17 00:00:00 2001
 From: Gabor Juhos <juhosg@openwrt.org>
 Date: Wed, 20 Feb 2013 08:40:33 +0100
 Subject: [PATCH] powerpc: 85xx: add support for the TP-Link TL-WDR4900 v1
@@ -9,44 +9,53 @@ concurrent dual-band wireless router. The devices uses
 the Freescale P1014 SoC.
 
 Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
+Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 ---
- arch/powerpc/boot/Makefile                  |   3 +
- arch/powerpc/boot/wrapper                   |   4 +
- arch/powerpc/platforms/85xx/Kconfig         |  11 ++
- arch/powerpc/platforms/85xx/Makefile        |   1 +
+ arch/powerpc/boot/Makefile           |  3 ++-
+ arch/powerpc/boot/wrapper            |  5 +++++
+ arch/powerpc/platforms/85xx/Kconfig  | 12 ++++++++++++
+ arch/powerpc/platforms/85xx/Makefile |  1 +
+ 4 files changed, 20 insertions(+), 1 deletion(-)
 
+diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
+index 25e3184f11f7..0826346fd97c 100644
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pseries-head.S
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
-+src-plat-$(CONFIG_TL_WDR4900_V1) += cuboot-tl-wdr4900-v1.c
++src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
  
  src-wlib := $(sort $(src-wlib-y))
  src-plat := $(sort $(src-plat-y))
-@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
+@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_SBC8548)                       += cuImage.sbc8548
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
 -
-+image-$(CONFIG_TL_WDR4900_V1)         += cuImage.tl-wdr4900-v1
++image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
  # Board ports in arch/powerpc/platform/86xx/Kconfig
  image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
  
+diff --git a/arch/powerpc/boot/wrapper b/arch/powerpc/boot/wrapper
+index f9141eaec6ff..bd55094d9899 100755
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -277,6 +277,10 @@ cuboot*)
-     *-mpc85*|*-tqm85*|*-sbc85*)
-         platformo=$object/cuboot-85xx.o
-         ;;
-+    *-tl-wdr4900-v1)
-+        platformo=$object/cuboot-tl-wdr4900-v1.o
+@@ -302,6 +302,11 @@ adder875-redboot)
+     platformo="$object/fixed-head.o $object/redboot-8xx.o"
+     binary=y
+     ;;
++simpleboot-tl-wdr4900-v1)
++    platformo="$object/fixed-head.o $object/simpleboot.o"
 +    link_address='0x1000000'
-+        ;;
-     *-amigaone)
-         link_address='0x800000'
-         ;;
++    binary=y
++    ;;
+ simpleboot-virtex405-*)
+     platformo="$object/virtex405-head.o $object/simpleboot.o $object/virtex.o"
+     binary=y
+diff --git a/arch/powerpc/platforms/85xx/Kconfig b/arch/powerpc/platforms/85xx/Kconfig
+index 68920d42b4bc..2bf6533ce023 100644
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
 @@ -170,6 +170,18 @@ config STX_GP3
@@ -58,7 +67,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 +    select DEFAULT_UIMAGE
 +    select ARCH_REQUIRE_GPIOLIB
 +    select GPIO_MPC8XXX
-+       select SWIOTLB
++    select SWIOTLB
 +    help
 +      This option enables support for the TP-Link TL-WDR4900 v1 board.
 +
@@ -68,9 +77,11 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  config TQM8540
        bool "TQ Components TQM8540"
        help
+diff --git a/arch/powerpc/platforms/85xx/Makefile b/arch/powerpc/platforms/85xx/Makefile
+index d1dd0dca5ebf..d0dab29a33eb 100644
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC)   += coren
+@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
  obj-$(CONFIG_FB_FSL_DIU)      += t1042rdb_diu.o
  obj-$(CONFIG_STX_GP3)   += stx_gp3.o
  obj-$(CONFIG_TQM85xx)   += tqm85xx.o
@@ -78,3 +89,6 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  obj-$(CONFIG_SBC8548)     += sbc8548.o
  obj-$(CONFIG_PPA8548)     += ppa8548.o
  obj-$(CONFIG_SOCRATES)    += socrates.o socrates_fpga_pic.o
+-- 
+2.20.1
+