kernel: update 4.1 to 4.1.13
[openwrt/svn-archive/openwrt.git] / target / linux / mediatek / patches / 0023-thermal-Add-Mediatek-thermal-controller-support.patch
index 827d721138aa8864dec33dd5a78a598d238a01ee..3c2d2dbc78f8dc8dff0c2c0ebfbe5f99c84e3e63 100644 (file)
@@ -18,8 +18,6 @@ Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
  3 files changed, 737 insertions(+)
  create mode 100644 drivers/thermal/mtk_thermal.c
 
-diff --git a/drivers/thermal/Kconfig b/drivers/thermal/Kconfig
-index af40db0..3aa5500 100644
 --- a/drivers/thermal/Kconfig
 +++ b/drivers/thermal/Kconfig
 @@ -285,6 +285,14 @@ config ACPI_THERMAL_REL
@@ -37,18 +35,13 @@ index af40db0..3aa5500 100644
  menu "Texas Instruments thermal drivers"
  source "drivers/thermal/ti-soc-thermal/Kconfig"
  endmenu
-diff --git a/drivers/thermal/Makefile b/drivers/thermal/Makefile
-index fa0dc48..51cfab7 100644
 --- a/drivers/thermal/Makefile
 +++ b/drivers/thermal/Makefile
-@@ -39,3 +39,4 @@ obj-$(CONFIG_TI_SOC_THERMAL) += ti-soc-thermal/
+@@ -39,3 +39,4 @@ obj-$(CONFIG_TI_SOC_THERMAL) += ti-soc-t
  obj-$(CONFIG_INT340X_THERMAL)  += int340x_thermal/
  obj-$(CONFIG_ST_THERMAL)      += st/
  obj-$(CONFIG_TEGRA_SOCTHERM)  += tegra_soctherm.o
 +obj-$(CONFIG_MTK_THERMAL)     += mtk_thermal.o
-diff --git a/drivers/thermal/mtk_thermal.c b/drivers/thermal/mtk_thermal.c
-new file mode 100644
-index 0000000..27aab12
 --- /dev/null
 +++ b/drivers/thermal/mtk_thermal.c
 @@ -0,0 +1,728 @@
@@ -780,6 +773,3 @@ index 0000000..27aab12
 +};
 +
 +module_platform_driver(mtk_thermal_driver);
--- 
-1.7.10.4
-