kernel: refresh patches
[openwrt/svn-archive/openwrt.git] / target / linux / ar7 / patches / 100-board_support.patch
index 82d09b0f0171984880a65691f0e8c82f6c1ad4db..95757d4643e806ee83e3e26432fab04a720e541b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -18,6 +18,23 @@
+@@ -18,6 +18,23 @@ choice
        prompt "System type"
        default SGI_IP22
  
@@ -26,7 +26,7 @@
  
 --- a/arch/mips/kernel/traps.c
 +++ b/arch/mips/kernel/traps.c
-@@ -1188,9 +1188,22 @@
+@@ -1188,9 +1188,22 @@ void *set_except_vector(int n, void *add
  
        exception_handlers[n] = handler;
        if (n == 0 && cpu_has_divec) {
@@ -54,7 +54,7 @@
  }
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -167,6 +167,13 @@
+@@ -167,6 +167,13 @@ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/s
  #
  
  #
@@ -70,7 +70,7 @@
  core-$(CONFIG_MACH_JAZZ)      += arch/mips/jazz/
 --- a/include/asm-mips/page.h
 +++ b/include/asm-mips/page.h
-@@ -182,8 +182,10 @@
+@@ -182,8 +182,10 @@ typedef struct { unsigned long pgprot; }
  #define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \
                                 VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC)