hostapd: adjust patches to work with git am
[openwrt/staging/xback.git] / package / network / services / hostapd / patches / 600-ubus_support.patch
index 412cc0a0322e1f43c210c79d1628457478d21778..a6b03ffd3faaea092fd321722465d70a98370bd3 100644 (file)
@@ -1,3 +1,10 @@
+From: Felix Fietkau <nbd@openwrt.org>
+Date: Sun, 17 Mar 2013 20:47:18 +0000
+Subject: [PATCH] hostapd: initial prototype of an ubus binding
+
+Supports listing, removing and banning clients, and hooking into
+probe/assoc/auth requests via object subscribe.
+
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
 @@ -166,6 +166,12 @@ OBJS += ../src/common/hw_features_common
  
  ifdef CONFIG_CODE_COVERAGE
  CFLAGS += -O0 -fprofile-arcs -ftest-coverage -U_FORTIFY_SOURCE
---- a/src/ap/hostapd.h
-+++ b/src/ap/hostapd.h
-@@ -18,6 +18,7 @@
- #include "utils/list.h"
- #include "ap_config.h"
- #include "drivers/driver.h"
-+#include "ubus.h"
+--- a/src/ap/airtime_policy.c
++++ b/src/ap/airtime_policy.c
+@@ -112,8 +112,14 @@ static void set_sta_weights(struct hosta
+ {
+       struct sta_info *sta;
  
- #define OCE_STA_CFON_ENABLED(hapd) \
-       ((hapd->conf->oce & OCE_STA_CFON) && \
-@@ -184,6 +185,7 @@ struct hostapd_data {
-       struct hostapd_iface *iface;
-       struct hostapd_config *iconf;
-       struct hostapd_bss_config *conf;
-+      struct hostapd_ubus_bss ubus;
-       int interface_added; /* virtual interface added for this BSS */
-       unsigned int started:1;
-       unsigned int disabled:1;
-@@ -707,6 +709,7 @@ hostapd_alloc_bss_data(struct hostapd_if
-                      struct hostapd_bss_config *bss);
- int hostapd_setup_interface(struct hostapd_iface *iface);
- int hostapd_setup_interface_complete(struct hostapd_iface *iface, int err);
-+void hostapd_set_own_neighbor_report(struct hostapd_data *hapd);
- void hostapd_interface_deinit(struct hostapd_iface *iface);
- void hostapd_interface_free(struct hostapd_iface *iface);
- struct hostapd_iface * hostapd_alloc_iface(void);
+-      for (sta = hapd->sta_list; sta; sta = sta->next)
+-              sta_set_airtime_weight(hapd, sta, weight);
++      for (sta = hapd->sta_list; sta; sta = sta->next) {
++              unsigned int sta_weight = weight;
++
++              if (sta->dyn_airtime_weight)
++                      sta_weight = (weight * sta->dyn_airtime_weight) / 256;
++
++              sta_set_airtime_weight(hapd, sta, sta_weight);
++      }
+ }
+@@ -244,7 +250,10 @@ int airtime_policy_new_sta(struct hostap
+       unsigned int weight;
+       if (hapd->iconf->airtime_mode == AIRTIME_MODE_STATIC) {
+-              weight = get_weight_for_sta(hapd, sta->addr);
++              if (sta->dyn_airtime_weight)
++                      weight = sta->dyn_airtime_weight;
++              else
++                      weight = get_weight_for_sta(hapd, sta->addr);
+               if (weight)
+                       return sta_set_airtime_weight(hapd, sta, weight);
+       }
+--- a/src/ap/beacon.c
++++ b/src/ap/beacon.c
+@@ -1351,6 +1351,12 @@ void handle_probe_req(struct hostapd_dat
+       int mld_id;
+       u16 links;
+ #endif /* CONFIG_IEEE80211BE */
++      struct hostapd_ubus_request req = {
++              .type = HOSTAPD_UBUS_PROBE_REQ,
++              .mgmt_frame = mgmt,
++              .ssi_signal = ssi_signal,
++              .elems = &elems,
++      };
+       if (hapd->iconf->rssi_ignore_probe_request && ssi_signal &&
+           ssi_signal < hapd->iconf->rssi_ignore_probe_request)
+@@ -1537,6 +1543,12 @@ void handle_probe_req(struct hostapd_dat
+       }
+ #endif /* CONFIG_P2P */
++      if (hostapd_ubus_handle_event(hapd, &req)) {
++              wpa_printf(MSG_DEBUG, "Probe request for " MACSTR " rejected by ubus handler.\n",
++                     MAC2STR(mgmt->sa));
++              return;
++      }
++
+       /* TODO: verify that supp_rates contains at least one matching rate
+        * with AP configuration */
+--- a/src/ap/dfs.c
++++ b/src/ap/dfs.c
+@@ -1225,6 +1225,8 @@ int hostapd_dfs_pre_cac_expired(struct h
+               "freq=%d ht_enabled=%d chan_offset=%d chan_width=%d cf1=%d cf2=%d",
+               freq, ht_enabled, chan_offset, chan_width, cf1, cf2);
++      hostapd_ubus_notify_radar_detected(iface, freq, chan_width, cf1, cf2);
++
+       /* Proceed only if DFS is not offloaded to the driver */
+       if (iface->drv_flags & WPA_DRIVER_FLAGS_DFS_OFFLOAD)
+               return 0;
+--- a/src/ap/drv_callbacks.c
++++ b/src/ap/drv_callbacks.c
+@@ -268,6 +268,10 @@ int hostapd_notif_assoc(struct hostapd_d
+       struct hostapd_iface *iface = hapd->iface;
+ #endif /* CONFIG_OWE */
+       bool updated = false;
++      struct hostapd_ubus_request req = {
++              .type = HOSTAPD_UBUS_ASSOC_REQ,
++              .addr = addr,
++      };
+       if (addr == NULL) {
+               /*
+@@ -412,6 +416,12 @@ int hostapd_notif_assoc(struct hostapd_d
+               goto fail;
+       }
++      if (hostapd_ubus_handle_event(hapd, &req)) {
++              wpa_printf(MSG_DEBUG, "Station " MACSTR " assoc rejected by ubus handler.\n",
++                         MAC2STR(req.addr));
++              goto fail;
++      }
++
+ #ifdef CONFIG_P2P
+       if (elems.p2p) {
+               wpabuf_free(sta->p2p_ie);
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
 @@ -493,6 +493,7 @@ void hostapd_free_hapd_data(struct hosta
        hostapd_interface_deinit(iface);
        wpa_printf(MSG_DEBUG, "%s: driver=%p drv_priv=%p -> hapd_deinit",
                   __func__, driver, drv_priv);
+--- a/src/ap/hostapd.h
++++ b/src/ap/hostapd.h
+@@ -18,6 +18,7 @@
+ #include "utils/list.h"
+ #include "ap_config.h"
+ #include "drivers/driver.h"
++#include "ubus.h"
+ #define OCE_STA_CFON_ENABLED(hapd) \
+       ((hapd->conf->oce & OCE_STA_CFON) && \
+@@ -184,6 +185,7 @@ struct hostapd_data {
+       struct hostapd_iface *iface;
+       struct hostapd_config *iconf;
+       struct hostapd_bss_config *conf;
++      struct hostapd_ubus_bss ubus;
+       int interface_added; /* virtual interface added for this BSS */
+       unsigned int started:1;
+       unsigned int disabled:1;
+@@ -707,6 +709,7 @@ hostapd_alloc_bss_data(struct hostapd_if
+                      struct hostapd_bss_config *bss);
+ int hostapd_setup_interface(struct hostapd_iface *iface);
+ int hostapd_setup_interface_complete(struct hostapd_iface *iface, int err);
++void hostapd_set_own_neighbor_report(struct hostapd_data *hapd);
+ void hostapd_interface_deinit(struct hostapd_iface *iface);
+ void hostapd_interface_free(struct hostapd_iface *iface);
+ struct hostapd_iface * hostapd_alloc_iface(void);
 --- a/src/ap/ieee802_11.c
 +++ b/src/ap/ieee802_11.c
 @@ -2798,7 +2798,7 @@ static void handle_auth(struct hostapd_d
        sta = ap_get_sta(hapd, mgmt->sa);
        if (!sta) {
                wpa_msg(hapd->msg_ctx, MSG_DEBUG, "Station " MACSTR
---- a/src/ap/beacon.c
-+++ b/src/ap/beacon.c
-@@ -1351,6 +1351,12 @@ void handle_probe_req(struct hostapd_dat
-       int mld_id;
-       u16 links;
- #endif /* CONFIG_IEEE80211BE */
-+      struct hostapd_ubus_request req = {
-+              .type = HOSTAPD_UBUS_PROBE_REQ,
-+              .mgmt_frame = mgmt,
-+              .ssi_signal = ssi_signal,
-+              .elems = &elems,
-+      };
-       if (hapd->iconf->rssi_ignore_probe_request && ssi_signal &&
-           ssi_signal < hapd->iconf->rssi_ignore_probe_request)
-@@ -1537,6 +1543,12 @@ void handle_probe_req(struct hostapd_dat
-       }
- #endif /* CONFIG_P2P */
-+      if (hostapd_ubus_handle_event(hapd, &req)) {
-+              wpa_printf(MSG_DEBUG, "Probe request for " MACSTR " rejected by ubus handler.\n",
-+                     MAC2STR(mgmt->sa));
+--- a/src/ap/rrm.c
++++ b/src/ap/rrm.c
+@@ -89,6 +89,9 @@ static void hostapd_handle_beacon_report
+               return;
+       wpa_msg(hapd->msg_ctx, MSG_INFO, BEACON_RESP_RX MACSTR " %u %02x %s",
+               MAC2STR(addr), token, rep_mode, report);
++      if (len < sizeof(struct rrm_measurement_beacon_report))
 +              return;
-+      }
-+
-       /* TODO: verify that supp_rates contains at least one matching rate
-        * with AP configuration */
++      hostapd_ubus_notify_beacon_report(hapd, addr, token, rep_mode, (struct rrm_measurement_beacon_report*) pos, len);
+ }
  
---- a/src/ap/drv_callbacks.c
-+++ b/src/ap/drv_callbacks.c
-@@ -268,6 +268,10 @@ int hostapd_notif_assoc(struct hostapd_d
-       struct hostapd_iface *iface = hapd->iface;
- #endif /* CONFIG_OWE */
-       bool updated = false;
-+      struct hostapd_ubus_request req = {
-+              .type = HOSTAPD_UBUS_ASSOC_REQ,
-+              .addr = addr,
-+      };
  
-       if (addr == NULL) {
-               /*
-@@ -412,6 +416,12 @@ int hostapd_notif_assoc(struct hostapd_d
-               goto fail;
-       }
+@@ -352,6 +355,9 @@ void hostapd_handle_radio_measurement(st
+                  mgmt->u.action.u.rrm.action, MAC2STR(mgmt->sa));
  
-+      if (hostapd_ubus_handle_event(hapd, &req)) {
-+              wpa_printf(MSG_DEBUG, "Station " MACSTR " assoc rejected by ubus handler.\n",
-+                         MAC2STR(req.addr));
-+              goto fail;
-+      }
-+
- #ifdef CONFIG_P2P
-       if (elems.p2p) {
-               wpabuf_free(sta->p2p_ie);
+       switch (mgmt->u.action.u.rrm.action) {
++      case WLAN_RRM_LINK_MEASUREMENT_REPORT:
++              hostapd_ubus_handle_link_measurement(hapd, buf, len);
++              break;
+       case WLAN_RRM_RADIO_MEASUREMENT_REPORT:
+               hostapd_handle_radio_msmt_report(hapd, buf, len);
+               break;
 --- a/src/ap/sta_info.c
 +++ b/src/ap/sta_info.c
 @@ -476,6 +476,7 @@ void ap_handle_timer(void *eloop_ctx, vo
                if (wpa_auth_get_ip_addr(sta->wpa_sm, ip_addr_buf) == 0) {
                        os_snprintf(ip_addr, sizeof(ip_addr),
 @@ -1470,6 +1485,13 @@ void ap_sta_set_authorized_event(struct
-               }
- #endif /* CONFIG_P2P */
-+              if (sta->auth_alg < ARRAY_SIZE(auth_algs))
-+                      auth_alg = auth_algs[sta->auth_alg];
-+
-+              if (auth_alg)
-+                      os_snprintf(alg_buf, sizeof(alg_buf),
-+                              " auth_alg=%s", auth_alg);
-+
-               keyid = ap_sta_wpa_get_keyid(hapd, sta);
-               if (keyid) {
-                       os_snprintf(keyid_buf, sizeof(keyid_buf),
-@@ -1488,17 +1510,19 @@ void ap_sta_set_authorized_event(struct
-                                        dpp_pkhash, SHA256_MAC_LEN);
-               }
--              wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_CONNECTED "%s%s%s%s",
--                      buf, ip_addr, keyid_buf, dpp_pkhash_buf);
-+              hostapd_ubus_notify_authorized(hapd, sta, auth_alg);
-+              wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_CONNECTED "%s%s%s%s%s",
-+                      buf, ip_addr, keyid_buf, dpp_pkhash_buf, alg_buf);
-               if (hapd->msg_ctx_parent &&
-                   hapd->msg_ctx_parent != hapd->msg_ctx)
-                       wpa_msg_no_global(hapd->msg_ctx_parent, MSG_INFO,
--                                        AP_STA_CONNECTED "%s%s%s%s",
-+                                        AP_STA_CONNECTED "%s%s%s%s%s",
-                                         buf, ip_addr, keyid_buf,
--                                        dpp_pkhash_buf);
-+                                        dpp_pkhash_buf, alg_buf);
-       } else {
-               wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_DISCONNECTED "%s", buf);
-+              hostapd_ubus_notify(hapd, "disassoc", sta->addr);
-               if (hapd->msg_ctx_parent &&
-                   hapd->msg_ctx_parent != hapd->msg_ctx)
---- a/src/ap/wpa_auth_glue.c
-+++ b/src/ap/wpa_auth_glue.c
-@@ -275,6 +275,7 @@ static void hostapd_wpa_auth_psk_failure
-       struct hostapd_data *hapd = ctx;
-       wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_POSSIBLE_PSK_MISMATCH MACSTR,
-               MAC2STR(addr));
-+      hostapd_ubus_notify(hapd, "key-mismatch", addr);
- }
---- a/wpa_supplicant/Makefile
-+++ b/wpa_supplicant/Makefile
-@@ -189,6 +189,13 @@ ifdef CONFIG_EAPOL_TEST
- CFLAGS += -Werror -DEAPOL_TEST
- endif
-+ifdef CONFIG_UBUS
-+CFLAGS += -DUBUS_SUPPORT
-+OBJS += ubus.o
-+OBJS += ../src/utils/uloop.o
-+LIBS += -lubox -lubus
-+endif
-+
- ifdef CONFIG_CODE_COVERAGE
- CFLAGS += -O0 -fprofile-arcs -ftest-coverage -U_FORTIFY_SOURCE
- LIBS += -lgcov
-@@ -1042,6 +1049,9 @@ ifdef CONFIG_CTRL_IFACE_MIB
- CFLAGS += -DCONFIG_CTRL_IFACE_MIB
- endif
- OBJS += ../src/ap/ctrl_iface_ap.o
-+ifdef CONFIG_UBUS
-+OBJS += ../src/ap/ubus.o
-+endif
- endif
- CFLAGS += -DEAP_SERVER -DEAP_SERVER_IDENTITY
---- a/wpa_supplicant/wpa_supplicant.c
-+++ b/wpa_supplicant/wpa_supplicant.c
-@@ -7716,6 +7716,8 @@ struct wpa_supplicant * wpa_supplicant_a
-       }
- #endif /* CONFIG_P2P */
-+      wpas_ubus_add_bss(wpa_s);
-+
-       return wpa_s;
- }
-@@ -7742,6 +7744,8 @@ int wpa_supplicant_remove_iface(struct w
-       struct wpa_supplicant *parent = wpa_s->parent;
- #endif /* CONFIG_MESH */
-+      wpas_ubus_free_bss(wpa_s);
-+
-       /* Remove interface from the global list of interfaces */
-       prev = global->ifaces;
-       if (prev == wpa_s) {
-@@ -8088,8 +8092,12 @@ int wpa_supplicant_run(struct wpa_global
-       eloop_register_signal_terminate(wpa_supplicant_terminate, global);
-       eloop_register_signal_reconfig(wpa_supplicant_reconfig, global);
-+      wpas_ubus_add(global);
-+
-       eloop_run();
-+      wpas_ubus_free(global);
-+
-       return 0;
- }
---- a/wpa_supplicant/wpa_supplicant_i.h
-+++ b/wpa_supplicant/wpa_supplicant_i.h
-@@ -21,6 +21,7 @@
- #include "config_ssid.h"
- #include "wmm_ac.h"
- #include "pasn/pasn_common.h"
-+#include "ubus.h"
- extern const char *const wpa_supplicant_version;
- extern const char *const wpa_supplicant_license;
-@@ -319,6 +320,8 @@ struct wpa_global {
- #endif /* CONFIG_WIFI_DISPLAY */
-       struct psk_list_entry *add_psk; /* From group formation */
-+
-+      struct ubus_object ubus_global;
- };
-@@ -693,6 +696,7 @@ struct wpa_supplicant {
-       unsigned char own_addr[ETH_ALEN];
-       unsigned char perm_addr[ETH_ALEN];
-       char ifname[100];
-+      struct wpas_ubus_bss ubus;
- #ifdef CONFIG_MATCH_IFACE
-       int matched;
- #endif /* CONFIG_MATCH_IFACE */
---- a/wpa_supplicant/wps_supplicant.c
-+++ b/wpa_supplicant/wps_supplicant.c
-@@ -33,6 +33,7 @@
- #include "p2p/p2p.h"
- #include "p2p_supplicant.h"
- #include "wps_supplicant.h"
-+#include "ubus.h"
- #ifndef WPS_PIN_SCAN_IGNORE_SEL_REG
-@@ -401,6 +402,8 @@ static int wpa_supplicant_wps_cred(void
-       wpa_hexdump_key(MSG_DEBUG, "WPS: Received Credential attribute",
-                       cred->cred_attr, cred->cred_attr_len);
-+      wpas_ubus_notify(wpa_s, cred);
-+
-       if (wpa_s->conf->wps_cred_processing == 1)
-               return 0;
---- a/wpa_supplicant/main.c
-+++ b/wpa_supplicant/main.c
-@@ -203,7 +203,7 @@ int main(int argc, char *argv[])
-       for (;;) {
-               c = getopt(argc, argv,
--                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:No:O:p:P:qsTtuv::W");
-+                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:nNo:O:p:P:qsTtuv::W");
-               if (c < 0)
-                       break;
-               switch (c) {
-@@ -268,6 +268,9 @@ int main(int argc, char *argv[])
-                       params.conf_p2p_dev = optarg;
-                       break;
+               }
  #endif /* CONFIG_P2P */
-+              case 'n':
-+                      iface_count = 0;
-+                      break;
-               case 'o':
-                       params.override_driver = optarg;
-                       break;
---- a/src/ap/rrm.c
-+++ b/src/ap/rrm.c
-@@ -89,6 +89,9 @@ static void hostapd_handle_beacon_report
-               return;
-       wpa_msg(hapd->msg_ctx, MSG_INFO, BEACON_RESP_RX MACSTR " %u %02x %s",
-               MAC2STR(addr), token, rep_mode, report);
-+      if (len < sizeof(struct rrm_measurement_beacon_report))
-+              return;
-+      hostapd_ubus_notify_beacon_report(hapd, addr, token, rep_mode, (struct rrm_measurement_beacon_report*) pos, len);
- }
  
++              if (sta->auth_alg < ARRAY_SIZE(auth_algs))
++                      auth_alg = auth_algs[sta->auth_alg];
++
++              if (auth_alg)
++                      os_snprintf(alg_buf, sizeof(alg_buf),
++                              " auth_alg=%s", auth_alg);
++
+               keyid = ap_sta_wpa_get_keyid(hapd, sta);
+               if (keyid) {
+                       os_snprintf(keyid_buf, sizeof(keyid_buf),
+@@ -1488,17 +1510,19 @@ void ap_sta_set_authorized_event(struct
+                                        dpp_pkhash, SHA256_MAC_LEN);
+               }
  
-@@ -352,6 +355,9 @@ void hostapd_handle_radio_measurement(st
-                  mgmt->u.action.u.rrm.action, MAC2STR(mgmt->sa));
+-              wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_CONNECTED "%s%s%s%s",
+-                      buf, ip_addr, keyid_buf, dpp_pkhash_buf);
++              hostapd_ubus_notify_authorized(hapd, sta, auth_alg);
++              wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_CONNECTED "%s%s%s%s%s",
++                      buf, ip_addr, keyid_buf, dpp_pkhash_buf, alg_buf);
+               if (hapd->msg_ctx_parent &&
+                   hapd->msg_ctx_parent != hapd->msg_ctx)
+                       wpa_msg_no_global(hapd->msg_ctx_parent, MSG_INFO,
+-                                        AP_STA_CONNECTED "%s%s%s%s",
++                                        AP_STA_CONNECTED "%s%s%s%s%s",
+                                         buf, ip_addr, keyid_buf,
+-                                        dpp_pkhash_buf);
++                                        dpp_pkhash_buf, alg_buf);
+       } else {
+               wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_DISCONNECTED "%s", buf);
++              hostapd_ubus_notify(hapd, "disassoc", sta->addr);
+               if (hapd->msg_ctx_parent &&
+                   hapd->msg_ctx_parent != hapd->msg_ctx)
+--- a/src/ap/sta_info.h
++++ b/src/ap/sta_info.h
+@@ -319,6 +319,7 @@ struct sta_info {
+ #endif /* CONFIG_TESTING_OPTIONS */
+ #ifdef CONFIG_AIRTIME_POLICY
+       unsigned int airtime_weight;
++      unsigned int dyn_airtime_weight;
+       struct os_reltime backlogged_until;
+ #endif /* CONFIG_AIRTIME_POLICY */
  
-       switch (mgmt->u.action.u.rrm.action) {
-+      case WLAN_RRM_LINK_MEASUREMENT_REPORT:
-+              hostapd_ubus_handle_link_measurement(hapd, buf, len);
-+              break;
-       case WLAN_RRM_RADIO_MEASUREMENT_REPORT:
-               hostapd_handle_radio_msmt_report(hapd, buf, len);
-               break;
 --- a/src/ap/vlan_init.c
 +++ b/src/ap/vlan_init.c
 @@ -22,6 +22,7 @@
        return hostapd_vlan_if_remove(hapd, vlan->ifname);
  }
  
---- a/src/ap/dfs.c
-+++ b/src/ap/dfs.c
-@@ -1225,6 +1225,8 @@ int hostapd_dfs_pre_cac_expired(struct h
-               "freq=%d ht_enabled=%d chan_offset=%d chan_width=%d cf1=%d cf2=%d",
-               freq, ht_enabled, chan_offset, chan_width, cf1, cf2);
-+      hostapd_ubus_notify_radar_detected(iface, freq, chan_width, cf1, cf2);
-+
-       /* Proceed only if DFS is not offloaded to the driver */
-       if (iface->drv_flags & WPA_DRIVER_FLAGS_DFS_OFFLOAD)
-               return 0;
---- a/src/ap/airtime_policy.c
-+++ b/src/ap/airtime_policy.c
-@@ -112,8 +112,14 @@ static void set_sta_weights(struct hosta
- {
-       struct sta_info *sta;
--      for (sta = hapd->sta_list; sta; sta = sta->next)
--              sta_set_airtime_weight(hapd, sta, weight);
-+      for (sta = hapd->sta_list; sta; sta = sta->next) {
-+              unsigned int sta_weight = weight;
-+
-+              if (sta->dyn_airtime_weight)
-+                      sta_weight = (weight * sta->dyn_airtime_weight) / 256;
-+
-+              sta_set_airtime_weight(hapd, sta, sta_weight);
-+      }
- }
-@@ -244,7 +250,10 @@ int airtime_policy_new_sta(struct hostap
-       unsigned int weight;
-       if (hapd->iconf->airtime_mode == AIRTIME_MODE_STATIC) {
--              weight = get_weight_for_sta(hapd, sta->addr);
-+              if (sta->dyn_airtime_weight)
-+                      weight = sta->dyn_airtime_weight;
-+              else
-+                      weight = get_weight_for_sta(hapd, sta->addr);
-               if (weight)
-                       return sta_set_airtime_weight(hapd, sta, weight);
-       }
---- a/src/ap/sta_info.h
-+++ b/src/ap/sta_info.h
-@@ -319,6 +319,7 @@ struct sta_info {
- #endif /* CONFIG_TESTING_OPTIONS */
- #ifdef CONFIG_AIRTIME_POLICY
-       unsigned int airtime_weight;
-+      unsigned int dyn_airtime_weight;
-       struct os_reltime backlogged_until;
- #endif /* CONFIG_AIRTIME_POLICY */
 --- a/src/ap/wnm_ap.c
 +++ b/src/ap/wnm_ap.c
 @@ -479,7 +479,8 @@ static void ieee802_11_rx_bss_trans_mgmt
        wpa_hexdump(MSG_DEBUG, "WNM: BSS Transition Candidate List Entries",
                    pos, end - pos);
  }
+--- a/src/ap/wpa_auth_glue.c
++++ b/src/ap/wpa_auth_glue.c
+@@ -275,6 +275,7 @@ static void hostapd_wpa_auth_psk_failure
+       struct hostapd_data *hapd = ctx;
+       wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_POSSIBLE_PSK_MISMATCH MACSTR,
+               MAC2STR(addr));
++      hostapd_ubus_notify(hapd, "key-mismatch", addr);
+ }
 --- a/src/utils/eloop.c
 +++ b/src/utils/eloop.c
 @@ -77,6 +77,9 @@ struct eloop_sock_table {
 +
 +      eloop_register_cb(uloop_poll_handler, uloop_timeout_poll_handler);
 +}
+--- a/wpa_supplicant/Makefile
++++ b/wpa_supplicant/Makefile
+@@ -189,6 +189,13 @@ ifdef CONFIG_EAPOL_TEST
+ CFLAGS += -Werror -DEAPOL_TEST
+ endif
++ifdef CONFIG_UBUS
++CFLAGS += -DUBUS_SUPPORT
++OBJS += ubus.o
++OBJS += ../src/utils/uloop.o
++LIBS += -lubox -lubus
++endif
++
+ ifdef CONFIG_CODE_COVERAGE
+ CFLAGS += -O0 -fprofile-arcs -ftest-coverage -U_FORTIFY_SOURCE
+ LIBS += -lgcov
+@@ -1042,6 +1049,9 @@ ifdef CONFIG_CTRL_IFACE_MIB
+ CFLAGS += -DCONFIG_CTRL_IFACE_MIB
+ endif
+ OBJS += ../src/ap/ctrl_iface_ap.o
++ifdef CONFIG_UBUS
++OBJS += ../src/ap/ubus.o
++endif
+ endif
+ CFLAGS += -DEAP_SERVER -DEAP_SERVER_IDENTITY
+--- a/wpa_supplicant/main.c
++++ b/wpa_supplicant/main.c
+@@ -203,7 +203,7 @@ int main(int argc, char *argv[])
+       for (;;) {
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:No:O:p:P:qsTtuv::W");
++                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:nNo:O:p:P:qsTtuv::W");
+               if (c < 0)
+                       break;
+               switch (c) {
+@@ -268,6 +268,9 @@ int main(int argc, char *argv[])
+                       params.conf_p2p_dev = optarg;
+                       break;
+ #endif /* CONFIG_P2P */
++              case 'n':
++                      iface_count = 0;
++                      break;
+               case 'o':
+                       params.override_driver = optarg;
+                       break;
+--- a/wpa_supplicant/wpa_supplicant.c
++++ b/wpa_supplicant/wpa_supplicant.c
+@@ -7716,6 +7716,8 @@ struct wpa_supplicant * wpa_supplicant_a
+       }
+ #endif /* CONFIG_P2P */
++      wpas_ubus_add_bss(wpa_s);
++
+       return wpa_s;
+ }
+@@ -7742,6 +7744,8 @@ int wpa_supplicant_remove_iface(struct w
+       struct wpa_supplicant *parent = wpa_s->parent;
+ #endif /* CONFIG_MESH */
++      wpas_ubus_free_bss(wpa_s);
++
+       /* Remove interface from the global list of interfaces */
+       prev = global->ifaces;
+       if (prev == wpa_s) {
+@@ -8088,8 +8092,12 @@ int wpa_supplicant_run(struct wpa_global
+       eloop_register_signal_terminate(wpa_supplicant_terminate, global);
+       eloop_register_signal_reconfig(wpa_supplicant_reconfig, global);
++      wpas_ubus_add(global);
++
+       eloop_run();
++      wpas_ubus_free(global);
++
+       return 0;
+ }
+--- a/wpa_supplicant/wpa_supplicant_i.h
++++ b/wpa_supplicant/wpa_supplicant_i.h
+@@ -21,6 +21,7 @@
+ #include "config_ssid.h"
+ #include "wmm_ac.h"
+ #include "pasn/pasn_common.h"
++#include "ubus.h"
+ extern const char *const wpa_supplicant_version;
+ extern const char *const wpa_supplicant_license;
+@@ -319,6 +320,8 @@ struct wpa_global {
+ #endif /* CONFIG_WIFI_DISPLAY */
+       struct psk_list_entry *add_psk; /* From group formation */
++
++      struct ubus_object ubus_global;
+ };
+@@ -693,6 +696,7 @@ struct wpa_supplicant {
+       unsigned char own_addr[ETH_ALEN];
+       unsigned char perm_addr[ETH_ALEN];
+       char ifname[100];
++      struct wpas_ubus_bss ubus;
+ #ifdef CONFIG_MATCH_IFACE
+       int matched;
+ #endif /* CONFIG_MATCH_IFACE */
+--- a/wpa_supplicant/wps_supplicant.c
++++ b/wpa_supplicant/wps_supplicant.c
+@@ -33,6 +33,7 @@
+ #include "p2p/p2p.h"
+ #include "p2p_supplicant.h"
+ #include "wps_supplicant.h"
++#include "ubus.h"
+ #ifndef WPS_PIN_SCAN_IGNORE_SEL_REG
+@@ -401,6 +402,8 @@ static int wpa_supplicant_wps_cred(void
+       wpa_hexdump_key(MSG_DEBUG, "WPS: Received Credential attribute",
+                       cred->cred_attr, cred->cred_attr_len);
++      wpas_ubus_notify(wpa_s, cred);
++
+       if (wpa_s->conf->wps_cred_processing == 1)
+               return 0;