htpdate: moved to github
[openwrt/svn-archive/packages.git] / net / chrony / Makefile
index fd1a712763caebee13be7b585f84283a3ffbc2c6..55f81caf25c1a7d5d3ef0f0b2c2f56fb97b4df2a 100644 (file)
@@ -1,36 +1,36 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chrony
-PKG_VERSION:=1.21
-PKG_RELEASE:=1
+PKG_VERSION:=1.26
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:= ftp://chrony.sunsite.dk/projects/chrony/ \
-       http://chrony.sunsite.dk/download/
-PKG_MD5SUM:=84f76a73dff5a3c9e9f11f3c29a4e93b
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:= ftp://download.tuxfamily.org/projects/chrony/ \
+       http://download.tuxfamily.org/chrony/
+PKG_MD5SUM:=ad6dd619ff1986e4ff780363c64e2246
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/chrony
+  SUBMENU:=Time Synchronization
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libreadline +libncurses
+  DEPENDS:=+libreadline +libncurses @!TARGET_avr32 @!powerpc
   TITLE:=NTP client/server for on-demand connections
   URL:=http://chrony.sunsite.dk/
 endef
 
 define Package/chrony/description
-       A NTP implementation that has been specifically written to work well in the case of an intermittent \   (e.g. dial-on-demand) connection to the network where your NTP servers are.
+       A NTP implementation that has been specifically written to work
+       well in the case of an intermittent (e.g. dial-on-demand)
+       connection to the network where your NTP servers are.
 endef
 
 define Package/chrony/conffiles
@@ -43,6 +43,7 @@ define Build/Configure
                        --prefix=/usr \
                        --with-readline-includes=$(STAGING_DIR)/usr/include \
                        --with-readline-library=$(STAGING_DIR)/usr/lib \
+                       --disable-linuxcaps \
        )
 endef
 
@@ -52,7 +53,7 @@ define Build/Compile
                prefix="$(PKG_INSTALL_DIR)/usr"
 endef
 
-define Package/chrony/install  
+define Package/chrony/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/chronyd $(1)/usr/sbin