build: try to find getopt in macOS homebrew's standard location
[openwrt/staging/ansuel.git] / include / prereq-build.mk
index f67a01299e3a7018659a7baa89a0e9a9a1f08bfd..8181812599f2346cde6e4d720daef4b8d23ede88 100644 (file)
@@ -125,7 +125,8 @@ $(eval $(call SetupHostCommand,egrep,Please install GNU 'grep', \
 $(eval $(call SetupHostCommand,getopt, \
        Please install an extended getopt version that supports --long, \
        gnugetopt -o t --long test -- --test | grep '^ *--test *--', \
-       getopt -o t --long test -- --test | grep '^ *--test *--'))
+       getopt -o t --long test -- --test | grep '^ *--test *--', \
+       /usr/local/opt/gnu-getopt/bin/getopt -o t --long test -- --test | grep '^ *--test *--'))
 
 $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
        gnustat -c%s $(TOPDIR)/Makefile, \