realtek: fix Netgear GS110TPP OEM install
authorBjørn Mork <bjorn@mork.no>
Sat, 17 Feb 2024 14:03:40 +0000 (15:03 +0100)
committerSander Vanheule <sander@svanheule.net>
Sun, 18 Feb 2024 08:59:30 +0000 (09:59 +0100)
Recent OEM firmware versions test the version number embedded in the uimage
"name" header field. The exact restricton is unknown, but "7.0.8.4" seems
to be the lowest number accepted on a GS110TPPv1 which already has that
version or higher.

A "9.9.9.9" version is accepted as valid by the GS110TPPv1 OEM firmware,
and considered both unique enough to identify an OpenWrt image and
moderately future proof against OEM version bumps.

This change is also boot tested on a GS108Tv3 with

 "BOOT Loader Version 1.0.0.2 (2018-08-31 17:05:26 UTC)"

to verify that it doesn't break boot on older hardware.

Link: https://forum.openwrt.org/t/72510/58
Signed-off-by: Bjørn Mork <bjorn@mork.no>
(cherry picked from commit 6da308f4de61676da448dda5690d45956d35b602)

target/linux/realtek/image/rtl838x.mk

index 09b4f3ebb03b73470f54535b935a471a7350d132..75118aee43d5dba237d63a36ba708512d5a832ec 100644 (file)
@@ -166,6 +166,7 @@ define Device/netgear_nge
   SOC := rtl8380
   IMAGE_SIZE := 14848k
   UIMAGE_MAGIC := 0x4e474520
+  UIMAGE_NAME := 9.9.9.9
   DEVICE_VENDOR := NETGEAR
 endef