package/lldp: don't link against libbsd on !USE_GLIBC builds
authorAlexander Couzens <lynxis@fe80.eu>
Tue, 4 Sep 2018 01:10:24 +0000 (03:10 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Tue, 4 Sep 2018 01:10:24 +0000 (03:10 +0200)
package/network/services/lldpd/Makefile

index 22b55c6df135ae08e4c6af33f6154990bc7c0282..2ce146aa8f4dc4869c7ec9e58d5f0fffbb800c4d 100644 (file)
@@ -109,5 +109,8 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no) \
        $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,)
 
+# there is no flag to disable libbsd
+CONFIGURE_VARS += \
+       $(if $(CONFIG_USE_GLIBC),,libbsd_LIBS="-lNONexistent")
 
 $(eval $(call BuildPackage,lldpd))