arm-trusted-firmware-tools: fix passing of CFLAGS
authorDaniel Golle <daniel@makrotopia.org>
Wed, 10 Feb 2021 01:05:00 +0000 (01:05 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 10 Feb 2021 01:20:58 +0000 (01:20 +0000)
HOST_CFLAGS were ignored as they were passed on incorrectly which lead
to build failure if OpenSSL wasn't present on the build host.
Fix that by properly passing HOST_CFLAGS when building each tool.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/arm-trusted-firmware-tools/Makefile

index 189817f00a5ef7cd0f8e049718baa613a6f4c714..a7112724c0f90d35b67e667fbcb96f8e5beba670 100644 (file)
@@ -29,15 +29,14 @@ define Package/arm-trusted-firmware-tools
   BUILDONLY:=1
 endef
 
-HOST_CFLAGS += -Wall -Werror -pedantic -std=c99
 define Host/Compile
        $(MAKE) -C \
                $(HOST_BUILD_DIR)/tools/fiptool \
-               CFLAGS="$(HOST_CFLAGS)" \
+               CPPFLAGS="$(HOST_CFLAGS)" \
                LDFLAGS="$(HOST_LDFLAGS)"
        $(MAKE) -C \
                $(HOST_BUILD_DIR)/tools/sptool \
-               CFLAGS="$(HOST_CFLAGS)" \
+               CPPFLAGS="$(HOST_CFLAGS)" \
                LDFLAGS="$(HOST_LDFLAGS)"
 endef