map: backport fixes from trunk
authorSteven Barth <cyrus@openwrt.org>
Tue, 13 Jan 2015 19:02:32 +0000 (19:02 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 13 Jan 2015 19:02:32 +0000 (19:02 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 43962

package/network/ipv6/map/Makefile
package/network/ipv6/map/files/map.sh
package/network/ipv6/map/src/mapcalc.c

index 3e010493a8ed67bd959244b76d482687218b6313..ed358defacc96c9d6ca2abcfd9ef62afcafc9422 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,8 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
-PKG_VERSION:=2
-PKG_RELEASE:=1
+PKG_VERSION:=3
+PKG_RELEASE:=2
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
index 83de4cc4dc52d49413429ee702fb7b41dfa585fe..945accdebdb4f1d16551cfae0c4e0eea4a2aea5c 100755 (executable)
@@ -52,6 +52,7 @@ proto_map_setup() {
                fi
        fi
 
+       echo "rule=$rule" > /tmp/map-$cfg.rules
        RULE_DATA=$(mapcalc ${tunlink:-\*} $rule)
        if [ "$?" != 0 ]; then
                proto_notify_error "$cfg" "INVALID_MAP_RULE"
@@ -59,6 +60,7 @@ proto_map_setup() {
                return
        fi
 
+       echo "$RULE_DATA" >> /tmp/map-$cfg.rules
        eval $RULE_DATA
        
        if [ -z "$RULE_BMR" ]; then
@@ -188,6 +190,7 @@ proto_map_setup() {
 proto_map_teardown() {
        local cfg="$1"
        ifdown "${cfg}_local"
+       rm -f /tmp/map-$cfg.rules
 }
 
 proto_map_init_config() {
index afce6d24d7007059fea8735d81a755fdc2457c82..b4b3d736f006730c2fe56315c0d637e4cc42accf 100644 (file)
@@ -2,7 +2,7 @@
  * mapcalc - MAP parameter calculation
  *
  * Author: Steven Barth <cyrus@openwrt.org>
- * Copyright (c) 2014 cisco Systems, Inc.
+ * Copyright (c) 2014-2015 cisco Systems, Inc.
  *
  * This program is free software; you can redistribute it and/or modify
  * it under the terms of the GNU General Public License version 2
@@ -271,8 +271,10 @@ int main(int argc, char *argv[])
                if (ealen < 0 && pdlen >= 0)
                        ealen = pdlen - prefix6len;
 
-               if (psidlen < 0)
+               if (psidlen <= 0) {
                        psidlen = ealen - (32 - prefix4len);
+                       psid = -1;
+               }
 
                if (psid < 0 && psidlen <= 16 && psidlen >= 0 && pdlen >= 0 && ealen >= psidlen) {
                        bmemcpys64(&psid16, &pd, prefix6len + ealen - psidlen, psidlen);