python-docker: Update to 7.0.0
authorJavier Marcet <javier@marcet.info>
Mon, 1 Jan 2024 10:44:14 +0000 (11:44 +0100)
committerRosen Penev <rosenp@gmail.com>
Tue, 2 Jan 2024 23:22:50 +0000 (15:22 -0800)
Upgrade Notes:
 - Removed SSL version (ssl_version) and explicit hostname check
 (assert_hostname) options
   - assert_hostname has not been used since Python 3.6 and was
   removed in 3.12
   - Python 3.7+ supports TLSv1.3 by default
 - Websocket support is no longer included by default
   - By default, docker-py hijacks the TCP connection and does not use
   Websockets
   - Websocket client is only required to use attach_socket(container,
   ws=True)
 - Python 3.7 no longer officially supported (reached end-of-life June
 2023)

Features:
 - Python 3.12 support
 - Full networking_config support for containers.create()
   - Replaces network_driver_opt (added in 6.1.0)
 - Add health() property to container that returns status (e.g.
 unhealthy)
 - Add pause option to container.commit()
 - Add support for bind mount propagation (e.g. rshared, private)
 - Add filters, keep_storage, and all parameters to prune_builds()
 (requires API v1.39+)

Bugfixes:
 - Consistently return docker.errors.NotFound on 404 responses
 - Validate tag format before image push

Miscellaneous:
 - Upgraded urllib3 version in requirements.txt (used for
 development/tests)
 - Documentation typo fixes & formatting improvements
 - Fixed integration test compatibility for newer Moby engine versions
 - Switch to ruff for linting

Signed-off-by: Javier Marcet <javier@marcet.info>
lang/python/python-docker/Makefile

index 1ce4defb126a3ec9de2fe6dc57144e7ffc04eb26..6eb8516c917cd64b4ccd4b1995f768b076d09cf5 100644 (file)
@@ -1,11 +1,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-docker
-PKG_VERSION:=6.1.3
+PKG_VERSION:=7.0.0
 PKG_RELEASE:=1
 
 PYPI_NAME:=docker
-PKG_HASH:=aa6d17830045ba5ef0168d5eaa34d37beeb113948c413affe1d5991fc11f9a20
+PKG_HASH:=323736fb92cd9418fc5e7133bc953e11a9da04f4483f828b527db553f1e7e5a3
 
 PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
 PKG_LICENSE:=Apache-2.0