kernel: bump 4.14 to 4.14.218
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 1 Feb 2021 09:35:34 +0000 (10:35 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 2 Feb 2021 10:52:31 +0000 (11:52 +0100)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm63xx/patches-4.14/206-USB-EHCI-allow-limiting-ports-for-ehci-platform.patch
target/linux/generic/backport-4.14/012-kbuild-add-macro-for-controlling-warnings-to-linux-c.patch
target/linux/generic/hack-4.14/721-phy_packets.patch
target/linux/generic/pending-4.14/110-ehci_hcd_ignore_oc.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch

index b1542e0029e2e6c0bbfafd9a7f6da701b65d3de2..90a67f5c655962de99a9295b8450702ae4479e1f 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .217
+LINUX_VERSION-4.14 = .218
 
-LINUX_KERNEL_HASH-4.14.217 = 62a36a25431016d98d0f1cff98be432086c51f86fd79042bd10a867b3a924d11
+LINUX_KERNEL_HASH-4.14.218 = e3fe86a15e03dcb8d4d74facd6f902eb994e3a0a7a9f189fad2a1cc7d8655950
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 3d5eda6637b9df2c4e3cf2037e8784c73b6f33a3..5c83ea2028b76b024bb350867f09877da39723b6 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -679,6 +679,10 @@ int ehci_setup(struct usb_hcd *hcd)
+@@ -691,6 +691,10 @@ int ehci_setup(struct usb_hcd *hcd)
  
        /* cache this readonly data; minimize chip reads */
        ehci->hcs_params = ehci_readl(ehci, &ehci->caps->hcs_params);
index 8993b6376c51c2664f26bf35bae8959d3dd93b55..0c2d27ed65096743c9bbf6be9a9b64078c90f244 100644 (file)
@@ -84,7 +84,7 @@ Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
 
 --- a/include/linux/compiler-gcc.h
 +++ b/include/linux/compiler-gcc.h
-@@ -366,3 +366,30 @@
+@@ -372,3 +372,30 @@
  #if GCC_VERSION >= 50100
  #define COMPILER_HAS_GENERIC_BUILTIN_OVERFLOW 1
  #endif
index cd10a3d6cb2cbf9a97581b9d9715e629b7e610cc..684cd3911f9f512a6ffd7afd04442583974ef4ab 100644 (file)
@@ -136,7 +136,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include <net/protocol.h>
  #include <net/dst.h>
-@@ -508,6 +509,22 @@ skb_fail:
+@@ -512,6 +513,22 @@ skb_fail:
  }
  EXPORT_SYMBOL(__napi_alloc_skb);
  
index 4a7f7cfce3ac0414e7d1005d3bdabd50bba5424b..24e4553e45522ad89bdcde27d134e8790df1cb09 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
 
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -652,7 +652,7 @@ static int ehci_run (struct usb_hcd *hcd
+@@ -664,7 +664,7 @@ static int ehci_run (struct usb_hcd *hcd
                "USB %x.%x started, EHCI %x.%02x%s\n",
                ((ehci->sbrn & 0xf0)>>4), (ehci->sbrn & 0x0f),
                temp >> 8, temp & 0xff,
@@ -28,7 +28,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
                    &ehci->regs->intr_enable); /* Turn On Interrupts */
 --- a/drivers/usb/host/ehci-hub.c
 +++ b/drivers/usb/host/ehci-hub.c
-@@ -645,7 +645,7 @@ ehci_hub_status_data (struct usb_hcd *hc
+@@ -648,7 +648,7 @@ ehci_hub_status_data (struct usb_hcd *hc
         * always set, seem to clear PORT_OCC and PORT_CSC when writing to
         * PORT_POWER; that's surprising, but maybe within-spec.
         */
@@ -37,7 +37,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
                mask = PORT_CSC | PORT_PEC | PORT_OCC;
        else
                mask = PORT_CSC | PORT_PEC;
-@@ -1015,7 +1015,7 @@ int ehci_hub_control(
+@@ -1018,7 +1018,7 @@ int ehci_hub_control(
                if (temp & PORT_PEC)
                        status |= USB_PORT_STAT_C_ENABLE << 16;
  
index e6a4dcd4a8caca1d5be6480aeb3e1718cd8a387f..1216ce696798d9a607688459217a9a3add3c8b03 100644 (file)
@@ -837,7 +837,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
 --- a/net/core/skbuff.c
 +++ b/net/core/skbuff.c
-@@ -808,6 +808,32 @@ void napi_consume_skb(struct sk_buff *sk
+@@ -812,6 +812,32 @@ void napi_consume_skb(struct sk_buff *sk
  }
  EXPORT_SYMBOL(napi_consume_skb);
  
@@ -870,7 +870,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  /* Make sure a field is enclosed inside headers_start/headers_end section */
  #define CHECK_SKB_FIELD(field) \
        BUILD_BUG_ON(offsetof(struct sk_buff, field) <          \
-@@ -1327,7 +1353,7 @@ static void skb_headers_offset_update(st
+@@ -1331,7 +1357,7 @@ static void skb_headers_offset_update(st
        skb->inner_mac_header += off;
  }
  
@@ -879,7 +879,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        __copy_skb_header(new, old);
  
-@@ -1335,6 +1361,7 @@ static void copy_skb_header(struct sk_bu
+@@ -1339,6 +1365,7 @@ static void copy_skb_header(struct sk_bu
        skb_shinfo(new)->gso_segs = skb_shinfo(old)->gso_segs;
        skb_shinfo(new)->gso_type = skb_shinfo(old)->gso_type;
  }