Merge "Replace deprecated __ASSEMBLY__ macro with __ASSEMBLER__" into integration
authorSoby Mathew <soby.mathew@arm.com>
Mon, 21 Oct 2019 12:09:52 +0000 (12:09 +0000)
committerTrustedFirmware Code Review <review@review.trustedfirmware.org>
Mon, 21 Oct 2019 12:09:52 +0000 (12:09 +0000)
14 files changed:
docs/components/firmware-update.rst
docs/conf.py
docs/design/firmware-design.rst
docs/getting_started/image-terminology.rst
docs/getting_started/porting-guide.rst
docs/getting_started/user-guide.rst
docs/index.rst
docs/maintainers.rst
docs/perf/psci-performance-juno.rst
docs/plat/marvell/porting.rst
docs/plat/meson-g12a.rst
docs/process/coding-guidelines.rst
docs/security_advisories/security-advisory-tfv-6.rst
drivers/arm/pl011/aarch32/pl011_console.S

index 2bff00f514a92ccd6c0cbe6633f71900475693f2..a591565681f6bdd39580358daad9eaf5b3990a40 100644 (file)
@@ -7,7 +7,7 @@ Introduction
 This document describes the design of the Firmware Update (FWU) feature, which
 enables authenticated firmware to update firmware images from external
 interfaces such as USB, UART, SD-eMMC, NAND, NOR or Ethernet to SoC Non-Volatile
-memories such as NAND Flash, LPPDR2-NVM or any memory determined by the
+memories such as NAND Flash, LPDDR2-NVM or any memory determined by the
 platform. This feature functions even when the current firmware in the system
 is corrupt or missing; it therefore may be used as a recovery mode. It may also
 be complemented by other, higher level firmware update software.
index b267de0e86311a2110c626a6e7cb98d766a1f2bf..a100241c1c0bd14ba8209ba0d9574c7a81618bb4 100644 (file)
@@ -15,9 +15,6 @@ import os
 
 project = 'Trusted Firmware-A'
 
-version = '2.1'
-release = version # We don't need these to be distinct
-
 # -- General configuration ---------------------------------------------------
 
 # Add any Sphinx extension module names here, as strings. They can be
index 1deacb7f9ff4ace74b83dfb72a4b328b82403d3a..4958fc0974daf814367eb6aa5dd8bb82c8315bbf 100644 (file)
@@ -1672,7 +1672,7 @@ The following list describes the memory layout on the Arm development platforms:
    point during a cold boot.
 
 -  On Juno, SCP_BL2 is loaded temporarily into the EL3 Runtime Software memory
-   region and transfered to the SCP before being overwritten by EL3 Runtime
+   region and transferred to the SCP before being overwritten by EL3 Runtime
    Software.
 
 -  BL32 (for AArch64) can be loaded in one of the following locations:
@@ -2623,7 +2623,7 @@ Cortex-A architecture through ``ARM_CORTEX_A<X> = yes`` in their
 Cortex-A15 target.
 
 Platform can also set ``ARM_WITH_NEON=yes`` to enable neon support.
-Note that using neon at runtime has constraints on non secure wolrd context.
+Note that using neon at runtime has constraints on non secure world context.
 TF-A does not yet provide VFP context management.
 
 Directive ``ARM_CORTEX_A<x>`` and ``ARM_WITH_NEON`` are used to set
index d9e08f76cdd27ddb3066341cd93d44ff33d82826..5993d6e7ac6383540069d7ab03962efaa60a72dc 100644 (file)
@@ -7,7 +7,7 @@ images referred to in the Trusted Firmware project.
 General Notes
 -------------
 
-- Some of the names and abbreviated names have changed to accomodate new
+- Some of the names and abbreviated names have changed to accommodate new
   requirements. The changed names are as backward compatible as possible to
   minimize confusion. Where applicable, the previous names are indicated. Some
   code, documentation and build artefacts may still refer to the previous names;
@@ -44,7 +44,7 @@ AP Boot ROM: ``AP_BL1``
 ~~~~~~~~~~~~~~~~~~~~~~~
 
 Typically, this is the first code to execute on the AP and cannot be modified.
-Its primary purpose is to perform the minimum intialization necessary to load
+Its primary purpose is to perform the minimum initialization necessary to load
 and authenticate an updateable AP firmware image into an executable RAM
 location, then hand-off control to that image.
 
@@ -96,7 +96,7 @@ SCP Boot ROM: ``SCP_BL1`` (previously ``BL0``)
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 Typically, this is the first code to execute on the SCP and cannot be modified.
-Its primary purpose is to perform the minimum intialization necessary to load
+Its primary purpose is to perform the minimum initialization necessary to load
 and authenticate an updateable SCP firmware image into an executable RAM
 location, then hand-off control to that image. This may be performed in
 conjunction with other processor firmware (for example, ``AP_BL1`` and
@@ -129,7 +129,7 @@ AP Firmware Update Boot ROM: ``AP_NS_BL1U``
 
 Typically, this is the first normal world code to execute on the AP during a
 firmware update operation, and cannot be modified. Its primary purpose is to
-load subequent firmware update images from an external interface and communicate
+load subsequent firmware update images from an external interface and communicate
 with ``AP_BL1`` to authenticate those images.
 
 During firmware update, there are (potentially) multiple transitions between the
index d7157690d6a0eda8980cd24a019c2e3427a9c699..9cca75e92fc40d281cc6397294532bd3b8584300 100644 (file)
@@ -549,7 +549,7 @@ optionally be defined:
 -  **PLAT_PARTITION_BLOCK_SIZE**
    The size of partition block. It could be either 512 bytes or 4096 bytes.
    The default value is 512.
-   `For example, define the build flag in platform.mk`_:
+   For example, define the build flag in ``platform.mk``:
    PLAT_PARTITION_BLOCK_SIZE := 4096
    $(eval $(call add_define,PLAT_PARTITION_BLOCK_SIZE))
 
@@ -954,7 +954,7 @@ Function : plat_reset_handler()
     Return   : void
 
 A platform may need to do additional initialization after reset. This function
-allows the platform to do the platform specific intializations. Platform
+allows the platform to do the platform specific initializations. Platform
 specific errata workarounds could also be implemented here. The API should
 preserve the values of callee saved registers x19 to x29.
 
@@ -2777,7 +2777,7 @@ more functionality is required, the needed library functions will need to be
 added to the local implementation.
 
 Some C headers have been obtained from `FreeBSD`_ and `SCC`_, while others have
-been written specifically for TF-A. Fome implementation files have been obtained
+been written specifically for TF-A. Some implementation files have been obtained
 from `FreeBSD`_, others have been written specifically for TF-A as well. The
 files can be found in ``include/lib/libc`` and ``lib/libc``.
 
index c7359ada3a63e0927dcf1962d77087cd7df45d1d..3dd23e5b32e6f6b1e76849068a834fb9268f6797 100644 (file)
@@ -188,8 +188,6 @@ Building TF-A
       `Summary of build options`_ for more information on available build
       options.
 
-   -  (AArch32 only) Currently only ``PLAT=fvp`` is supported.
-
    -  (AArch32 only) ``AARCH32_SP`` is the AArch32 EL3 Runtime Software and it
       corresponds to the BL32 image. A minimal ``AARCH32_SP``, sp_min, is
       provided by TF-A to demonstrate how PSCI Library can be integrated with
@@ -1360,7 +1358,7 @@ a single FIP binary. It assumes that a `Linaro Release`_ has been installed.
        make [DEBUG=1] [V=1] fiptool
 
        # Unpack firmware images from Linaro FIP
-       ./tools/fiptool/fiptool unpack <path-to-linaro-release>/fip.bin
+       ./tools/fiptool/fiptool unpack <path-to-linaro-release>/[SOFTWARE]/fip.bin
 
    The unpack operation will result in a set of binary images extracted to the
    current working directory. The SCP_BL2 image corresponds to
@@ -1407,7 +1405,7 @@ a single FIP binary. It assumes that a `Linaro Release`_ has been installed.
 
       .. code:: shell
 
-          export CROSS_COMPILE=<path-to-aarch32-gcc>/bin/arm-linux-gnueabihf-
+          export CROSS_COMPILE=<path-to-aarch32-gcc>/bin/arm-eabi-
 
    -  Build BL32 in AArch32.
 
index 4f0f6ef79c1320db9712d48ab76a38fffb75bd77..4cd17988c628f8a3fac6e6e03f0c28bc4231ac00 100644 (file)
@@ -154,7 +154,7 @@ Arm FVPs without shifted affinities, and that do not support threaded CPU cores
 (64-bit host machine only).
 
 .. note::
-   The FVP models used are Version 11.5 Build 33, unless otherwise stated.
+   The FVP models used are Version 11.6 Build 45, unless otherwise stated.
 
 -  ``FVP_Base_AEMv8A-AEMv8A``
 -  ``FVP_Base_AEMv8A-AEMv8A-AEMv8A-AEMv8A-CCN502``
@@ -197,7 +197,7 @@ Arm FVPs without shifted affinities, and that do not support threaded CPU cores
 The Foundation FVP can be downloaded free of charge. The Base FVPs can be
 licensed from Arm. See the `Arm FVP website`_.
 
-All the above platforms have been tested with `Linaro Release 18.04`_.
+All the above platforms have been tested with `Linaro Release 19.06`_.
 
 This release also contains the following platform support:
 
@@ -288,7 +288,7 @@ Arm licensees may contact Arm directly via their partner managers.
 .. _Juno Arm Development Platform: http://www.arm.com/products/tools/development-boards/versatile-express/juno-arm-development-platform.php
 .. _Arm FVP website: FVP_
 .. _FVP: https://developer.arm.com/products/system-design/fixed-virtual-platforms
-.. _Linaro Release 18.04: https://community.arm.com/dev-platforms/b/documents/posts/linaro-release-notes-deprecated#LinaroRelease18.04
+.. _Linaro Release 19.06: http://releases.linaro.org/members/arm/platforms/19.06
 .. _OP-TEE Secure OS: https://github.com/OP-TEE/optee_os
 .. _NVIDIA Trusted Little Kernel: http://nv-tegra.nvidia.com/gitweb/?p=3rdparty/ote_partner/tlk.git;a=summary
 .. _Trusty Secure OS: https://source.android.com/security/trusty
index d997baace00d38ab8a9da5bc621b5c916f0ffe3c..86e445a76c5e10efcecaaf7f6247e06ee1e2f299 100644 (file)
@@ -49,9 +49,9 @@ Amlogic Meson S905x (GXL) platform port
 :F: plat/amlogic/gxl/
 
 Amlogic Meson S905X2 (G12A) platform port
----------------------------------------
+-----------------------------------------
 :M: Carlo Caione <ccaione@baylibre.com>
-:G: `carlo.caione`_
+:G: `carlocaione`_
 :F: docs/plat/meson-g12a.rst
 :F: drivers/amlogic/g12a
 :F: plat/amlogic/g12a/
@@ -122,7 +122,7 @@ Intel SocFPGA platform ports
 :M: Tien Hock Loh <tien.hock.loh@intel.com>
 :G: `thloh85-intel`_
 :M: Hadi Asyrafi <muhammad.hadi.asyrafi.abdul.halim@intel.com>
-:G: `mabdulha`_
+:G: mabdulha
 :F: plat/intel/soc
 :F: drivers/intel/soc/
 
@@ -282,6 +282,7 @@ Xilinx platform port
 .. _Anson-Huang: https://github.com/Anson-Huang
 .. _bryanodonoghue: https://github.com/bryanodonoghue
 .. _b49020: https://github.com/b49020
+.. _carlocaione: https://github.com/carlocaione
 .. _danh-arm: https://github.com/danh-arm
 .. _etienne-lms: https://github.com/etienne-lms
 .. _glneo: https://github.com/glneo
@@ -308,6 +309,7 @@ Xilinx platform port
 .. _sivadur: https://github.com/sivadur
 .. _smaeul: https://github.com/smaeul
 .. _soby-mathew: https://github.com/soby-mathew
+.. _thloh85-intel: https://github.com/thloh85-intel
 .. _thomas-arm: https://github.com/thomas-arm
 .. _TonyXie06: https://github.com/TonyXie06
 .. _vwadekar: https://github.com/vwadekar
index 4cc43026579b6c00390bce2a5cef3d5766a82db9..c127c1c4ad9c28f34b48f1878710a039198dc3ec 100644 (file)
@@ -168,7 +168,7 @@ the cache associated with power level 0 is flushed (L1).
 | 5     | 21                  | 17                 | 6                        |
 +-------+---------------------+--------------------+--------------------------+
 
-The ``CLUSH_OVERHEAD`` times for lead CPU 4 and all CPUs in the non-lead cluster
+The ``CFLUSH_OVERHEAD`` times for lead CPU 4 and all CPUs in the non-lead cluster
 are large because all other CPUs in the cluster are powered down during the
 test. The ``CPU_SUSPEND`` call powers down to the cluster level, requiring a
 flush of both L1 and L2 caches.
index 8fc1c1f6dbb55a592952866661505465f1599c65..0a71dbd54dbbed75d8c8ec9186e5631abf4c799a 100644 (file)
@@ -112,7 +112,7 @@ Comphy Porting (phy-porting-layer.h or phy-default-porting-layer.h)
 
     .. seealso::
         For XFI/SFI comphy type there is procedure "rx_training" which eases
-        process of suiting some of the parameters. Please see :ref:`uboot_cmd`
+        process of suiting some of the parameters. Please see *uboot_cmd*
         section: rx_training.
 
     The PHY porting layer simplifies updating static values per board type,
index 1021da47c03fdbec7d96f464e4cf09822ac1ec26..7cd1bf746eff77663c85010d396e54a51c63cfa3 100644 (file)
@@ -1,5 +1,5 @@
 Amlogic Meson S905X2 (G12A)
-==========================
+===========================
 
 The Amlogic Meson S905X2 is a SoC with a quad core Arm Cortex-A53 running at
 ~1.8GHz. It also contains a Cortex-M3 used as SCP.
index a53da77b94ccba777328f674afe1f2df6953eb69..cb8b892455deacfeb0cce0dc2e9daf41228a4b2d 100644 (file)
@@ -23,8 +23,8 @@ include:
 
 - ``**WARNING: Use of volatile is usually wrong``: see
   `Why the “volatile” type class should not be used`_ . Although this document
-  contains some very useful information, there are several legimate uses of the
-  volatile keyword within the TF codebase.
+  contains some very useful information, there are several legitimate uses of
+  the volatile keyword within the TF codebase.
 
 Headers and inclusion
 ---------------------
index 495edddae5f5be2fc63a2b3f24dd23b6317bb5da..9eeaeec575067d0039cb386b366b37fbf22f3ae1 100644 (file)
@@ -51,7 +51,7 @@ the MMU.
 For Cortex-A73 and Cortex-A75 CPUs, the PRs in this advisory invalidate the
 branch predictor when entering EL3 by temporarily dropping into AArch32
 Secure-EL1 and executing the ``BPIALL`` instruction. This workaround is
-signifiantly more complex than the "MMU disable/enable" workaround. The latter
+significantly more complex than the "MMU disable/enable" workaround. The latter
 is not effective at invalidating the branch predictor on Cortex-A73/Cortex-A75.
 
 Note that if other privileged software, for example a Rich OS kernel, implements
index e1e346c2f7bf5c953167ca597cc2df6808088899..05c8250dc3a97e5d4d14e54379a7e82aae2aa3e6 100644 (file)
@@ -57,7 +57,7 @@ func console_pl011_core_init
 #if (ARM_ARCH_MAJOR == 7) && !defined(ARMV7_SUPPORTS_VIRTUALIZATION)
        push    {r0,r3}
        softudiv        r0,r1,r2,r3
-       mov     r1, r0
+       mov     r2, r0
        pop     {r0,r3}
 #else
        udiv    r2, r1, r2