ar71xx: fix AVM package selection
authorDavid Bauer <mail@david-bauer.net>
Fri, 8 Jun 2018 19:41:25 +0000 (21:41 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 9 Jun 2018 11:46:01 +0000 (13:46 +0200)
The AVM package selection partially broke with the addition of the
FRITZ!Box 4020. This commit restores the intended behavior.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ar71xx/image/generic.mk

index bceeba0009e366357e4f7ab3e3858dc310fc4f02..a49b0d655d92c0a98fa2851b3a4aedde47184dce 100644 (file)
@@ -1305,7 +1305,7 @@ endef
 define Device/fritz300e
   $(call Device/AVM)
   DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
-  DEVICE_PACKAGES := rssileds -swconfig
+  DEVICE_PACKAGES += rssileds -swconfig
   BOARDNAME := FRITZ300E
   SUPPORTED_DEVICES := fritz300e
   IMAGE_SIZE := 15232k
@@ -1315,7 +1315,7 @@ TARGET_DEVICES += fritz300e
 define Device/fritz4020
   $(call Device/AVM)
   DEVICE_TITLE := AVM FRITZ!Box 4020
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage
+  DEVICE_PACKAGES += kmod-usb-core kmod-usb2 kmod-usb-storage
   BOARDNAME := FRITZ4020
   SUPPORTED_DEVICES := fritz4020
   IMAGE_SIZE := 15232k