mpc85xx: only build zImage on required targets master
authorDavid Bauer <mail@david-bauer.net>
Sat, 8 Jun 2024 02:34:09 +0000 (04:34 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sat, 8 Jun 2024 02:34:12 +0000 (04:34 +0200)
Make the OF-compatible zImage per-board selectable. This allows the
image to only be built with the wrapper if the target actually uses it.

This fixes build-failures for the mpc85xx-p2020 subtarget.

Fixes: blabla
Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mpc85xx/patches-6.1/010-powerpc-add-compressed-zImage-for-mpc85xx.patch
target/linux/mpc85xx/patches-6.1/111-powerpc-85xx-hpe-msm-support.patch

index edf541a8ccd263b0861cb0ea9b8f4ada522272b1..16ef37bd78c83ad114c508a929ccdd7f1f5b7038 100644 (file)
@@ -16,11 +16,19 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -345,6 +345,7 @@ image-$(CONFIG_MPC836x_MDS)                += cuImage.
+@@ -175,6 +175,7 @@ src-plat-$(CONFIG_EMBEDDED6xx) += cuboot
+ src-plat-$(CONFIG_AMIGAONE) += cuboot-amigaone.c
+ src-plat-$(CONFIG_PPC_PS3) += ps3-head.S ps3-hvcall.S ps3.c
+ src-plat-$(CONFIG_EPAPR_BOOT) += epapr.c epapr-wrapper.c
++src-plat-$(CONFIG_PPC_ZIMAGE_LA3000000) += fixed-head.S
+ src-plat-$(CONFIG_PPC_PSERIES) += pseries-head.S
+ src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
+ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
+@@ -345,6 +346,7 @@ image-$(CONFIG_MPC836x_MDS)                += cuImage.
  image-$(CONFIG_ASP834x)                       += dtbImage.asp834x-redboot
  
  # Board ports in arch/powerpc/platform/85xx/Kconfig
-+image-y                                       += zImage.la3000000
++image-$(CONFIG_PPC_ZIMAGE_LA3000000)   += zImage.la3000000
  image-$(CONFIG_MPC8540_ADS)           += cuImage.mpc8540ads
  image-$(CONFIG_MPC8560_ADS)           += cuImage.mpc8560ads
  image-$(CONFIG_MPC85xx_CDS)           += cuImage.mpc8541cds \
@@ -38,3 +46,16 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  of)
      platformo="$object/of.o $object/epapr.o"
      make_space=n
+--- a/arch/powerpc/Kconfig
++++ b/arch/powerpc/Kconfig
+@@ -74,6 +74,10 @@ config NMI_IPI
+       depends on SMP && (DEBUGGER || KEXEC_CORE || HARDLOCKUP_DETECTOR)
+       default y
++config PPC_ZIMAGE_LA3000000
++       bool
++       default n
++
+ config PPC_WATCHDOG
+       bool
+       depends on HARDLOCKUP_DETECTOR
index 10ad4b98bdd083ca406197264c8005b0bb64472b..4b9c6f82196c75b5be72a25db9829d4b7f2228c0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -114,6 +114,17 @@ config FIREBOX_T10
+@@ -114,6 +114,18 @@ config FIREBOX_T10
          This board is a VPN Gateway-Router with a
          Freescale P1010 SoC.
  
@@ -9,6 +9,7 @@
 +      select DEFAULT_UIMAGE
 +      select ARCH_REQUIRE_GPIOLIB
 +      select GPIO_MPC8XXX
++      select PPC_ZIMAGE_LA3000000
 +      help
 +        This option enables support for the HPE MSM460 board.
 +