privoxy: use PKG_NAME variable instead of hardcoding privoxy 22539/head
authorChristian Marangi <ansuelsmth@gmail.com>
Thu, 2 Nov 2023 19:48:03 +0000 (20:48 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 2 Nov 2023 19:48:03 +0000 (20:48 +0100)
Use PKG_NAME in PKG_SOURCE AND PKG_BUILD_DIR instead of hardcoding to
privoxy to make the Makefile cleaner.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
net/privoxy/Makefile

index 8ec658cba74c7352be7ce50287a9d286b21abebc..485280964bac5689131fc5cea54dcf147ffad64d 100644 (file)
@@ -11,10 +11,10 @@ PKG_NAME:=privoxy
 PKG_VERSION:=3.0.34
 PKG_RELEASE:=1
 
-PKG_SOURCE:=privoxy-$(PKG_VERSION)-stable-src.tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
 PKG_HASH:=e6ccbca1656f4e616b4657f8514e33a70f6697e9d7294356577839322a3c5d2c
-PKG_BUILD_DIR:=$(BUILD_DIR)/privoxy-$(PKG_VERSION)-stable
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1