Add support for NLS,including KOI8-R (Russian) (#819)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 4 Nov 2006 14:25:57 +0000 (14:25 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 4 Nov 2006 14:25:57 +0000 (14:25 +0000)
SVN-Revision: 5444

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-nls-cp437.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-cp850.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-iso8859-1.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-iso8859-15.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-koi8-r.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-nls-utf8.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index 4c3453494a2a7fe503c10d8f666c66a9bedb1ca0..14eb835c88044b929d3879eefd3e56b6d5fcc7b7 100644 (file)
@@ -301,6 +301,42 @@ config BR2_PACKAGE_KMOD_IDE
            - ide-disk
            - pdc202xx_old
 
+config BR2_PACKAGE_KMOD_NLS_CP437
+       tristate "Codepage 437 (United States, Canada)"
+       default m
+       help
+         Kernel module for NLS Codepage 437 (United States, Canada)
+
+config BR2_PACKAGE_KMOD_NLS_CP850
+       tristate "Codepage 850 (Europe)"
+       default m
+       help
+         Kernel module for NLS Codepage 850 (Europe)
+
+config BR2_PACKAGE_KMOD_NLS_ISO8859_1
+       tristate "ISO 8859-1 (Latin 1; Western European Languages)"
+       default m
+       help
+         Kernel module for ISO 8859-1 (Latin 1)
+
+config BR2_PACKAGE_KMOD_NLS_ISO8859_15
+       tristate "ISO 8859-15 (Latin 9; Western, with Euro symbol)"
+       default m
+       help
+         Kernel module for ISO 8859-15 (Latin 9)
+
+config BR2_PACKAGE_KMOD_NLS_KOI8_R
+       tristate "KOI8-R (Russian)"
+       default m
+       help
+         Kernel module for KOI8-R (Russian)
+
+config BR2_PACKAGE_KMOD_NLS_UTF8
+       tristate "UTF8"
+       default m
+       help
+         Kernel module for UTF8
+
 config BR2_PACKAGE_KMOD_VFAT
        tristate "VFAT filesystem support"
        default m
diff --git a/openwrt/target/linux/control/kmod-nls-cp437.control b/openwrt/target/linux/control/kmod-nls-cp437.control
new file mode 100644 (file)
index 0000000..c8f6bdf
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-nls-cp437
+Priority: optional
+Section: sys
+Description: Kernel module for NLS Codepage 437 (United States, Canada)
diff --git a/openwrt/target/linux/control/kmod-nls-cp850.control b/openwrt/target/linux/control/kmod-nls-cp850.control
new file mode 100644 (file)
index 0000000..b301495
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-nls-cp850
+Priority: optional
+Section: sys
+Description: Kernel module for NLS Codepage 850 (Europe)
diff --git a/openwrt/target/linux/control/kmod-nls-iso8859-1.control b/openwrt/target/linux/control/kmod-nls-iso8859-1.control
new file mode 100644 (file)
index 0000000..95a1bdb
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-nls-iso8859-1
+Priority: optional
+Section: sys
+Description: Kernel module for ISO 8859-1 (Latin 1)
diff --git a/openwrt/target/linux/control/kmod-nls-iso8859-15.control b/openwrt/target/linux/control/kmod-nls-iso8859-15.control
new file mode 100644 (file)
index 0000000..0583f35
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-nls-iso8859-15
+Priority: optional
+Section: sys
+Description: Kernel module for ISO 8859-15 (Latin 9)
diff --git a/openwrt/target/linux/control/kmod-nls-koi8-r.control b/openwrt/target/linux/control/kmod-nls-koi8-r.control
new file mode 100644 (file)
index 0000000..60b7a3c
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-nls-koi8-r
+Priority: optional
+Section: sys
+Description: Kernel module for KOI8-R (Russian)
diff --git a/openwrt/target/linux/control/kmod-nls-utf8.control b/openwrt/target/linux/control/kmod-nls-utf8.control
new file mode 100644 (file)
index 0000000..75af1f5
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-nls-utf8
+Priority: optional
+Section: sys
+Description: Kernel module for NLS UTF-8
index 590ba375cc5d2f906de07ef0a8d18bc12b7544ab..e4c82cbebaab9f6c0c3e9dedad9c00426286af93 100644 (file)
@@ -203,6 +203,24 @@ $(eval $(call KMOD_template,VFAT,vfat,\
        $(MODULES_DIR)/kernel/fs/vfat/vfat.o \
        $(MODULES_DIR)/kernel/fs/fat/fat.o \
 ,CONFIG_VFAT_FS,,30,fat vfat))
+$(eval $(call KMOD_template,NLS_CP437,nls-cp437,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_cp437.o \
+,CONFIG_NLS_CODEPAGE_437,,40,nls_cp437.o))
+$(eval $(call KMOD_template,NLS_CP850,nls-cp850,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_cp850.o \
+,CONFIG_NLS_CODEPAGE_850,,40,nls_cp850.o))
+$(eval $(call KMOD_template,NLS_ISO8859_1,nls-iso8859-1,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_iso8859-1.o \
+,CONFIG_NLS_ISO8859_1,,40,nls_iso8859-1.o))
+$(eval $(call KMOD_template,NLS_ISO8859_15,nls-iso8859-15,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_iso8859-15.o \
+,CONFIG_NLS_ISO8859_15,,40,nls_iso8859-15.o))
+$(eval $(call KMOD_template,NLS_KOI8_R,nls-koi8-r,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_koi8-r.o \
+,CONFIG_NLS_KOI8_R,,40,nls_koi8-r.o))
+$(eval $(call KMOD_template,NLS_UTF8,nls-utf8,\
+       $(MODULES_DIR)/kernel/fs/nls/nls_utf8.o \
+,CONFIG_NLS_UTF8,,40,nls_utf8.o))
 $(eval $(call KMOD_template,CRYPTO,crypto,\
        $(MODULES_DIR)/kernel/crypto/*.o \
 ,,,20,arc4 \
index 2dc1393971a9d2c8759aa1c552a16dd65071213b..399df70e87e2aa12abce7fb31459477a11f75013 100644 (file)
@@ -1131,10 +1131,10 @@ CONFIG_NLS=y
 # Native Language Support
 #
 CONFIG_NLS_DEFAULT="iso8859-1"
-# CONFIG_NLS_CODEPAGE_437 is not set
+CONFIG_NLS_CODEPAGE_437=m
 # CONFIG_NLS_CODEPAGE_737 is not set
 # CONFIG_NLS_CODEPAGE_775 is not set
-# CONFIG_NLS_CODEPAGE_850 is not set
+CONFIG_NLS_CODEPAGE_850=m
 # CONFIG_NLS_CODEPAGE_852 is not set
 # CONFIG_NLS_CODEPAGE_855 is not set
 # CONFIG_NLS_CODEPAGE_857 is not set
@@ -1154,7 +1154,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
 # CONFIG_NLS_ISO8859_8 is not set
 # CONFIG_NLS_CODEPAGE_1250 is not set
 # CONFIG_NLS_CODEPAGE_1251 is not set
-# CONFIG_NLS_ISO8859_1 is not set
+CONFIG_NLS_ISO8859_1=m
 # CONFIG_NLS_ISO8859_2 is not set
 # CONFIG_NLS_ISO8859_3 is not set
 # CONFIG_NLS_ISO8859_4 is not set
@@ -1164,10 +1164,10 @@ CONFIG_NLS_DEFAULT="iso8859-1"
 # CONFIG_NLS_ISO8859_9 is not set
 # CONFIG_NLS_ISO8859_13 is not set
 # CONFIG_NLS_ISO8859_14 is not set
-# CONFIG_NLS_ISO8859_15 is not set
-# CONFIG_NLS_KOI8_R is not set
+CONFIG_NLS_ISO8859_15=m
+CONFIG_NLS_KOI8_R=m
 # CONFIG_NLS_KOI8_U is not set
-# CONFIG_NLS_UTF8 is not set
+CONFIG_NLS_UTF8=m
 
 #
 # Multimedia devices