pcre: disable shared libraries for host builds
authorRosen Penev <rosenp@gmail.com>
Sat, 19 Mar 2022 23:18:49 +0000 (16:18 -0700)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 27 Mar 2022 12:38:13 +0000 (14:38 +0200)
Getting rid of shared libraries for hostpkg avoids having to use rpath
hacks to find the library. It also fixes compilation with host glib2
binaries.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/pcre/Makefile

index 42149fc511f1d0cb9296c61c25c968ba95cc0fd3..43267562eaf2d1836f4d7cf480c56ebd45501e8b 100644 (file)
@@ -62,6 +62,7 @@ define Package/libpcrecpp
 endef
 
 HOST_CONFIGURE_ARGS += \
+       --disable-shared \
        --enable-utf8 \
        --enable-unicode-properties \
        --enable-pcre16 \