replace xargs commands with $(XARGS)
authorNicolas Thill <nico@openwrt.org>
Fri, 24 Aug 2007 12:10:14 +0000 (12:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 24 Aug 2007 12:10:14 +0000 (12:10 +0000)
SVN-Revision: 8478

include/package.mk

index 1f4d8878ec713bfb58cc0f67f7791f06aaae9963..125355ba4a49bd41c3f6246dc6439021c1b1953d 100644 (file)
@@ -104,13 +104,13 @@ endef
 
 # prevent libtool from setting rpath when linking
 define libtool_disable_rpath
-       find $(PKG_BUILD_DIR) -name 'libtool' | xargs \
+       find $(PKG_BUILD_DIR) -name 'libtool' | $(XARGS) \
                $(SED) 's,^hardcode_libdir_flag_spec=.*,hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ ",g'
 endef
 
 # prevent libtool from linking against host development libraries
 define libtool_fixup_libdir
-       find $(PKG_BUILD_DIR) -name '*.la' | xargs \
+       find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
                $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
 endef