realtek: build DGS-1210 images with CAMEO tag
authorMarkus Stockhausen <markus.stockhausen@gmx.de>
Tue, 5 Jul 2022 06:46:59 +0000 (08:46 +0200)
committerSander Vanheule <sander@svanheule.net>
Tue, 5 Jul 2022 07:56:37 +0000 (09:56 +0200)
From now on we will insert CAMEO tags into sysupgrade images for
DGS-1210 devices. This will make the "OS:...FAILED" and "FS:...FAILED"
messages go away.

Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de>
target/linux/realtek/image/Makefile
target/linux/realtek/image/rtl838x.mk

index b54a1f0a8d6c08d6d73b49bccf08b98ee1f1c284..3a1ba2f60e81c9cae4ef7560629d86fe53f25b02 100644 (file)
@@ -17,6 +17,10 @@ define Build/zyxel-vers
        done ) >> $@
 endef
 
+define Build/dlink-cameo
+       $(SCRIPT_DIR)/cameo-tag.py $@ $(DLINK_KERNEL_PART_SIZE)
+endef
+
 define Build/dlink-headers
         dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
         dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
index c01acd10bc4a60437107f7f5d574395e2ed6fb2c..dc181821105f19b0ebbbd6b1c3a9f09d32cc6ac1 100644 (file)
@@ -16,6 +16,7 @@ define Device/d-link_dgs-1210
   IMAGE_SIZE := 13824k
   DEVICE_VENDOR := D-Link
   DLINK_KERNEL_PART_SIZE := 1572864
+  KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
 endef
 
 define Device/d-link_dgs-1210-10p