kernel: bump 4.9 to 4.9.160
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Feb 2019 10:24:12 +0000 (11:24 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Feb 2019 16:34:25 +0000 (17:34 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch
target/linux/generic/hack-4.9/721-phy_packets.patch
target/linux/ixp4xx/patches-4.9/600-skb_avoid_dmabounce.patch
target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch

index 98cf7cafe495e17a0d6c6b1b3fe19d9c9e293364..311922fab698c7c8df4cebc16ce9a4aa40b67a99 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .159
 LINUX_VERSION-4.14 = .102
+LINUX_VERSION-4.9 = .160
 
-LINUX_KERNEL_HASH-4.9.159 = 9f9df13168a090d12314e2e8dac040e71ce3f2ed89eafbece2b14dabb6771742
 LINUX_KERNEL_HASH-4.14.102 = d8a982cfa2804edc2ae9d20792ab0e3897f3976ced5632f2392c2e1918562501
+LINUX_KERNEL_HASH-4.9.160 = c09af067af62d299f5e33c279968de58c88fb7c59bd05e8f3bb460f611f60515
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index d1da94b4e68597f66872e84ad244dd5945fccbd5..facc43004e5ebec05d54e0d55923fc55d66e8fa4 100644 (file)
@@ -108,7 +108,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
        local_irq_restore(flags);
        return data;
  }
-@@ -391,7 +391,7 @@ static void *__napi_alloc_frag(unsigned
+@@ -393,7 +393,7 @@ static void *__napi_alloc_frag(unsigned
  {
        struct napi_alloc_cache *nc = this_cpu_ptr(&napi_alloc_cache);
  
@@ -117,7 +117,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  }
  
  void *napi_alloc_frag(unsigned int fragsz)
-@@ -441,7 +441,7 @@ struct sk_buff *__netdev_alloc_skb(struc
+@@ -445,7 +445,7 @@ struct sk_buff *__netdev_alloc_skb(struc
        local_irq_save(flags);
  
        nc = this_cpu_ptr(&netdev_alloc_cache);
@@ -126,7 +126,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
        pfmemalloc = nc->pfmemalloc;
  
        local_irq_restore(flags);
-@@ -505,7 +505,7 @@ struct sk_buff *__napi_alloc_skb(struct
+@@ -509,7 +509,7 @@ struct sk_buff *__napi_alloc_skb(struct
        if (sk_memalloc_socks())
                gfp_mask |= __GFP_MEMALLOC;
  
index 9bc5b01776a20874b0811c60b0d8c9a065295a14..d22c8730325f32845cd8f0f1fa1494562cb25650 100644 (file)
@@ -136,7 +136,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include <net/protocol.h>
  #include <net/dst.h>
-@@ -529,6 +530,22 @@ skb_fail:
+@@ -533,6 +534,22 @@ skb_fail:
  }
  EXPORT_SYMBOL(__napi_alloc_skb);
  
index 046ec4e8f3af9adf83468a9354bf491e36b3d44e..cdd9fde8f076a419f781af4f48c800f9975083a7 100644 (file)
@@ -10,7 +10,7 @@
  
        /* Get the HEAD */
        skb = kmem_cache_alloc_node(cache, gfp_mask & ~__GFP_DMA, node);
-@@ -1224,6 +1227,10 @@ int pskb_expand_head(struct sk_buff *skb
+@@ -1228,6 +1231,10 @@ int pskb_expand_head(struct sk_buff *skb
        if (skb_shared(skb))
                BUG();
  
index cc66e7f3e1a54ce39f5262c09a453a04d8a224d6..c5b06ec7f475452d0164a1e01fef6eff6af8b0f8 100644 (file)
@@ -338,7 +338,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* register save area for suspend/resume */
 --- a/include/linux/netdev_features.h
 +++ b/include/linux/netdev_features.h
-@@ -74,6 +74,7 @@ enum {
+@@ -76,6 +76,7 @@ enum {
        NETIF_F_BUSY_POLL_BIT,          /* Busy poll */
  
        NETIF_F_HW_TC_BIT,              /* Offload TC infrastructure */
@@ -346,14 +346,14 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        /*
         * Add your fresh new feature above and remember to update
-@@ -136,6 +137,7 @@ enum {
+@@ -138,6 +139,7 @@ enum {
  #define NETIF_F_HW_L2FW_DOFFLOAD      __NETIF_F(HW_L2FW_DOFFLOAD)
  #define NETIF_F_BUSY_POLL     __NETIF_F(BUSY_POLL)
  #define NETIF_F_HW_TC         __NETIF_F(HW_TC)
 +#define NETIF_F_HW_ACCEL_MQ   __NETIF_F(HW_ACCEL_MQ)
  
- #define for_each_netdev_feature(mask_addr, bit)       \
-       for_each_set_bit(bit, (unsigned long *)mask_addr, NETDEV_FEATURE_COUNT)
+ /* Finds the next feature with the highest number of the range of start till 0.
+  */
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
 @@ -1512,6 +1512,8 @@ enum netdev_priv_flags {
@@ -444,7 +444,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                return -ENODEV;
 --- a/net/core/skbuff.c
 +++ b/net/core/skbuff.c
-@@ -842,6 +842,32 @@ void napi_consume_skb(struct sk_buff *sk
+@@ -846,6 +846,32 @@ void napi_consume_skb(struct sk_buff *sk
  }
  EXPORT_SYMBOL(napi_consume_skb);
  
@@ -477,7 +477,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  /* Make sure a field is enclosed inside headers_start/headers_end section */
  #define CHECK_SKB_FIELD(field) \
        BUILD_BUG_ON(offsetof(struct sk_buff, field) <          \
-@@ -1075,7 +1101,7 @@ static void skb_headers_offset_update(st
+@@ -1079,7 +1105,7 @@ static void skb_headers_offset_update(st
        skb->inner_mac_header += off;
  }
  
@@ -486,7 +486,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        __copy_skb_header(new, old);
  
-@@ -1083,6 +1109,7 @@ static void copy_skb_header(struct sk_bu
+@@ -1087,6 +1113,7 @@ static void copy_skb_header(struct sk_bu
        skb_shinfo(new)->gso_segs = skb_shinfo(old)->gso_segs;
        skb_shinfo(new)->gso_type = skb_shinfo(old)->gso_type;
  }