bcm4908: enable Netgear R8000P bootloader image
authorRafał Miłecki <rafal@milecki.pl>
Thu, 8 Apr 2021 08:39:56 +0000 (10:39 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 8 Apr 2021 08:50:59 +0000 (10:50 +0200)
This enables building BCM4908 "raw" image that can be flashed using
bootloader web UI. It requires serial console access & stopping booting
by the "Press any key to stop auto run".

It's easy to build vendor like CHK image but it can't be safely flashed
using vendor UI at this point. Netgear implements method called "NAND
incremental flashing" that doesn't seem to flash bootfs partition as
provided.

Above method seems to update vmlinux.lz without updating 94908.dtb. It
prevents OpenWrt kernel from booting due to incomplete DTB file. Full
Netgear R8000P support can be enabled after finding a way to make vendor
firmware flash OpenWrt firmware including the 94908.dtb update.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm4908/image/Makefile

index 8a2d4dc17410b481ffa6bedb9e855f1aeda8d465..426db4c5a67f63393ec659ae5376e6acc1968179 100644 (file)
@@ -48,6 +48,7 @@ define Device/Default
   DEVICE_IMG_NAME = $$(DEVICE_IMG_PREFIX)-$$(1).$$(2)
   BLOCKSIZE := 128k
   PAGESIZE := 2048
+  IMAGE/bin := append-ubi | bcm4908img
 endef
 
 define Device/asus_gt-ac5300
@@ -67,11 +68,10 @@ define Device/netgear_r8000p
   DEVICE_VENDOR := Netgear
   DEVICE_MODEL := R8000P
   DEVICE_DTS := broadcom/bcm4908/bcm4906-netgear-r8000p
-  IMAGES := chk
+  IMAGES := bin
   IMAGE/chk := append-ubi | bcm4908img | netgear-chk
   NETGEAR_BOARD_ID := U12H359T00_NETGEAR
   NETGEAR_REGION := 1
-  BROKEN := y
 endef
 TARGET_DEVICES += netgear_r8000p