boost: use user-config.jam instead of site-config.jam
authorFelix Fietkau <nbd@openwrt.org>
Fri, 6 Jul 2012 09:23:03 +0000 (09:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 6 Jul 2012 09:23:03 +0000 (09:23 +0000)
On some machines the build ignores site-config.jam and proceeds doing a native build.
To catch such errors earlier, set the architecture in the gcc toolset

SVN-Revision: 32631

libs/boost/Makefile

index c2460391742283ff671097f170973fcf8372420b..d10a5206229953c6cf9bbd530c54563d3146c7ee 100644 (file)
@@ -185,15 +185,15 @@ TARGET_LDFLAGS += -pthread -lrt
 
 define Build/Compile
        ( cd $(PKG_BUILD_DIR) ; \
-               echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS)\" <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > tools/build/v2/site-config.jam ; \
+               echo "using gcc : $(ARCH) : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS)\" <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > tools/build/v2/user-config.jam ; \
                $(if $(CONFIG_PACKAGE_boost-python), \
                        echo "using python : : $(STAGING_DIR_ROOT)/usr/bin/python :     $(STAGING_DIR)/usr/include/python2.7/ ;" >> \
-                               tools/build/v2/site-config.jam; \
+                               tools/build/v2/user-config.jam; \
                ) \
                bjam \
                        '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
                        $(filter -j%,$(PKG_JOBS)) \
-                       --toolset=gcc --build-type=minimal --layout=system \
+                       --toolset=gcc-$(ARCH) --build-type=minimal --layout=system \
                        --disable-long-double \
                        $(CONFIGURE_ARGS) \
                        $(if $(CONFIG_PACKAGE_boost-chrono),,--without-chrono) \