Merge pull request #927 from jeenu-arm/state-switch
authordavidcunado-arm <david.cunado@arm.com>
Thu, 11 May 2017 15:04:52 +0000 (16:04 +0100)
committerGitHub <noreply@github.com>
Thu, 11 May 2017 15:04:52 +0000 (16:04 +0100)
Execution state switch

15 files changed:
1  2 
bl1/aarch64/bl1_context_mgmt.c
bl31/bl31_main.c
include/lib/aarch64/arch.h
include/lib/aarch64/arch_helpers.h
include/lib/el3_runtime/context_mgmt.h
include/lib/psci/psci_lib.h
include/plat/arm/common/arm_sip_svc.h
include/plat/arm/common/plat_arm.h
lib/el3_runtime/aarch64/context_mgmt.c
lib/psci/psci_common.c
plat/arm/common/arm_common.c
plat/arm/common/arm_common.mk
plat/arm/common/arm_sip_svc.c
plat/mediatek/mt6795/bl31_plat_setup.c
plat/qemu/qemu_bl2_setup.c

index 7069ed6481d4d04ad33eee255f2fc696f3e9bba5,d226f61a0e8266563a7c9830369e33472c683b50..2c7fe0705ffa0f7fc5c7d65cfb8285fef0673c75
@@@ -1,7 -1,31 +1,7 @@@
  /*
-  * Copyright (c) 2015-2016, ARM Limited and Contributors. All rights reserved.
+  * Copyright (c) 2015-2017, ARM Limited and Contributors. All rights reserved.
   *
 - * Redistribution and use in source and binary forms, with or without
 - * modification, are permitted provided that the following conditions are met:
 - *
 - * Redistributions of source code must retain the above copyright notice, this
 - * list of conditions and the following disclaimer.
 - *
 - * Redistributions in binary form must reproduce the above copyright notice,
 - * this list of conditions and the following disclaimer in the documentation
 - * and/or other materials provided with the distribution.
 - *
 - * Neither the name of ARM nor the names of its contributors may be used
 - * to endorse or promote products derived from this software without specific
 - * prior written permission.
 - *
 - * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
 - * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 - * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 - * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
 - * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
 - * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
 - * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
 - * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
 - * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
 - * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
 - * POSSIBILITY OF SUCH DAMAGE.
 + * SPDX-License-Identifier: BSD-3-Clause
   */
  
  #include <arch_helpers.h>
Simple merge
Simple merge
Simple merge
Simple merge
index bbfd4daf85a815673659faa13095187f5bd83c6b,f3eac31854d93cacb2051904a5b2c0c124bb0626..68375afaedf37957378e34f977e44f26e620ce4b
@@@ -1,7 -1,31 +1,7 @@@
  /*
-  * Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+  * Copyright (c) 2016-2017, ARM Limited and Contributors. All rights reserved.
   *
 - * Redistribution and use in source and binary forms, with or without
 - * modification, are permitted provided that the following conditions are met:
 - *
 - * Redistributions of source code must retain the above copyright notice, this
 - * list of conditions and the following disclaimer.
 - *
 - * Redistributions in binary form must reproduce the above copyright notice,
 - * this list of conditions and the following disclaimer in the documentation
 - * and/or other materials provided with the distribution.
 - *
 - * Neither the name of ARM nor the names of its contributors may be used
 - * to endorse or promote products derived from this software without specific
 - * prior written permission.
 - *
 - * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
 - * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 - * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 - * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
 - * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
 - * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
 - * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
 - * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
 - * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
 - * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
 - * POSSIBILITY OF SUCH DAMAGE.
 + * SPDX-License-Identifier: BSD-3-Clause
   */
  
  #ifndef __ARM_SIP_SVC_H__
Simple merge
Simple merge
Simple merge
Simple merge
index 90997e32148057ec2532cff3d7494852850ec376,62a2ef55ecb7a657667cc50a8f3fb836f983f50b..7fe61019e28c1e92e76be811dfcfe0953c2de6ae
@@@ -1,7 -1,31 +1,7 @@@
  /*
-  * Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+  * Copyright (c) 2016-2017, ARM Limited and Contributors. All rights reserved.
   *
 - * Redistribution and use in source and binary forms, with or without
 - * modification, are permitted provided that the following conditions are met:
 - *
 - * Redistributions of source code must retain the above copyright notice, this
 - * list of conditions and the following disclaimer.
 - *
 - * Redistributions in binary form must reproduce the above copyright notice,
 - * this list of conditions and the following disclaimer in the documentation
 - * and/or other materials provided with the distribution.
 - *
 - * Neither the name of ARM nor the names of its contributors may be used
 - * to endorse or promote products derived from this software without specific
 - * prior written permission.
 - *
 - * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
 - * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 - * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 - * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
 - * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
 - * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
 - * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
 - * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
 - * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
 - * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
 - * POSSIBILITY OF SUCH DAMAGE.
 + * SPDX-License-Identifier: BSD-3-Clause
   */
  
  #include <arm_sip_svc.h>
index 2a4a7ed7c528acef9123e2dee4ffe36557223b3a,1ba8b1450ec04ecc669f456008b7810e24da3df9..a70d10311331e7c9be06e059d52678773aec5c42
@@@ -1,7 -1,31 +1,7 @@@
  /*
-  * Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+  * Copyright (c) 2016-2017, ARM Limited and Contributors. All rights reserved.
   *
 - * Redistribution and use in source and binary forms, with or without
 - * modification, are permitted provided that the following conditions are met:
 - *
 - * Redistributions of source code must retain the above copyright notice, this
 - * list of conditions and the following disclaimer.
 - *
 - * Redistributions in binary form must reproduce the above copyright notice,
 - * this list of conditions and the following disclaimer in the documentation
 - * and/or other materials provided with the distribution.
 - *
 - * Neither the name of ARM nor the names of its contributors may be used
 - * to endorse or promote products derived from this software without specific
 - * prior written permission.
 - *
 - * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
 - * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 - * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 - * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
 - * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
 - * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
 - * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
 - * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
 - * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
 - * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
 - * POSSIBILITY OF SUCH DAMAGE.
 + * SPDX-License-Identifier: BSD-3-Clause
   */
  #include <arm_gic.h>
  #include <assert.h>
Simple merge