backport: increase max stack frame size compiler check to 1280
authorLuca Coelho <luciano.coelho@intel.com>
Sun, 18 Feb 2018 13:24:58 +0000 (15:24 +0200)
committerJohannes Berg <johannes.berg@intel.com>
Fri, 23 Feb 2018 11:34:50 +0000 (12:34 +0100)
The verification code has some large data variables that are allocated
in the stack.  Increase the maximum stack frame size in the compiler
check slightly (from 1024 to 1280) to prevent harmless warnings.

Signed-off-by: Luca Coelho <luciano.coelho@intel.com>
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
backport/compat/Makefile

index 5c79b9b849cb34da3a6596428298ec7dd99132fb..ac70aaf82fccec7f3ea18a3050b6c4b8827a2ab6 100644 (file)
@@ -1,4 +1,4 @@
-ccflags-y += -I$(src)
+ccflags-y += -I$(src) -Wframe-larger-than=1280
 ifeq ($(CONFIG_BACKPORT_INTEGRATE),)
 obj-m += compat.o
 else