uhub: libevent fixes
authorJohn Crispin <john@openwrt.org>
Fri, 3 Aug 2012 09:15:21 +0000 (09:15 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 3 Aug 2012 09:15:21 +0000 (09:15 +0000)
SVN-Revision: 32955

net/uhub/Makefile

index 5a8f5f356eea207698555f8129fcc258b9e4c432..2614a0ab7b92198830fb0b5b7e44e5ae5b0b3ea8 100644 (file)
@@ -21,7 +21,7 @@ define Package/uhub
   SUBMENU:=P2P
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent2 +USE_EGLIBC:librt
+  DEPENDS:=+libevent +USE_EGLIBC:librt
   TITLE:=High performance ADC hub
   URL:=http://www.extatic.org/uhub/
 endef
@@ -32,6 +32,9 @@ define Package/uhub/description
         on high-end servers, or a small private hub on embedded hardware.
 endef
 
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/libevent
+TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib/libevent
+
 ifdef CONFIG_USE_EGLIBC
 TARGET_LDFLAGS += -lrt
 endif