ath79: mikrotik: fix build error with kernel 6.1
authorKoen Vandeputte <koen.vandeputte@citymesh.com>
Wed, 20 Sep 2023 13:02:40 +0000 (15:02 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 6 Oct 2023 19:53:13 +0000 (21:53 +0200)
drivers/mfd/rb4xx-cpld.c:167:19: error: initialization of 'void (*)(struct spi_device *)' from incompatible pointer type 'int (*)(struct spi_device *)' [-Werror=incompatible-pointer-types]
  167 |         .remove = rb4xx_cpld_remove,
      |                   ^~~~~~~~~~~~~~~~~
drivers/mfd/rb4xx-cpld.c:167:19: note: (near initialization for 'rb4xx_cpld_driver.remove')
cc1: some warnings being treated as errors
make[8]: *** [scripts/Makefile.build:250: drivers/mfd/rb4xx-cpld.o] Error 1
make[7]: *** [scripts/Makefile.build:500: drivers/mfd] Error 2
make[6]: *** [scripts/Makefile.build:500: drivers] Error 2
make[5]: *** [Makefile:2012: .] Error 2

As the allocated function does nothing, simply delete it.

Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
target/linux/ath79/files/drivers/mfd/rb4xx-cpld.c

index da18424c63383c563777e33fe156ceb5fdb8a082..148157aa7b71ba1ba2784bb5c92676b9b88e5d0b 100644 (file)
@@ -151,11 +151,6 @@ static int rb4xx_cpld_probe(struct spi_device *spi)
                                    NULL, 0, NULL);
 }
 
-static int rb4xx_cpld_remove(struct spi_device *spi)
-{
-       return 0;
-}
-
 static const struct of_device_id rb4xx_cpld_dt_match[] = {
        { .compatible = "mikrotik,rb4xx-cpld", },
        { },
@@ -164,7 +159,6 @@ MODULE_DEVICE_TABLE(of, rb4xx_cpld_dt_match);
 
 static struct spi_driver rb4xx_cpld_driver = {
        .probe = rb4xx_cpld_probe,
-       .remove = rb4xx_cpld_remove,
        .driver = {
                .name = "rb4xx-cpld",
                .bus = &spi_bus_type,