uml: merge r15119 to 8.09
authorNicolas Thill <nico@openwrt.org>
Tue, 28 Apr 2009 00:08:11 +0000 (00:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 28 Apr 2009 00:08:11 +0000 (00:08 +0000)
SVN-Revision: 15464

target/linux/uml/patches/002-gcc4_unfortify_source.patch [new file with mode: 0644]

diff --git a/target/linux/uml/patches/002-gcc4_unfortify_source.patch b/target/linux/uml/patches/002-gcc4_unfortify_source.patch
new file mode 100644 (file)
index 0000000..b13e5df
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+                       echo $(call cc-option,-fno-unit-at-a-time); \
+                       else echo $(call cc-option,-funit-at-a-time); fi ;)
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)