kernel: bump 5.4 to 5.4.194
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 17 May 2022 21:33:27 +0000 (21:33 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 17 May 2022 22:11:28 +0000 (00:11 +0200)
Compile-tested: lantiq/xrx200, armvirt/64
Run-tested: lantiq/xrx200, armvirt/64

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0441-PCI-of-Add-inbound-resource-parsing-to-helpers.patch
target/linux/generic/hack-5.4/902-debloat_proc.patch
target/linux/ipq806x/patches-5.4/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/ipq806x/patches-5.4/900-arm-add-cmdline-override.patch
target/linux/mvebu/patches-5.4/019-PCI-aardvark-Add-PHY-support.patch
target/linux/mvebu/patches-5.4/026-PCI-aardvark-Fix-initialization-with-old-Marvell-s-A.patch
target/linux/mvebu/patches-5.4/300-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/oxnas/patches-5.4/996-generic-Mangle-bootloader-s-kernel-arguments.patch

index aaef19eaefee83d0769ec7fffc77b2bd8d4b4eff..c3e904ae69b40e8ceea81f31b2951f9ff4e1bcbe 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .192
+LINUX_VERSION-5.4 = .194
 
-LINUX_KERNEL_HASH-5.4.192 = 32482e1152fb07b126180a374f5f7d14601bd13a50ab8cbb75465aa998da9e93
+LINUX_KERNEL_HASH-5.4.194 = 284157891929f26f34ddd4c447980c1ce364c78df4f89b64edeac8ff9a1d3df6
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 2c9ed3534cd5246a610b7d84bab57a121e1ffb53..08d0b1cb9a361ccd582914ce937fa331fe4f63e7 100644 (file)
@@ -82,7 +82,7 @@ Cc: linux-rockchip@lists.infradead.org
  
 --- a/drivers/pci/controller/pci-aardvark.c
 +++ b/drivers/pci/controller/pci-aardvark.c
-@@ -1523,7 +1523,8 @@ static int advk_pcie_probe(struct platfo
+@@ -1521,7 +1521,8 @@ static int advk_pcie_probe(struct platfo
                return ret;
        }
  
index 0309b3c3caa57e106a74da7b0fc5ac3f80a082db..afde1e88df446a29d3de1bad88940202a9b6474f 100644 (file)
@@ -246,7 +246,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                                &vmalloc_op,
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1988,10 +1988,12 @@ void __init init_mm_internals(void)
+@@ -1984,10 +1984,12 @@ void __init init_mm_internals(void)
        start_shepherd_timer();
  #endif
  #ifdef CONFIG_PROC_FS
index 33c77fb729fdae2aa1eefb3812f5694b3ed3c7a3..3a0695b5b90dc0a446950efcdb754964bc2644e7 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1828,6 +1828,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1824,6 +1824,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 17f20f068c642f2c31423ffb128853bdf7f913ce..87d7015ffc59a5ff903aeb15366e7fe30e40131f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1841,6 +1841,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_MANGL
+@@ -1837,6 +1837,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_MANGL
  
  endchoice
  
index 525d9ec794e0c69c55c6d1e6d373cc67ba0f3144..52ceed1b0298b8ed940080fb999264293b2220b8 100644 (file)
@@ -56,7 +56,7 @@ Cc: Miquèl Raynal <miquel.raynal@bootlin.com>
  #define PCIE_MSG_LOG_REG                      (CONTROL_BASE_ADDR + 0x30)
  #define PCIE_ISR0_REG                         (CONTROL_BASE_ADDR + 0x40)
  #define PCIE_MSG_PM_PME_MASK                  BIT(7)
-@@ -288,6 +291,7 @@ struct advk_pcie {
+@@ -289,6 +292,7 @@ struct advk_pcie {
        int link_gen;
        struct pci_bridge_emul bridge;
        struct gpio_desc *reset_gpio;
@@ -64,7 +64,7 @@ Cc: Miquèl Raynal <miquel.raynal@bootlin.com>
  };
  
  static inline void advk_writel(struct advk_pcie *pcie, u32 val, u64 reg)
-@@ -481,6 +485,11 @@ static void advk_pcie_setup_hw(struct ad
+@@ -482,6 +486,11 @@ static void advk_pcie_setup_hw(struct ad
        u32 reg;
        int i;
  
@@ -76,7 +76,7 @@ Cc: Miquèl Raynal <miquel.raynal@bootlin.com>
        /* Set to Direct mode */
        reg = advk_readl(pcie, CTRL_CONFIG_REG);
        reg &= ~(CTRL_MODE_MASK << CTRL_MODE_SHIFT);
-@@ -1493,6 +1502,62 @@ out_release_res:
+@@ -1491,6 +1500,62 @@ out_release_res:
        return err;
  }
  
@@ -139,7 +139,7 @@ Cc: Miquèl Raynal <miquel.raynal@bootlin.com>
  static int advk_pcie_probe(struct platform_device *pdev)
  {
        struct device *dev = &pdev->dev;
-@@ -1625,6 +1690,10 @@ static int advk_pcie_probe(struct platfo
+@@ -1623,6 +1688,10 @@ static int advk_pcie_probe(struct platfo
        else
                pcie->link_gen = ret;
  
index 5a6173a666ad09d770593211b6b64f4d70724de8..77df5a730553b5ee4957f48c4338f54b8589d058 100644 (file)
@@ -31,7 +31,7 @@ Cc: <stable@vger.kernel.org> # 5.8+: ea17a0f153af: phy: marvell: comphy: Convert
 
 --- a/drivers/pci/controller/pci-aardvark.c
 +++ b/drivers/pci/controller/pci-aardvark.c
-@@ -1526,7 +1526,9 @@ static int advk_pcie_enable_phy(struct a
+@@ -1524,7 +1524,9 @@ static int advk_pcie_enable_phy(struct a
        }
  
        ret = phy_power_on(pcie->phy);
index b6b3247c9d3158b28b8b798b1c05ccad46802b04..1595659aa7b0c189a95d2e466ea9e52849570667 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1828,6 +1828,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1824,6 +1824,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index bc46f308d39985656f295f23a1d360326acdf643..8a452fada18410ed7cfab8ea4f67c4d9bfd40b35 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1828,6 +1828,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1824,6 +1824,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.